Nombreux problèmes (admin w7, java...)

Tous les problèmes de Windows : message d'erreur, BSOD et écran bleu, erreur Windows Update ou d'installation, etc

Modérateur : Mods Windows

KtrocK

Nombreux problèmes (admin w7, java...)

par KtrocK »

Bonjour,

J'ai un nouvel ordinateur sur lequel j'ai fréquemment installé windows 7, mais aujourd'hui alors que j'ai essayé d'utiliser Java je me suis rendu compte que c'était impossible!
Pourtant j'ai bien installé le plug-in firefox, mais rien à faire quand je rencontre du java sur le net le chargement se lance (le logo qui tourne avec la barre en bas), mais ne se charge pas d'un pourcent!
Même une application utilisant Java ne fonctionne pas.

On m'a dit que cela pouvait venir d'Avast et on m'a donné des fichiers à corriger dans Programmes. Or en voulant les coller, on me demande si je veux activer mes droits d'admin. Je dis oui, mais un message d'erreur me signale qu'il me faut l'autorisation d'Avast.
Je décide de vérifier mes droits d'admin (quand bien même je suis le seul compte du pc...) dans Executer avec net users administrateur /active:yes, la fenêtre de commande s'ouvre et se ferme aussitôt sans que je ne puisse rien lire.

Enfin voila, j'ai l'impression que rien ne va... J'ai eu des manips à droite à gauche pour m'aider, mais soit ça passait par des gestions d'utilisateurs dans "Ordinateur => Gérer" et je ne voyais pas ce qu'il fallait modifier, soit c'était dans "Panneau de Configuration => Outil d'Administration" et là encore il me manque le panneau que je suis censé ouvrir dans ces outils.

C'est assez gênant comme problème qui engendre un problème qui engendre un problème :/
Je ne comprend pas, jusqu'à présent j'ai pu installer mes logiciels sans soucis...

Et je n'ai cet ordinateur que depuis une semaine, j'ai tout mis tout à jour...
KtrocK

Re: Nombreux problèmes (admin w7, java...)

par KtrocK »

Bonjour,
J'espère que l'absence de réponse est due au fait que personne ne sait comment m'aider, parce que si c'est pour mauvaise localisation du topic sachez que je ne l'ai pas créé dans la sous-catégorie windows 7 à cause de mon autre problème de java :(

Donc depuis j'ai continué mes recherches et il semblerait en réalité que mon pouvoir d'admin est efficace, c'est juste avast qui se laissait pas faire.
Le principal problème est alors Java.
Et je peux vous dire que je commence à désespérer tant j'ai l'impression d'avoir tout essayé...
Étant dans un windows 64bits j'ai installé les versions hors ligne 64bits, puis la version 32 bits, puis un test avec les deux versions installées en même temps...
Mais lors de ces tests j'ai remarqué une chose: Java 32 bits s'installe toujours dans "Program Files (x86)". Or pour ma tentative avec les deux Java j'aurai aimé avoir Java64 dans Program Files x86, et Java32 dans le simple Program Files!
Rien à faire, quand je modifie le dossier de destination lors de l'installation, j'ai beau préciser "Program Files\Java\jre7", les dossiers se créent mais restent vide et Java file dans Progam Files x86...
D'ailleurs un détail me turlupine: lorsque je valide la destination, cela affiche bien " [...]\jre7" alors que dans la proposition de base ça se termine en "[...]\jre7\" avec un antislash à la fin. Mais comme je dois choisir le dossier avec la fonction Parcourir je n'ai aucun moyen de rajouter un antislash quand je choisis mon dossier.

Enfin voila, plein de configurations d'installation différentes, entre temps je désinstalle à chaque fois le programme via le panneau de configuration, je supprime les dossiers manuellement, j'efface les registres et les fichiers d'appli' avec CCleaner et je redémarre... Mais rien n'y fait.
(Mis à part que le nettoyage des registres m'a bousillé quelques raccourcis sur mon bureau mais ça c'est une autre histoire...)

J'aimerai vraiment faire fonctionner Java, ça me rend fou j'ai beau tout essayer il se refuse à fonctionner...
SkyTech

Re: Nombreux problèmes (admin w7, java...)

par SkyTech »

Bonjour,
KtrocK a écrit :On m'a dit que cela pouvait venir d'Avast et on m'a donné des fichiers à corriger dans Programmes. Or en voulant les coller, on me demande si je veux activer mes droits d'admin. Je dis oui, mais un message d'erreur me signale qu'il me faut l'autorisation d'Avast.
Jusque là c'est normal qu'avast! se "protège", pourquoi ne pas juste le désactiver pour tester ?
KtrocK a écrit :Mais lors de ces tests j'ai remarqué une chose: Java 32 bits s'installe toujours dans "Program Files (x86)". Or pour ma tentative avec les deux Java j'aurai aimé avoir Java64 dans Program Files x86, et Java32 dans le simple Program Files!
Le Program Files x86 est l'environnement de compatibilité pour les programmes 32 bits, tu peux donc pas installer la version 64 bits dedans et de même pour la version 32 bits dans Program Files.

Java fonctionne sous Internet Explorer ?

Si non je pense que tu peux tester en modifiant $PATH : http://www.commentcamarche.net/forum/af ... ava-64bits
Test avec le chemin d'installation de l'une ou l'autre version, avec un redémarrage pour prendre en compte la modification.
KtrocK

Re: Nombreux problèmes (admin w7, java...)

par KtrocK »

Merci pour ta réponse!
Devant bouger de mon domicile pour les fêtes de fin d'années je ne suis pas sûr d'avoir le temps de tester cela rapidement mais je vous tiendrai au courant des résultats!

Du coup en fait j'avais compris l'inverse au niveau des dossiers de Programmes! J'espère que les installations dans les bons dossiers régleront les problèmes :)
KtrocK

Re: Nombreux problèmes (admin w7, java...)

par KtrocK »

Bonsoir!
Hélas si je n'ai plus donné de nouvelles ce n'est pas parce que le problème est résolu mais parce que je n'étais pas chez moi et donc que je ne pouvais pas effectuer de test...
Mais je viens de retrouver mon ordinateur et j'ai installé les bonnes versions de Java dans les bons dossiers!

Cette fois pas d'erreur directes, mais...Ceci... (voir le screen en pièce jointe)
Sur tous les navigateurs, même problème : un rectangle gris s'affiche lorsque je teste java, et après un long moment l'erreur que l'on peut voir sur Mozilla s'affiche (mais mozilla avait également le rectangle gris auparavant).
Est-ce qu'à force de faire des tests dans le mauvais sens auparavant j'ai déréglé certaines choses?
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Windows : Résoudre les problèmes »