[Résolu]faire reconnaitre un cdrom ?

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

salut peripetie,
tu as installé Xubuntu? Parce que si tu préfères utiliser XFCE, je te conseille fortement d'installer cette version.
Pour lancer une appli et pouvoir fermer ensuite le terminal :

Code : Tout sélectionner

xfce4-panel &
On dirait que tu as des plugins qui merdoient. Tu as essayé de virer du panneau (j'ai pas dit via le terminal, hein) le plugin de son et de tracé CPU pour voir. Tu dois avoir accés au son dans le menu si tu en as besoin, mais je ne sais plus où exactement.

Donc, tu as viré gdm, bien bien bien… Tu vas donc le réinstaller si tu veux avoir ton écran habituel de connexion. Si tu veux garder startx, c'est bien aussi.
EDIT : tu avais peut-être gdm2. Fait une recherche en console pour voir si gdm2 est encore là :

Code : Tout sélectionner

aptitude search gdm
Je ne sais pas ce que tu as viré pour que tu aies le footware, mais je dirais qu'il fallait le garder. Le thème gtk n'y est pour rien, j'ai l'impression que tu as un souci de largeur de bordure sur le plugin cpugraph.

Par contre pour Grub, je ne comprends pas pourquoi tu n'as pas le choix de boot. Tu as "GRUB_TIMEOUT="10"" donc 10 secondes d'attente. Windows ne dois pas avoir été détecté, ça arrive rarement, mais ça arrive.
Tu vas relancer sa détection:

Code : Tout sélectionner

sudo os-prober
Tu regardes ce qu'il te trouve et sur quelle partition. Tu relances ensuite la génération du fichier de grub

Code : Tout sélectionner

sudo update-grub
Par contre, si tu viens d'installer et que ton install est déjà boiteuse, tu perdras moins de temps à réinstaller qu'à réparer.

La suite, la suite… @+
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Hello Lætitia,

Oui, j'ai bien gravé et installé Xubuntu. KDE en jette mais je préfère Xfce.

Réinstaller je veux bien, mais plusieurs choses me freinent encore:
- L'image que j'ai gravé (qui n'est pas live cdrom) est - me semble-t-il - doté d'un autre outil que GParted. Il est confus, et comme je voudrais pas casser Windows encore un coup...
- j'ai installé Xubuntu plusieurs fois sur ce disque dur, et j'ai chaque fois des problèmes récurrents PLUS de nouveaux problèmes. Je pense donc qu'un nettoyage de la partition s'impose. Soit depuis Xubuntu (J'ai vu un outil pour cela quelque part), soit avant réinstallation.
- Et puis à tant qu'à faire de bricoler...

Je parle récurrence car pour cette réinstallation je te jure que je n'ai pas bricolé dans tous les sens ! J'ai ramené sources.list, installé Chromium, mis quelques modules dedans ainsi que dans Firefox, j'ai installé Akregator, Wine, Amarok, un jeu (trackballs) et 2-3 bricoles: GrubCustomiser... Je n'ai pas touché à gnome, mais il me semble omniprésent: mes icônes ont changé, ainsi que mon menu d'application et ça me rappelle furieusement quand il était là ! Je ne l'ai pourtant pas installé cette fois-ci !!!
L'impression que j'ai c'est que Xubuntu lis d'anciennes instructions sur le disque dur.

D'ailleurs gdm:

Code : Tout sélectionner

aptitude search gdm
c   gdm                             - GNOME Display Manager                     
p   gdm-guest-session               - extension à gdm pour la session invité    
v   gdm-theme                       -                                           
p   gdmap                           - Outil pour visualiser l'espace disque     
p   kdm-gdmcompat                   - Provide basic gdm functionality to systems
p   liblcgdm-dev                    - LCG Data Management common development fil
p   liblcgdm1                       - LCG Data Management common libraries      
p   mythbuntu-gdm-theme             - Mythbuntu GDM theme                       
p   peace-gdm-theme                 - Peace look - GDM theme                    
p   sabily-gdm-themes               - Sabily GDM themes                         
p   tropic-gdm-theme                - Tropic look - GDM theme                   
p   ubuntume-gdm-themes             - Sabily GDM themes (transitional package)  
p   ubuntustudio-gdm-theme          - Ubuntu Studio - GDM theme                 
c   xubuntu-gdm-theme               - Xubuntu GDM & Xsplash greeter themes
Amarok ne marchait pas. Ou plutôt il ne me passait qu'un seul auteur quelque soit le format de ses fichiers MP3 ou OGG. Mais je sais Amarok difficilement compatible avec gnome
Dès que j'ai vu Xubuntu chanceler j'ai viré Amarok. Puis Exaile (ah oui: Exaile est par default dans Xubuntu) qui ne marchait plus non plus.

Sinon le son ça va: Je l'ai sur les vidéos.

Grub ça va aussi. Je peux démarrer sur Windows. Mais oui Grub est arrangé. La photo, la définition d'image, des couleurs, et les entrées inutiles c'est moi.
Mais là encore l'impression qu'il lit celui qui est dessous qui était déjà arrangé: Timeout=10 c'est l'ancien grub ! Ne serait-ce point un souci du coté de la partition ces lectures sous-jacentes ?

Là je dois démarrer en console, ce qui fait que je n'ai plus de session invité sans mot de passe, je dois faire apparaitre le panel qui est blanc lavasse, et le terminal est étrange: par exemple le "&" ne la referme pas ni la console non plus. Et il ne rend plus la main ainsi: Autre bizarrerie: la touche CTRL + ALT + F7 ne me sort pas de la console (c'est CTRL + ALT + F8 qui m'en sort) mais me fait maintenant apparaitre l'écran de démarrage de xubuntu, qui reste là eternellement sans jamais rien démarrer.
Là encore un souvenir de gnome !

En bref j'ai l'impression de naviguer entre deux partitions...

Voilà pour le footware du moment. Désolé de faire des post de cette longueur
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

salut,
bon, bah "gdm" est supprimé mais ses fichiers de conf sont encore là. Tu peux le réinstaller si tu veux.

Code : Tout sélectionner

sudo aptitude install gdm
Du coup, le "Ne serait-ce point un souci du coté de la partition ces lectures sous-jacentes" me laisse penser que tu n'as peut-être pas formater la partition sur laquelle tu as installé "/" vu que tu as galéré au partitionnement.
Regarde, sur ma capture, j'ai coché le formatage
Image
Surtout, ne formate pas "/home"
Si tu veux vraiment être sûr de repartir sur des bases saines, tu formates "/" en livecd. Et tu réinstalles. Ça m'est arrivé une fois d'oublier de formater "/" avant. J'avais un beau footware comme le tien.

Tu as eu tes images sur cette page http://cdimage.ubuntu.com/xubuntu/relea ... 2/release/ Tu as installé via un alternate?
Xubuntu pour le 64 bits
http://cdimage.ubuntu.com/xubuntu/relea ... -amd64.iso
Xubuntu pour le 32 bits
http://cdimage.ubuntu.com/xubuntu/relea ... p-i386.iso
Les MD5SUM http://cdimage.ubuntu.com/xubuntu/relea ... se/MD5SUMS

@+
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Yep !

Oui je croix bien reconnaitre cette page http://cdimage.ubuntu.com/xubuntu/relea ... 2/release/, et j'y ai effectivement pris Lucid en 64 bits. L'outil de partitionnement est loin d'être clair, et il y manque même sûrement quelque chose puisqu'il m'a fait un swap de 1.5 G alors que ma ram est de 4 G !?!!

Image

Je vais donc le retélécharger sur ton lien, retrouver GParted; mais deux cdrom cette année, qui plus est le même mois la maison ne recule devant aucun sacrifice !
Comme tu le vois je suis en dual-boot. Moi c'est /dev/sda5 ?

Quand à gde, plus il sera loin, mieux je me porterais. Il est encore beaucoup trop présent

Voilà ! Te remercie et te donne des news bientôt

<edit> C'est réinstallé. Mais c'est formaté avant. Reste à attendre un peu car le footware arrive plus tard...
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Bon bin ça se remet tout doucement à vaciller...

Cette fois c'est différent des autres. Au démarrage j'ai vu que Xubuntu avait mis le deskop en anglais. Les titres des fenêtres restent en français mais leur contenu est en anglais.
Dans le "langage support" je vois le français, il est installé, mais il reste grisé, je ne peux pas le sélectionner. Sinon le système est à jour mais disons que quelques paquets ne peuvent être chargés à chaque fois

Code : Tout sélectionner

Failed to fetch http://ppa.launchpad.net/mozilla/firefox-next/ubuntu/dists/lucid/main/binary-amd64/Packages.gz  404  Not Found
Some index files failed to download, they have been ignored, or old ones used instead.
Rien qui ne concerne le langage, ni même rien de critique me semble-t-il ?
Par instants aussi la connections wifi se coupe te se reconnecte plusieurs fois de suite. Mais peut-être alentour un backtrack cherche-t-il à chopper le handscape de ma box ^^
Aussi j'ai trouvé une session invité avec un mot de passe, ce qui n'était pas le cas, et la langue du correcteur orthographique dans Firefox désélectionnée m'enfin tout ça semble remédié.

Je pense que le jeu "Trackballs" faisait bien beuguer l'interface, même avec le paquet de débeugage. Alors je l'ai viré complètement. Mais le mal est peut-être fait maintenant... Je ne croix pas encore à un footware de lectures de vieilles partitions.

Mais je me pose aussi des questions quand à mon SWAP de 1.5Go en regard de ma Ram de 4Go. Dois-je l'agrandir ?

Si tu as quelques infos je veux bien. Je te promet de me documenter et de ne rien toucher en attendant
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

salut,
je passe en coup de vent. J'essaierai de repasser demain.
Ça donne quoi :

Code : Tout sélectionner

locale
@+
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Bonsoir Laetitia, merci d'être passée, même en coup de vent

Code : Tout sélectionner

locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr
LANGUAGE=fr:en
LC_CTYPE="fr"
LC_NUMERIC="fr"
LC_TIME="fr"
LC_COLLATE="fr"
LC_MONETARY="fr"
LC_MESSAGES="fr"
LC_PAPER="fr"
LC_NAME="fr"
LC_ADDRESS="fr"
LC_TELEPHONE="fr"
LC_MEASUREMENT="fr"
LC_IDENTIFICATION="fr"
LC_ALL=
La dégradation est nettement moins marquée que les autres fois mais néanmoins.
Au démarrage beaucoup de choses s'écrivent que je n'ai pas le temps de lire. Je vais essayer de faire des photos.
La connexion se coupe parfois toutes les minutes-minutes et demi et se ré-établit. Un redémarrage arrange souvent les choses.
Une partie de la mémoire n'est pas gardée: par exemple la clé WPA dans la session invité et d'autres petites choses. Mais je ne perd plus le presse-papier en milieu de session, c'est déjà ça
La connexion wifi se coupe parfois et se reconnecte aussitôt

En bref il y a du mieux mais ce n'est pas encore ça, et c'est toujours quand tout est réinstallé que ça émerge. Je souhaite voir si je peux réparer (mais le code plus haut ne me dis rien qui vaille...) mais si c'est trop de job je sauve le home, le source.list, et puis je ne sais plus lequel et je reformate tout.

En tous cas merci pour ce que tu fais. Passe un joyeux réveillon
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

bonjour,
bonne année à toi. Plein de geekeries & pas de bug.

Ah wé, t'as de l'anglais qui se balade. Essaie de reconfigurer les locales

Code : Tout sélectionner

dpkg-reconfigure locales
C'est quand même bizarre que tu aies toujours des trucs qui merdoient, même après une install' fraîche. Y4a un truc qu'on maîtrise pas et qui met l'footware.

@+
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Yep Lætitia, meilleurs vœux à toi aussi,

Code : Tout sélectionner

dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "fr:en",
	LC_ALL = (unset),
	LANG = "fr"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure must be run as root
Donc:

Code : Tout sélectionner

sudo su
[sudo] password for philippe: 
[email protected]:/home/philippe# dpkg-reconfigure locales
Generating locales...
  en_US.UTF-8... done
  fr_BE.UTF-8... up-to-date
  fr_CA.UTF-8... up-to-date
  fr_CH.UTF-8... up-to-date
  fr_FR.UTF-8... up-to-date
  fr_LU.UTF-8... up-to-date
Generation complete.
J'ai redémarré mais toujours en anglais.
Je t'attendais un peu pour savoir:
- si l'utilisation de la commande

Code : Tout sélectionner

fsck
avec peut-être le cdrom
- ou la réinstalation de Xubuntu desktop,
pouvait apporter quelque chose.
la situation ne s'est pas trop dégradé plus depuis que j'ai désinstallé le jeu beugeur "Trackballs". Toutefois le presse-papier qui ne révèle pas son contenu, et Drupal qui ne veut absolument pas démarrer dans lampp.
Les éléments restent sur le bureau lorsqu'on les fait glisser dans un dossier - en clair ils sont copiés - mais peut-être cela est-il normal ?
L'écran de veille Ubuntu avait disparu, il est revenu tout seul !

Je cherche aussi de mon coté mais je t'attends avant de faire quoi que ce soit. Je tiens à m'excuser d'être tous les jours ta corvée du jour mais je patauge et j'ai vraiment besoin.
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

salut,
meuh non, t'es pas une corvée. C'est sympa d'aider les autres. :)
Donc, rien de mieux en reconfigurant.

Que donne :

Code : Tout sélectionner

 cat /etc/environment

Code : Tout sélectionner

cat /etc/default/locale

Code : Tout sélectionner

aptitude search ~ilanguage-pack-fr
@+
peripetie

Re: [Résolu]faire reconnaitre un cdrom ?

par peripetie »

Yep Lætie,

Code : Tout sélectionner

cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANGUAGE="fr_FR:fr"
LC_MESSAGES="fr_FR.UTF-8"
LANG="fr_FR.UTF-8"

Code : Tout sélectionner

cat /etc/default/locale
LANG="fr_FR.UTF-8"
LANGUAGE="fr:en"
LC_MESSAGES="fr_FR.UTF-8"

Code : Tout sélectionner

aptitude search ~ilanguage-pack-fr
i A language-pack-fr                - translation updates for language French   
i A language-pack-fr-base           - translations for language French
J'ai regardé du coté des locales, et j'ai modifié aujourd'hui à coup de gksudo mousepad le fichier /etc/environment qui recelait une ligne juste FR et aussi un fr:en. Mais là je vais attendre de lire ce que tu en penses.

Moi aussi j'aime bien aider. Il vaut mieux d'ailleurs sur ce réseau où la gratuité est norme, où on est à des bornes, et où le coup de main ne peut-être que désintéressé.
Tout ça pour dire que si le café que je voudrais au moins t'offrir doit rester virtuel il ne faudra pas m'en vouloir; mais ça tu le sais déjà mieux que moi mais ça me fait du bien de le dire.

<edit>
Je suis mort de rire !
Et bien oui: Ubuntu parle de nouveau français. Et sais-tu comment cela s'est-il fait ?
Allons, allons, je suis sûr que tu le sais...
Et bien en redémarrant la session !
J'ai constaté - mais je l'avais déjà remarqué - que l'on pouvait choisir la langue à ce moment. Il y a donc là l'anglais, l'allemand (que j'avais installé pour essayer de switcher la langue) et... plusieurs fois le français puisque j'ai tenté de le réinstaller. J'ai juste choisi Français (France) au lieu de français tout court et le tour était joué !
Voilà au moins un problème réglé. Encore quelques bricoles d'instabilité mais petit à petit je devrais y parvenir.
Je vais encore te remercier (je ne peux faire que cela).
Mais je ne m'éloigne pas trop...

A bientôt
<edit/>
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu]faire reconnaitre un cdrom ?

par Lætitia »

Champion du monde \o/

Cet Ubuntu m'étonnera toujours. Sinon, effectivement, il fallait supprimer la ligne LANGUAGE=\"fr:en\" de /etc/default/locale. Ou "sudo locale-gen fr_FR.utf8".

'fin bon, tant mieux si ça va. :)

@+
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »