[résolu] Comment ajouter un son pour une extension Firefox

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

Wullfk

[résolu] Comment ajouter un son pour une extension Firefox

par Wullfk »

Bonjour,

un problème chasse l'autre PDT_001 (enfin plutôt une manip que je ne sais pas faire sous GNU/Linux)

j'utilise dans Firefox l'extension Secure Login , il y a normalement la possibilité de mettre un son lorque l'on met son login et pwd préalablement enregistré (je l'utilise sans aucun problème sous Win7) hors quelques soit le son .wav que je mette, le son ne se produit pas.

est ce que quelqu'un aurait une explication et une solution à ça.

par avance merci

Amicalement ;)
Dernière modification par Wullfk le 22 mars 2011 15:31, modifié 1 fois.
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: Comment ajouter un son pour une extension Firefox

par Lætitia »

salut,
euh… je trouve pas PDT_013 Je n'en ai aucune idée. Peut-être que le son de base n'existe pas sous Ubuntu. Faudrait voir si ça le fait systématiquement sous Ff/Ubuntu.

@+
Wullfk

Re: Comment ajouter un son pour une extension Firefox

par Wullfk »

mouai , bizarre cette histoire.

sais tu ou se trouve (qu'elle fainéant je fais PDT_014 ) le répertoire des sons système?
étant donné que dans mon cas j'ai pris le son dans un dossier que j'ai importé d'une clé USB, et que j'ai mis dans mon /home/wullfk
je voudrais donc essayé avec un son qui se trouverais dans le répertoire système défini pour contenir les sons.

++
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: Comment ajouter un son pour une extension Firefox

par Lætitia »

salut,
les sons se trouvent dans "/usr/share/sounds/" Je ne sais pas quel est le format utilisé pour ce plugin.

@+
Wullfk

Re: Comment ajouter un son pour une extension Firefox

par Wullfk »

J'ai comme une vague intuition que c'est du flash, et ce serait la raison pour laquelle cela ne focntionnerai pas, j'ai pu lire d'ici de là qu'il y existait aussi quelques problèmes avec PulseAudio
maintenant reste à savoir à qui la faute : Flash ou Pulse ?
dans "/usr/share/sounds/ je ne visualise aucun fichier son !
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: Comment ajouter un son pour une extension Firefox

par Lætitia »

Bah merdum alors.
T'as pas les dossiers de sons Ubuntu/stereo entre autre dans ce répertoire ? Je crois qu'il y a plusieurs dossiers sons. Mais depuis Karmic, ça a pas mal changé du côté du son.

@+
Wullfk

Re: Comment ajouter un son pour une extension Firefox

par Wullfk »

Bonjour,

problème résolu, ça venais d'une incompatibilité avec PulseAudio, réparer en installant esound :

Code : Tout sélectionner

sudo apt-get install esound
cela désinstalle PulseAudio et les notifications sonore dans les extensions Firefox ou la notification des mails dans Thunderbird fonctionne.

j'ai enfin pu résoudre ce problème PDT_018

Je clos le sujet.

Salut PDT_019
captnfab

Re: [résolu] Comment ajouter un son pour une extension Firef

par captnfab »

Nice, bien joué et merci pour le retour :)
Wullfk

Re: [résolu] Comment ajouter un son pour une extension Firef

par Wullfk »

Salut CaptainFab

hum! un peu bizarre tout de même, car aujourd'hui au premier démarrage du netbook pas de son fonctionnel pour l'extension Secure Login dans Firefox 4.0 je précise que l'extension est compatible. du coup je vérifie que esound soit bien installé, pas de problème à ce niveau, je tente le parie audacieux de remettre PulseAudio (faire et défaire c'est toujours travailler), je refais quelques tests toujours rien, en fait c'est pas que je n'ai rien du tout, mais cela fait comme si le son voulais démarrer mais qu'il ne peut pas. PDT_014
enfin bref, je vérifie quelques packages sur le plugin flash , et je reboot, et la à nouveau sa fonctionne!!!!

finalité de la chose, c'est qu'en fin de compte installer esound peut "peut être" résoudre le problème, mais c'est pas garantie à 100%

bon on va patienter jusqu'à la sortie d'UBUNTU 11.04 qui sait certaines choses auront été optimiser, j'en doute pas, c'est l'avantage de l'OpenSource.

@+ ;)
Wullfk

Re: [résolu] Comment ajouter un son pour une extension Firef

par Wullfk »

Bonjour,

Je confirme ce que j'ai dit dans le post précédent, et pour cause sur une des configs desktop (celle ou j'ai installé Ubuntu sur un SSD), le problème est plus coriace que ce que je pensais.
sur cette fameuse config, qu'il y ai ou pas esound ou PulseAudio, que le plugin Flash Player soit lui aussi à jour, le phénomène est somme toute bizarre, à savoir qu'il m'est impossible de lire un fichier .wav si celui ci est en PRM 8bits , pire encore il n'est pas possible d'ouvrir les propriétés du fichier, car cela ferme le dossier et me fait revenir sur le bureau, et rien de plus.

Je précise que tout mes packages sont à jour.
je soupçonne une incompatibilité matériel, sachant que la CM est une ASUS MAXIMUS EXTREM et que par défaut la carte son fournis avec est une FX ,carte fille sur port PCIE 1x

donc résultat 2/3 configs qui fonctionnent.

@+ ;)
captnfab

Re: [résolu] Comment ajouter un son pour une extension Firef

par captnfab »

Pour ton problème de .wav, que se passe-t-il si tu essayes de lire ça depuis un terminal avec mplayer ?

Je ne le répèterai jamais assez mais, dès qu'il s'agit de débugguer, ou même de comprendre ce qu'il se passe, le terminal est tellement plus simple...

NB: si tu n'as pas mplayer: aptitude install mplayer
Wullfk

Re: [résolu] Comment ajouter un son pour une extension Firef

par Wullfk »

Salut CaptnFab,

je te dirais ce qu'il en est ce soir, car la je suis au taff avec mon netbook.

je ne te contredirai pas sur l'utilité du terminal, et je suis parfaitement conscient quand passant par lui on élimine tout ce qui est sur-couche de l'interface graphique, c'est d'autant plus utile lorsqu'il s'agit de débuggage. le problème c'est qu'il faut savoir sans servir, la c'est une autre histoire.

par contre si ça peut être utile, j'ai lancé cette commande

Code : Tout sélectionner

gkdbg
de tête j'ai un doute sur l'écriture exact de la commande. j'ai pas mes notes devant moi
pour visualiser si j'avais des erreurs, n'ayant pas le pc sous les yeux en ce moment, je ne peut te détailler le résultat, mais après tout le descriptif concernant la config, il y avait effectivement des lignes d'erreurs, mais pas compréhensible à mon niveau de connaissance.

@+ ;)
Wullfk

Re: [résolu] Comment ajouter un son pour une extension Firef

par Wullfk »

captnfab a écrit :Pour ton problème de .wav, que se passe-t-il si tu essayes de lire ça depuis un terminal avec mplayer ?
je suis chez moi , comment je lance la commande pour écouter le fichier, via le terminal?

car en fait y a des sons que je peux écouter et d'autre non, la vérification est vite faite, puisqu'il suffit que je laisse le pointeur de la souris sur le fichier .wav pour savoir si la lecture se fait ou pas.

j'ai pas du tout ce problème sur les autres configs PDT_014

++
captnfab

Re: [résolu] Comment ajouter un son pour une extension Firef

par captnfab »

Bah, pour lire un fichier, mettons /home/ton_login/plouf/bla.mp3 , tu vas dans le dossier contenant le fichier

cd ~/plouf/

Puis tu lis le fichier

mplayer bla.mp3

En utilisant la complétion (avec tab) bien sûr, afin de minimiser le risque de faute de frappe.

Si le terminal te dis

-bash: mplayer : commande introuvable

C'est que mplayer n'est pas installé, ce que tu peux faire avec la commande suivante (en root):

aptitude install mplayer
Wullfk

Re: [résolu] Comment ajouter un son pour une extension Firef

par Wullfk »

Salut CaptnFab,

que de problème depuis mon dernier message, enfin rien de grave en soit.

le plus PDT_016 c'est d'avoir réussi à avoir un écran bleu (BSOD) sous GNU/Linux, et un peu de mal pour relancer Ubuntu
après avoir effectué une mise à jour avec demande de redémarrage, des que j'arrivais sur la fenêtre de démarrage d'Ubuntu (celle avec les petits points), paf (le chien) écran noir et reboot.
j'ai donc décidé d'avancer le nettoyage de printemps de ma tour.

pour l'instant ça fonctionne, pour combien de temps (I don't know ???)

en ce qui concerne les fameux fichiers .wav qui "déconne" ben j'ai guerre plus avancé, au mieux j'ai modifier mon choix de son pour l'extension de FF et là aussi ça vaut ce que ça vaut mais ça à l'air de tenir, je dis bien "ça à l'air" car des fois il suffit d'un reboot, et hop sa marche plus.

le plus frustrant si l'on peut dire c'est que ce même fichier son .wav fonctionne parfaitement sur les deux autres configs.

donc à suivre....
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »