[résolu]démarrage multiboot Win7/XP/UBUNTU

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

Wullfk

[résolu]démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

Bonjour,

je viens de franchir encore une étape (après mes quelques tests sur VM) je me lance dans le grand bain, en installant en dur UBUNTU 10.04 sur un HDD indépendant des autres OS.
L'installation c'est déroulé sans problème, avec installation de GRUB sur le disque ou est UBUNTU , mais pour l'instant j'ai pas accès à ma session
ben oui à la fin de l'installation, j'ai bien redémarrer comme c'est demandé, mais nada, pas de reboot, je fais donc un reboot manuel avec le bouton "reset" de mon pc, là j'obtiens bien l'écran d'accueil de ma CM ASUS P5B-Deluxe, puis après l'écran de sélection de l'OS , pour le moment UBUNTU n'apparait pas normal, j'ai pas configurer EASYBCD, je démarre donc sur mon OS par défaut Windows 7 32Bits , je télécharge la dernière version d'EASYBCD (2.0 bêta) puis je le configure pour qu'il prenne en charge UBUNTU et donc GRUB.
petit info tout de même dans Windows 7 les partitions propre à UBUNTU sont bien présente mais elle non aucune lettre d'attribué, je pense que c'est normale.
je ferme EASYBCD et je redémarre, je choisis UBUNTU sur l'écran de choix, ce dernier apparaissant bien maintenant, résultat depuis 10mn j'ai un écran noir avec un tout petit curseur qui clignote, mais rien d'autre.

donc la question est, que faire dans ce cas là.
dois je démarrer sur le liveCD d'UBUNTU pour aller modifier GRUB?

Merci d'avance de l'aide et des conseils que vous pourrez m'apporter

@+
Dernière modification par Wullfk le 24 mai 2010 16:00, modifié 1 fois.
Wullfk

Re: démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

hum!! bizarre, j'ai fait un démarrage sur le liveCD

dans un terminal j'ai lancé cette commande

Code : Tout sélectionner

sudo   fdisk  -l
(-L minuscule)
j'obtiens bien le détail de l'installation, mais point de GRUB à l'horizon

donc je décide d'aller plus loin dans ma recherche
afin de réinstaller le bootloader, je tape les cmd suivantes dans un terminal :

Code : Tout sélectionner

sudo  grub 

réponse

Code : Tout sélectionner

sudo  grub command not found
là je tape :
find /boot/grub/menu.lst
rien

je poursuis (tétu le bougre) et décide de réinstaller complétement UBUNTU en conservant strictement les mêmes paramètres :
./ = ext4 = 12Go
/swap = 2Go (je dispose de 2,50Go sur le PC à cause d'une barette RAM foireuse, sinon j'aurais 3Go (2x1024 + 2x512Mo)
/home = ext4 = 50Go
/tmp = ext4 = 4Go

à ce niveau là je sais pas si mes choix sont judicieux, en sachant que le HDD fait 250Go et qu'il est vierge

à la fin de l'installation, je demande via le bouton avancé que le bootloader soit installé sur la partition ./ (sdc1)
encore une fois je sais pas si c'est bien ça qu'il faut faire.

l'installation s'exécute normalement, puis viens le moment ou il faut redémarrer.
j'exécute, et j'obtiens sur un écran noir

Code : Tout sélectionner

[2316-149704] end_request : I/O error, dev sr0, sector 506992 
cette ligne ce répercutant jusqu'en bas de l'écran
je reboot à la "chacal" (touche reset de la tour) j'ai toujours mes trois choix de boot, je sélectionne UBUNTU 10.04 (le nom que j'ai attribué dans EASYBCD) et rebelote écran noir avec petit curseur clignotant en haut.

donc retour à la case départ.

voila si cela peut apporter plus de précision à mon problème.

++
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: démarrage multiboot Win7/XP/UBUNTU

par Lætitia »

salut Wullfk,
bien Grub est en sdc1.
Apparement, il y a un problème avec le périphérique sr0.
Tu as l'air d'être un peu mécano, peux tu tenter de débrancher ton lecteur cd. Ensuite, tu essaies de booter sur Ubuntu.

En liveCD, tu fais

Code : Tout sélectionner

sudo lshw
, tu sauvegardes le contenu sur une clef et tu postes le retour. On verra ce qu'il y a comme matériel.

Sur Lucid Lynx, tu as Grub2, son fichier de configuration se trouve en /Boot/grub/grub.cfg. Ce n'est pas ce fichier qu'on édite directement.
Un petit lien qui t'expliqueras comment fonctionne Grub2 http://www.linuxpedia.fr/doku.php/expert/grub2
Et oui toujours et encore de la lecture :)
Juste une mise en bouche avant que tu ne dévores «Simple comme Ubuntu» :lol:

Bon courage,
Wullfk

Re: démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

Bonjour Laetitia,

problème résolu. merci tout de même pour ton aide

j'avais une diskette vierge inséré dans le lecteur, à la base c'était pour créer une sauvegarde que propose EASYBCD , malheureusement cette sauvegarde refuse de se faire, j'obtiens un message d'erreur avec un charabia que je ne comprend pas.
bref, j'ai laissé tombé cette sauvegarde, mais j'ai omis de retirer la disquette du lecteur.

une fois découvert la chose, tout c'est rétablie normalement au boot suivant.
premier écran j'ai bien mes 3 choix d'OS , puis une fois que j'ai sélectionné UBUNTU 10.04 je démarre bien sur GRUB pour arriver à l'écran d'accueil de la session.
j'ai effectué les mises à jours système nécessaires, installer le dépôt Medibuntu
deb http://fr.packages.medibuntu.org/ hardy free non-free et sa clé GPG
conformément à ce qui est expliqué dans la documentation "Simple comme Ubuntu v 8.04"

tout comme celle prenant en charge ma CG ASUS NvIDIA 7600GS en sélectionnant le choix recommandé.
j'ai aussi installé Sun Java 6, ainsi que , que le plugin Flash pour Firefox. (Gnash SWF Player) pour rester dans la logique du libre

donc maintenant j'ai un "vrai" UBUNTU d'installer (en comparaison avec la VM que je conserve tout de même). il faut aussi que je configure les paramètres lièe à mon imprimante HP Photsmart Plus)
me reste plus qu'a me familiariser avec les différentes applications proposé (Evolution, OpenOffice, etc...) moi qui suis Windowsien de base, j'utilise actuellement et principalement Outlook, Office 2007 Pro.
y a que pour Firefox que cela ne me changera pas, puisque cela fait quelques temps déjà que je l'utilise, et que j'ai complètement délaissé IE8.
je compte installé tout de même un deuxième navigateur, OPERA .

Je peux clôturer ce fil (j'ai un bol inouï ou est ce de la perspicacité, car ça fait deux fois que je résout un problème tout seul, après avoir poster une demande d'aide, si tout pouvait être comme ça)
Wullfk

Re: démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

Sur Lucid Lynx, tu as Grub2, son fichier de configuration se trouve en /Boot/grub/grub.cfg. Ce n'est pas ce fichier qu'on édite directement.
Un petit lien qui t'expliqueras comment fonctionne Grub2 http://www.linuxpedia.fr/doku.php/expert/grub2
Et oui toujours et encore de la lecture :)
Laetitia,
c'est quoi la commande pour savoir quel version de GRUB j'ai sur UBUNTU 10.04, tu m'en à déjà parler je crois, mais j'ai bouffé l'infirmation.

@+
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: démarrage multiboot Win7/XP/UBUNTU

par Lætitia »

Wullfk a écrit : j'ai effectué les mises à jours système nécessaires, installer le dépôt Medibuntu
deb http://fr.packages.medibuntu.org/ hardy free non-free et sa clé GPG
Euh… c'est

Code : Tout sélectionner

deb http://fr.packages.medibuntu.org/ lucid free non-free
pour la 10.04.
Wullfk a écrit : je compte installé tout de même un deuxième navigateur, OPERA .
Tu fais du gringue à Sacles PDT_004
Wullfk a écrit : c'est quoi la commande pour savoir quel version de GRUB j'ai sur UBUNTU 10.04
Si tu as grub legacy,

Code : Tout sélectionner

apt-cache policy grub
Si tu as grub-pc (grub 2)

Code : Tout sélectionner

apt-cache policy grub-pc
L'une des 2 commandes te renverras un

Code : Tout sélectionner

Installé : (aucun)
. Ce que ce n'est pas le bon.
Sur Lucid, c'est grub-pc qui est installé.
Wullfk a écrit : Je peux clôturer ce fil (j'ai un bol inouï ou est ce de la perspicacité, car ça fait deux fois que je résout un problème tout seul, après avoir poster une demande d'aide, si tout pouvait être comme ça)
Qu'est ce que tu veux, c'est juste une question d'ondes positives qu'il y a sur le forum. Il fait beau, Mak a dû sortir ses grigris et amulettes en tout genre.

@+
Wullfk

Re: [résolu]démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

Re,

réponse un peu tardive, mais bon, je m'éclate :youpi: bien sur ce nouvel OS

Concernant le choix d'installer Opéra :fxlancepierre:
j'ai pas trouver de paquet pour l"installer.

et puis
Tu fais du gringue à Sacles
indirectement c'est lui qui ma inciter à l'essayer sur Windows PDT_018 , même si j'utilise encore majoritairement Firefox.

sinon pour

Code : Tout sélectionner

deb http://fr.packages.medibuntu.org/ lucid free non-free
:oops: effectivement, c'est bien ce que tu dis :merci: , moi je n'ai fait que reprendre ce qu'il y a dans la doc (UBUNTU v.8.04), et de ce fait c'est la version hardy qui est cité.
:bye2:
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [résolu]démarrage multiboot Win7/XP/UBUNTU

par Lætitia »

salut Wullfk,
Wullfk a écrit : Concernant le choix d'installer Opéra :fxlancepierre:
j'ai pas trouver de paquet pour l"installer.
Il est possible d'installer Opera via les dépôts Debian. Ça a l'air de bien fonctionner, bon.
En console, tu charges la clef de sécurité pour Opera:

Code : Tout sélectionner

wget -q http://deb.opera.com/archive.key -O- | sudo apt-key add -
Tu ajoutes le dépôt à ton /etc/apt/sources.list

Code : Tout sélectionner

deb http://deb.opera.com/opera/ lenny non-free
tu recharges les paquets:

Code : Tout sélectionner

sudo aptitude update
Et tu installes Opera:

Code : Tout sélectionner

sudo aptitude install opera
Je suis ravie de voir que tu aimes glisser sur la banquise. PDT_003 Amuse-toi bien ;)
@+
Wullfk

Re: [résolu]démarrage multiboot Win7/XP/UBUNTU

par Wullfk »

Salut Laetitia,

ben je vais certainement te décevoir, mais si tu viens à lire un post récent que je viens d'écrire, j'ai je crois réussi à planté UBUNTU, enfin le mot est peut être un peu trop fort concernant une distrib Linux.

du coup, plutôt que de mettre un pensement sur une jambe de bois, ben je suis en train de refaire l'installation d'UBUNTU, enfin juste le ./ j'ai pas modifier le /home, au pire si sa coince encore je referais tout (faire et défaire c'est toujours travaillé, isn't it)

entre temps j'avais réussi à installer OPERA. à bien configurer FF, Evolution, installer la Deskbar, Ubuntu Tweak (c'est peut son paramétrage qui ma retourné l'OS).

et paff le chien (lol)

donc je repars de zéro

Salut ;)
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [résolu]démarrage multiboot Win7/XP/UBUNTU

par Lætitia »

salut,
Wullfk a écrit : Ubuntu Tweak (c'est peut son paramétrage qui ma retourné l'OS).
Ah bah, ça c'est possible. Si tu peux t'en passer, c'est bien aussi.

@+
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »