Locales partiellement délocalisées (RESOLU)

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

eggregor

Locales partiellement délocalisées (RESOLU)

par eggregor »

Bonjour à tous, et particulièrement à toi Captain, parce que "les tous" me semblent clairsemés.

Je reviens donc sur mon souci des menus en anglais, qui est apparu comme règlé il y a quelques semaines, et qui s'est tout "redéfait" sans que je comprenne bien quand, comment, et pourquoi.

J'ai donc tout la-haut dans la barre des menus :
Applications - Places - System avec plus loin Thu Jan 14, 15.31 quand je rédige ce message
L'étrangeté commence si je clique "gauche" sur Applications par exemple, pour faire apparaitre les sous-menus :
Accessoires
Bureautique
Graphisme, et le reste = apparaissent bien en Français.

Mais dans la continuïté ( en passant si je fais un clic droit sur le "continuïté" que je viens d'écrire, le correcteur orthographique me propose des mots en Anglais ) si j'ouvre une application comme Gimp, celle-ci va apparaître entièrement en Anglais, ce qui pour une telle usine à gaz, me la rend tout à fait inutilisable.

Et si je clique "droit" sur Applications ou l'un de ses voisins, les propositions : help, edit menus etc, sont en Anglais.

A vrai dire presque toutes les applications sont en Anglais, à l'exception de Fotoxx qui s'ouvre bien en Français.
( Open Office est en anglais, abiword également, evolution itou, Icedove en Français par contre, il a dû accepter un paramétrage manuel.

Donc :
Les titres en Anglais
Les menus en Français
Les applications en Anglais

Et je ne trouve pas de possibilité de choisir le Français séparément dans les applications ! Je suppose que çà n'a pas lieu d'exister, et de toutes façons c'est pas le bon sens.

Autres détails :
Iceweasel est en Français, parce que je l'ai paramètré et qu'il a bien voulu suivre, par contre, bien que j'ai téléchargé le dictionnaire français, son correcteur orthographique reste donc en Anglais.

Epiphany, dont je ne me sers pas, est en Anglais bien que Edit > Preferences > Language soit paramétré (fr-fr,fr).

Je ne dis pas que j'y perds mon Latin UTF8, mais je pédale dans la semoule.

Dernier détail pour finir et en rigoler :
Applications > Bureautique > Dictionnaire ( tout çà en Français ) = S'ouvre sur Dictionary, ensuite :
Edit > Preferences = s'ouvre sur Dictionary préférence, avec dans le tableau :
o Dictionnaires Espagnol
o Dictionnaires Longdo Thaï-Anglais
o Serveur de dictionnaires par défaut ( tout çà également écrit en Français)

Si je sélectionne l'Espagnol par exemple et que je fais "remove", refus d'obtempérer.
Si je fais +add, même chose.

Quand tu passeras par la maison Captain, si tu as une formule magique ?
Dernière modification par eggregor le 17 janv. 2010 14:31, modifié 1 fois.
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Tu peux nous envoyer les fichiers /etc/locale.gen et /etc/gdm/locale.conf ? (Tu les copies sur ton bureau, les renommes en .txt et nous les envoies en pièce jointe)
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Tu es rapide Captain, je passais à vrai dire par acquis de conscience.

Copier sur le bureau ! encore faudrait-il que la machine veuille le faire.
Je te les mets ici, en expurgeant ce qui n'est pas "fr"
cat /etc/locale.gen
# This file lists locales that you wish to have built. You can find a list
# of valid supported locales at /usr/share/i18n/SUPPORTED, and you can add
# user defined locales to /usr/local/share/i18n/SUPPORTED. If you change
# this file, you need to rerun locale-gen.

# fr_FR ISO-8859-1
fr_FR.UTF-8 UTF-8 (pour info j'avais décommenté la ligne en éditant parce que dpkg-reconfigure locales ne marchait pas)
# [email protected] ISO-8859-15
cat /etc/gdm/locale.conf
#
# This is similar to a locale.alias file, but is not one. This file was
# autogenerated from the GNU libc locales source, with some editing.
#
French(France) fr_FR
French(France) [email protected]
French(France) fr_FR.UTF-8

Est-ce que çà t'éclaire ? PDT_041
captnfab

Re: Locales partiellement délocalisées

par captnfab »

eggregor a écrit :Est-ce que çà t'éclaire ? PDT_041
Je veux TOUT ! :)

et ce fichier aussi : /etc/default/locale

Pour copier les fichiers dans le home :

Code : Tout sélectionner

cp /etc/locale.gen localegen.txt
cp /etc/gdm/locale.conf localrgdm.txt
cp /etc/default/locale localedef.txt
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Plop,

De retour seulement. J'avais joué à l'ouvrier hier et j'ai eu un coup de pompe incroyable devant mon écran en fin d'après-midi.
J'essaie de comprendre ce que tu vas trouver dans une telle liste, mais je sais que tu vas trouver.
J'espère que je fais la bonne manip pour l'envoi des PJ.

Une chance de te connaître Captain !
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Bon, « malheureusement », tes fichiers de conf sont parfaitement bien remplis. Donc le problème est ailleurs.

L'idée est la suivante : GDM se charge (il est en français ou en anglais lui ?) Et une fois cela fait, il transmet à GNOME les informations sur les locales qu'il doit utiliser. Ensuite, gnome démarre. Reste à savoir où survient le pépin.

Alors, si la configuration des locales de GDM se fait à l'installation de celui-ci, on peut espérer régler le problème avec un :

Code : Tout sélectionner

sudo dpkg-reconfigure gdm
Je n'y crois guère, mais ça ne mange pas de pain :)

Sinon, est-ce que tu as essayé de change rla langue dans GDM au moment de taper ton nom d'utilisateur / mot de passe ?

Si ça n'est pas le cas, tu devrais essayer :) Et si tu as activé la connection automatique, tu peux la désactiver temporairement en lançant

Code : Tout sélectionner

sudo gdmsetup
Dis-moi déjà si ceci règle ton pb :)
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Plop Captain,
C'est sympa de te retrouver le matin, merci de ta fidélité.

Je te mets en PJ ce qui s'affiche dans le terminal concernant GDM, pas grand chose à en tirer je présume.
Donc GDM est bien en Français.
La transformation est assez récente puisqu'elle s'est opérée le 17 décembre quand j'avais ouvert un fil ici même, et après reconfiguration des locales en passant à UTF8.

A l'écran GDM :
Que je choisisse "langue par défaut, ou Français", puisque les 2 propositions existent est sans effet.

Que je coche "lancer le script Xclient" ou " GNOME" ne change rien non plus.

Voilà, je ne sais quoi ajouter, je file au marché voir l'arrivage des poissons.

A plus Captain.
Je corrige, la pièce jointe est restée dans le sas, je te la colle ci-dessous.
debian:/home/eggregor# gdmsetup
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

/usr/share/sounds/gnome/default/alerts/bark.ogg:

File Size: 13.3k Bit Rate: 197k
Encoding: Vorbis
Channels: 2 @ 16-bit
Samplerate: 48000Hz
Replaygain: off
Duration: 00:00:00.54

In:100% 00:00:00.54 [00:00:00.00] Out:26.0k [ | ] Hd:3.8 Clip:0
Done.
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
gdmsetup[15810]: Gtk-WARNING: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
debian:/home/eggregor# dpkg-reconfigure gdm
Scheduling reload of GNOME Display Manager configuration: gdm.
debian:/home/eggregor#
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Coucou Eggregor,

Hem, encore un truc qui pourrait influer sur la config des locales…
Est-ce que tu as modifié des fichiers dans /etc/X11/ ou dans /etc/X11/Xsession.d/ ?
Est-ce qu'il existe un fichier .xsession dans ton répertoire personnel (ton home) ?
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Hello,
Merci d'être passé, la réponse est non aux trois questions, du moins je n'ai pas créé intentionnellement des modifications, et il n'existe pas de fichier Xsession dans mon home.

Je te disais il y a peu, que j'ai relu le fil "install Sid avec debootstrap" où apparaissent en page 3 notamment ( sur la fin de page) constamment des messages lors des updates, qui évoquent "setting locale failed", je te le redonne pour mémoire :

perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Code : Tout sélectionner

Détail à tout hasard :
Tous les matins, apparait le petit bouton orange dans la zone de notification, signalant la disponibilité des mises à jour.
( Cà le fait sur cette machine et pas sur l'autre, va savoir )

Généralement j'ouvre un terminal et je fais aptitude update, puis full-upgrade et tous se passe sans encombre sauf bien sûr comme il y a peu avec les paquets cassés qui m'inquiétaient.

Il y a une quinzaine environ, j'ai cliqué sans réfléchir sur le bouton orange, et bien sûr le gestionnaire de mise à jour s'est ouvert.
Je me suis dit, après tout, je fais comme çà.
Mais après lancement, j'ai eu plein de messages à la noix, et quand j'ai cliqué sur détail, le même message ou presque le même que celui ci-dessus avec "setting locale failed", est réapparu. ( Prévoyant, j'ai enregistré)

Get:17 http://ftp.fr.debian.org sid/main make 3.81-7 [391kB]
Fetched 16.0MB in 59s (270kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Preconfiguring packages ...
Can not write log, openpty() failed (/dev/pts not mounted?)
Puis à la fin, certains paquets ne s'étaient pas installés, et restaient présent dans la liste.
Alors, j'ai ouvert le terminal, j'ai fait les manoeuvres habituelles de full-upĝrade : les paquets se sont installés, et le bouton s'est éteint.
Est-ce qu'il n'y a pas une piste à explorer dans ce truc ?

En réalité, l'install "debootstrap" s'est terminée début novembre.
Tout a fonctionné, sauf les menus en Français, et je suis resté convaincu que quelquechose manquait à l'appel dans l'install, le kernel ayant fixé notre attention assez durablement.

Et puis peu après, j'ai retrouvé tes chaussures sur le quai et je t'ai cru noyé dans le grand bassin, donc j'ai un peu laissé tomber cette affaire, mais la question reste d'actualité, manque-t-il un petit quelquechose dans la machine ?

Bon w-e Captain, je traverserai le forum à tout hasard, mais on a le temps !
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Ok, bon, on va revenir sur le problème du paquet « locales ».

alors, dans un terminal en root :

Code : Tout sélectionner

aptitude download locales
Ceci aura pour effet de télécharger le fichier locales_blabla.deb

Code : Tout sélectionner

dpkg --force-all -P locales
Ceci aura pour effet de désinstaller le paquet « locales » et de purger les fichiers de configuration.

Puis

Code : Tout sélectionner

dpkg -i locales_*
Qui installera le fichier locales_blabla.deb À l'installation, tu choisiras bien « fr_FR.UTF-8 » comme seul et unique locale, et tu la choisiras ensuite comme locale par défaut.
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Désolé Captain, encore une descente en ville qui m'a mangé l'après-midi.

J'ai fait tout ce que tu as dit, je te livre les résultats, mes yeux écarquillés n'y comprennent pas tout, mais il doit y avoir matière pour un loup de mer comme toi. je te refile le bébé.

debian:/home/eggregor# aptitude download locales
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu... Fait
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Prendre : 1 http://ftp.fr.debian.org sid/main locales 2.10.2-5 [4 752kB]
4 752ko téléchargés en 7s (641ko/s)
debian:/home/eggregor# dpkg --force-all -P locales
dpkg : locales : problème de dépendance, mais suppression comme demandé :
langupdate dépend de locales ; cependant :
Le paquet locales doit être supprimé.
openoffice.org-l10n-fr dépend de locales | belocs-locales-data | locales-all ; cependant :
Le paquet locales doit être supprimé.
Le paquet belocs-locales-data n'est pas installé.
Le paquet locales-all n'est pas installé.
language-env dépend de locales.
(Lecture de la base de données... 129237 fichiers et répertoires déjà installés.)
Suppression de locales ...
Purge des fichiers de configuration de locales ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Traitement des actions différées (« triggers ») pour « man-db »...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct
debian:/home/eggregor# dpkg -i locales_*
Selecting previously deselected package locales.
(Reading database ... 128671 files and directories currently installed.)
Unpacking locales (from locales_2.10.2-5_all.deb) ...
Setting up locales (2.10.2-5) ...
Generating locales (this might take a while)...
Generation complete.
Processing triggers for man-db ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "fr_FR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct

Marrant quand même, moitié français, moitié anglais !
Je ne fais pas d'interprétation incertaine, on a peut-être la bonne piste ?
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Bon, les locales se sont réinstallées, mais bizarrement, ne t'ont pas posées de questions pour l'installation on dirait ?

Donc regardons maintenant si le

Code : Tout sélectionner

sudo dpkg-reconfigure locales
fonctionne…
(tu choisis bien le fr_FR.utf8)
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Je pense que c'est un truc très bête Captain, que j'ai raconté plusieurs fois et qui n'est pas dans l'ordre des choses.

Il y a quelquechose de "dpkg" qui ne fonctionne pas.

Quand je tape la commande, j'ai bien une liste qui apparait, et avec flècjhe vers le bas j'arrive à fr_FR.UTF8 mais je n'arrive pas à le sélectionner :
Ou bien je ne trouve pas la bonne commande ? ou bien elle n'existe pas !

J'ai peut-être la berlue, mais je n'ai jamais été confronté à cette chose.
Si je fais "envoi" le message ci-dessous apparait, qui d'ailleurs change la sélection que j'avais faite l'autre jour en éditant le fichier locale.gen je crois, et en décommentant la ligne concernée.

C'est de là que vient le merdier, je le sens comme çà.


debian:/home/eggregor# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "[email protected]"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
Generation complete.

Je viens de faire un redémarrage et Iceweasel me dit qu'il n'arrive pas à restaurer la configuration précédente, normal je présume avec le [email protected] qui est réapparu.

Bon, un truc pas courant en Méditerranée : je vais cuisiner les couteaux que j'ai achetés ce matin, est-ce que çà te dit quelquechose Captain? Je fais une petite diversion vois-tu !
captnfab

Re: Locales partiellement délocalisées

par captnfab »

Pour sélectionner, tu fais « espace », ensuite, tu fais tab pour arriver sur « [OK] » et tu valides par « entrée » :)
eggregor

Re: Locales partiellement délocalisées

par eggregor »

Pataplouf,

Merci Captain, le pire c'est que je l'avais appris comment sélectionner, mais que j'étais incapable de le retrouver.
Quelle galère le vieillissement !

Donc reconfiguration des locales faite fr_FRUTF8 sélectionné sur les deux questions posées.

debian:/home/eggregor# locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Pour autant je n'observe pas de grands changements.
Les titres de la barre menus restent en anglais, les menus en français, et les applications en anglais.

J'ai fait un restart, je vais quand même tenter un vrai reboot, si çà bouge je reviens te le dire.
EDIT:
Cà ne marche pas, mais il s'est passé un phénomène bizarre, après l'écran GDM, où je n'ai rien modifié, je me suis retrouvé avec le bureau Gnome, et une barre de menus tout la-haut qui ne comportait plus que Applications, Places, System, la vignette du terminal et le bouton "éteindre", ma souris avait bien son pointeur qui bougeait mais plus moyen de cliquer pour ouvrir quoique ce soit.
J'ai balisé un peu ! j'ai eu peur d'avoir aussi un problème clavier.

J'ai arrêté la bécane avec les "touches magiques" et au redémarrage j'ai coché session Gnome sur l'écran GDM, il a fallu plus de temps que d'habitude, mais tout s'est remis en place ( en anglais comme dab )

En fait quand j'ai fait le 1er arrêt, il y a eu une ligne rouge "Failed" mais je n'ai pas eu le temps de lire, ni de stopper le défilement.
Pas de doute que les locales m'auront (nous auront) donné du soucis.

Bon dimanche.
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »