Paquet cassé, paquet conflit ( RESOLU )

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

eggregor

Paquet cassé, paquet conflit ( RESOLU )

par eggregor »

Bonjour,
J'ai vu Captain, que je croyais flottant sur les mers du Sud, que tu es de retour, quoique "flanant" sur les pontons.

Je vais une fois encore abuser de ton savoir, voilà le truc qui me préoccupe, en lançant un upgrade :
( SID noyau 2.6.30-2-amd64 )
Les paquets suivants sont CASSÉS :
xserver-xorg-core

Les paquets suivants ont des dépendances non satisfaites :
xserver-xorg-core: Est en conflit avec: xserver-xorg-video-5 qui est un paquet virtuel

Cà dure depuis une semaine grosse moto.

Alors j'ai lu et relu pas mal de fils à doite et à gauche sans trouver de solution.
A vrai dire si ! des tas de solutions qui se disent et se contredisent, au point que je n'ose plus vraiment tenter les codes qui sont parfois indiqués.

Le même problème est apparu sur l'autre machine ( SID noyau 2.6.31-1-686 )
Cà concerne aussi xserver-xorg-core avec le même conflit, mais il y a aussi tout un micmac entre epiphany et d'autres choses.

En fait je n'arrive pas à trouver une doc précise sur les paquets cassés, les conflits et les dépendances non-satisfaites.

Si tu as un peu de temps ?
Dernière modification par eggregor le 14 janv. 2010 15:04, modifié 1 fois.
captnfab

Re: Paquet cassé, paquet conflit

par captnfab »

Bonsoir Eggregor,

Eh bien, je n'ai pas énormément de temps en ce moment (je vogue sur la grande blanche du sud au nord, du nord au sud…) mais je passe qd même environs une fois par jour sur le forum.

Alors, tout d'abord, ne t'en fais pas, j'ai aussi ces messages d'aptitude à propos de paquets cassés.

Pour connaître la liste des paquets cassés :

Code : Tout sélectionner

aptitude search ~b
Normalement, tu ne vas avoir aucune réponse. En effet, les messages d'aptitude signifie que « Si tu mettais tout à jour, tu aurais des conflits, mais que pour éviter ça, tu ne vas mettre que certains paquets à jour. » Donc finalement, pas de mal.

Pour te donner une idée de ce que me propose la mise à jour :
$ sudo aptitude full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu... Fait
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants sont CASSÉS :
xserver-xorg-core
Les paquets suivants seront mis à jour :
xserver-xorg xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-video-intel xserver-xorg-video-nv
8 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 3 585ko d'archives. Après dépaquetage, 426ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
xserver-xorg-core: Est en conflit avec: xserver-xorg-input-4 qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

Conserver les paquets suivants dans leur version actuelle :
xserver-xorg [1:7.4+4 (testing, now)]
xserver-xorg-core [2:1.6.5-1 (testing, now)]
xserver-xorg-input-evdev [1:2.2.5-1 (testing, now)]
xserver-xorg-input-kbd [1:1.3.2-4 (testing, now)]
xserver-xorg-input-mouse [1:1.4.0-4 (testing, now)]
xserver-xorg-input-synaptics [1.2.0-2 (testing, now)]
xserver-xorg-video-intel [2:2.9.1-1 (testing, now)]
xserver-xorg-video-nv [1:2.1.14-2 (testing, now)]

Tier: Annuler toutes les actions utilisateur (20000)

Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.
Donc bon, il n'y a pas grand chose à faire sinon d'attendre que les paquets qui bloquent arrivent dans sid. Pendant ce temps, tu peux toujours faire les mises à jour (taper Y pour accepter la solution) du moment qu'il ne te désinstalle rien au passage.

En revanche, si ton « aptitude search ~b » te renvoie quelque chose, alors là il y a un problème. Que l'on tentera de résoudre :)
eggregor

Re: Paquet cassé, paquet conflit

par eggregor »

Plop captain,

Jockey, je pratique comme tu dis en laissant les mises à jour se faire incomplètement, et je n'ai pas de réponse avec aptitude search -b, donc patience comme tu dis.

Il y a aussi des messages qui apparaissent lors de upgrades, dont je ne connais et ne trouve pas le sens, tels :

Tier: Annuler toutes les actions utilisateur (20000)
Tier: Actions sures (10000)
Les paquets suivants sont recommandés mais ne seront pas installés : Que faut-il faire ?

Et puis exemple ce matin, gros téléchargement upgrade sur SID32, qui va peut-être avoir réglé les paquets cassés avec d'ailleurs l'arrivée du noyau 2.6.32-trunk-686, que faut-il comprendre de ce message final ?

Etat actuel : 50 mises à jour restantes [ - 95 ]

Je cherche une réponse depuis un moment, mais je ne suis jamais "tombé" sur une explication.

Bonne journée captain, merci de ton aide et, à l'occasion dis-moi ce que tu appelles la grande blanche, je vois bien l'axe nord-sud mais la piste ne me dis rien.
captnfab

Re: Paquet cassé, paquet conflit

par captnfab »

eggregor a écrit :Plop captain,
Jockey, je pratique comme tu dis en laissant les mises à jour se faire incomplètement, et je n'ai pas de réponse avec aptitude search -b, donc patience comme tu dis.
Attention, ça n'est pas « moins b » : '-b' c'est « tilde b » : '~b'
eggregor a écrit :Il y a aussi des messages qui apparaissent lors de upgrades, dont je ne connais et ne trouve pas le sens, tels :
Tier: Annuler toutes les actions utilisateur (20000)
Tier: Actions sures (10000)
Les paquets suivants sont recommandés mais ne seront pas installés : Que faut-il faire ?
Ce sont les solutions que te propose aptitude pour mettre à jour partiellement ton système :)
eggregor a écrit :Et puis exemple ce matin, gros téléchargement upgrade sur SID32, qui va peut-être avoir réglé les paquets cassés avec d'ailleurs l'arrivée du noyau 2.6.32-trunk-686, que faut-il comprendre de ce message final ?

Etat actuel : 50 mises à jour restantes [ - 95 ]
Ben, c'est plutôt une bonne chose. Sur les 145 mises à jour que tu pouvais faire, il t'en a fait 95 et il n'en reste donc plus que 50.

Tu peux m'envoyer le résultat de

Code : Tout sélectionner

aptitude search ~U
(là aussi c'est un tilde, et le U est en majuscule) s'il te plaît ? Il s'agit là de la liste des paquets pour lesquels il existe une version plus récente.

J'aimerai bien aussi avoir le message renvoyé par

Code : Tout sélectionner

aptitude -s -y full-upgrade
(à faire juste après un sudo aptitude update)
eggregor a écrit :Bonne journée captain, merci de ton aide et, à l'occasion dis-moi ce que tu appelles la grande blanche, je vois bien l'axe nord-sud mais la piste ne me dis rien.
Je me suis fait Marseille - Paris en TGV, et tout du long, les fenêtres ne me montraient que du blanc, du blanc et encore du blanc. L'axe Nord-Sud enneigé depuis Aix en Provence jusqu'à Paris (et sans doute plus haut…), j'avais l'impression de voguer sur une grande mer de neige !
eggregor

Re: Paquet cassé, paquet conflit

par eggregor »

Bien content d'apprendre que ce ~ s'appelle tilde, mais ma vue baisse il faut bien l'admettre.

Voilà les résultats depuis la Sid64B, je vais les imprimer et regarder ce que donnent les commande sur la 32B,
A plus Captain, je suis content de te savoir en forme à faire du toboggan à la SNCF.

debian:/home/eggregor# aptitude search ~b
debian:/home/eggregor# aptitude search ~U
i A xserver-xorg - serveur X X.Org
i xserver-xorg-core - Serveur X X.Org - base du serveur
i A xserver-xorg-input-evdev - X.Org X server -- evdev input driver
i A xserver-xorg-input-kbd - Serveur X X.Org - pilote de clavier
i A xserver-xorg-input-mouse - Serveur X X.Org - pilote de souris
i A xserver-xorg-video-apm - X.Org X server -- APM display driver
i A xserver-xorg-video-ark - X.Org X server -- ark display driver
i A xserver-xorg-video-ati - X.Org X server -- ATI display driver wrapp
i A xserver-xorg-video-chips - X.Org X server -- Chips display driver
i A xserver-xorg-video-cirrus - serveur X X.Org -- pilote d'affichage Cirr
i A xserver-xorg-video-fbdev - X.Org X server -- fbdev display driver
i A xserver-xorg-video-i128 - X.Org X server -- i128 display driver
i A xserver-xorg-video-i740 - X.Org X server -- i740 display driver
i A xserver-xorg-video-intel - X.Org X server -- Intel i8xx, i9xx display
i A xserver-xorg-video-mach64 - X.Org X server -- ATI Mach64 display drive
i A xserver-xorg-video-mga - X.Org X server -- MGA display driver
i A xserver-xorg-video-neomagic - X.Org X server -- Neomagic display driver
i A xserver-xorg-video-nv - X.Org X server -- NV display driver
i A xserver-xorg-video-r128 - X.Org X server -- ATI r128 display driver
i A xserver-xorg-video-radeon - X.Org X server -- ATI Radeon display drive
i A xserver-xorg-video-radeonhd - X.Org X server -- AMD/ATI r5xx, r6xx displ
i A xserver-xorg-video-rendition - X.Org X server -- Rendition display driver
i A xserver-xorg-video-s3 - X.Org X server -- legacy S3 display driver
i A xserver-xorg-video-s3virge - X.Org X server -- S3 ViRGE display driver
i A xserver-xorg-video-savage - X.Org X server -- Savage display driver
i A xserver-xorg-video-siliconmotio - X.Org X server -- SiliconMotion display dr
i A xserver-xorg-video-sis - X.Org X server -- SiS display driver
i A xserver-xorg-video-sisusb - X.Org X server -- SiS USB display driver
i A xserver-xorg-video-tdfx - X.Org X server -- tdfx display driver
i A xserver-xorg-video-trident - Server X X.Org -- pilote d'affichage Tride
i A xserver-xorg-video-tseng - X.Org X server -- Tseng display driver
i A xserver-xorg-video-v4l - X.Org X server -- Video 4 Linux display dr
i A xserver-xorg-video-vesa - X.Org X server -- VESA display driver
i A xserver-xorg-video-vmware - X.Org X server -- VMware display driver
i A xserver-xorg-video-voodoo - Server X X.Org -- pilote d'affichage Voodo
debian:/home/eggregor# aptitude update
Atteint http://ftp.fr.debian.org sid Release.gpg
Atteint http://mirror.home-dn.net sid Release.gpg
Atteint http://mirror.home-dn.net sid/main Translation-fr
Atteint http://mirror.home-dn.net sid Release
Atteint http://ftp.fr.debian.org sid/main Translation-fr
Atteint http://mirror.home-dn.net sid/main Packages/DiffIndex
Ign http://ftp.fr.debian.org sid/contrib Translation-fr
Ign http://ftp.fr.debian.org sid/non-free Translation-fr
Atteint http://ftp.fr.debian.org sid Release
Atteint http://ftp.fr.debian.org sid/main Packages/DiffIndex
Atteint http://ftp.fr.debian.org sid/contrib Packages/DiffIndex
Atteint http://ftp.fr.debian.org sid/non-free Packages/DiffIndex
Lecture des listes de paquets... Fait

debian:/home/eggregor# aptitude -s -y full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu... Fait
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants sont CASSÉS :
xserver-xorg-core
Les paquets suivants seront mis à jour :
xserver-xorg xserver-xorg-input-evdev xserver-xorg-input-kbd
xserver-xorg-input-mouse xserver-xorg-video-apm xserver-xorg-video-ark
xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus
xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-nv xserver-xorg-video-r128
xserver-xorg-video-radeon xserver-xorg-video-radeonhd
xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis
xserver-xorg-video-sisusb xserver-xorg-video-tdfx
xserver-xorg-video-trident xserver-xorg-video-tseng
xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vmware
xserver-xorg-video-voodoo
35 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 6 030ko d'archives. Après dépaquetage, 217ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
xserver-xorg-core: Est en conflit avec: xserver-xorg-video-5 qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

Conserver les paquets suivants dans leur version actuelle :
xserver-xorg [1:7.4+4 (now)]
xserver-xorg-core [2:1.6.5-1 (now)]
xserver-xorg-input-evdev [1:2.2.5-1 (now)]
xserver-xorg-input-kbd [1:1.3.2-4 (now)]
xserver-xorg-input-mouse [1:1.4.0-4 (now)]
xserver-xorg-video-apm [1:1.2.1-2 (now)]
xserver-xorg-video-ark [1:0.7.1-2 (now)]
xserver-xorg-video-ati [1:6.12.3-1 (now)]
xserver-xorg-video-chips [1:1.2.1-3 (now)]
xserver-xorg-video-cirrus [1:1.3.1-1 (now)]
xserver-xorg-video-fbdev [1:0.4.0-4 (now)]
xserver-xorg-video-i128 [1:1.3.2-1 (now)]
xserver-xorg-video-i740 [1:1.3.0-1 (now)]
xserver-xorg-video-intel [2:2.9.1-1 (now)]
xserver-xorg-video-mach64 [6.8.2-1 (now)]
xserver-xorg-video-mga [1:1.4.11.dfsg-1 (now)]
xserver-xorg-video-neomagic [1:1.2.3-1 (now)]
xserver-xorg-video-nv [1:2.1.14-2 (now)]
xserver-xorg-video-r128 [6.8.1-1 (now)]
xserver-xorg-video-radeon [1:6.12.3-1 (now)]
xserver-xorg-video-radeonhd [1.2.5-1 (now)]
xserver-xorg-video-rendition [1:4.2.1-1 (now)]
xserver-xorg-video-s3 [1:0.6.2-1 (now)]
xserver-xorg-video-s3virge [1:1.10.2-2 (now)]
xserver-xorg-video-savage [1:2.3.0-1 (now)]
xserver-xorg-video-siliconmotion [1:1.7.2-1 (now)]
xserver-xorg-video-sis [1:0.10.1-2 (now)]
xserver-xorg-video-sisusb [1:0.9.1-1 (now)]
xserver-xorg-video-tdfx [1:1.4.1-1 (now)]
xserver-xorg-video-trident [1:1.3.1-1 (now)]
xserver-xorg-video-tseng [1:1.2.1-1 (now)]
xserver-xorg-video-v4l [0.2.0-3 (now)]
xserver-xorg-video-vesa [1:2.2.1-1 (now)]
xserver-xorg-video-vmware [1:10.16.7-1 (now)]
xserver-xorg-video-voodoo [1:1.2.2-1 (now)]

Tier: Annuler toutes les actions utilisateur (20000)

Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 35 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Charger/installer/enlever des paquets.

PS : J'ai laissé tombé mais j'ai toujours des soucis avec les locales.

Après que tout se soit mis en français en décembre, quand j'ai réouvert un fil sur cet aspect, le système s'est remis les jours suivants, tout seul, à un mélange curieux de français/anglais.
Je pense que çà se redéfait lors des mises à jour, de certaines mises à jour.

Pour la petite histoire j'ai relu hier le plus gros de ce qu'avaient été nos échanges sur le fil "install Sid avec debootstrap, bref pépins", ce qui m'a fait une fois encore apprécier a posteriori la patience dont tu as fait preuve.

Cette lecture m'a permis de redécouvrir que durant la partie la plus longue de nos échanges, couvrant les commandes avortées pour l'installation du kernel, il était tout le temps question des "locales failed", et si elles le sont moins aujourd'hui, elles portent quand même encore un petit quelquechose qui débloque.

Mais bon, çà ne m'empêche pas de fonctionner et çà m'oblige à survivre en english un minimum.
eggregor

Re: Paquet cassé, paquet conflit

par eggregor »

Plop Captain,
État actuel : 0 mise à jour restante [-4].
L'affaire est règlée donc ?
Plus de paquet cassés ni en situation conflictuelle.

Il faut c'est certain, s'habituer à Sid qui passe d'une situation où tout roule impec, à un embrouillamini ( j'ai bien dit ) inextricable pour un petit bras dans mon genre.
Cà vient doucement Captain, je te dérangerai encore un jour ou l'autre, mais je continue de progresser.

Je mettrai Résolu demain.
captnfab

Re: Paquet cassé, paquet conflit

par captnfab »

Plop Eggregor,
Désolé, je suis un peu pris en ce moment :)
eggregor a écrit :
État actuel : 0 mise à jour restante [-4].
L'affaire est règlée donc ?
Voui :)
eggregor a écrit :Plus de paquet cassés ni en situation conflictuelle.

Il faut c'est certain, s'habituer à Sid qui passe d'une situation où tout roule impec, à un embrouillamini ( j'ai bien dit ) inextricable pour un petit bras dans mon genre.
Ça vient doucement Captain, je te dérangerai encore un jour ou l'autre, mais je continue de progresser.
Effectivement, il faut le temps ! Mais tu progresses très vite, crois-moi ;)

En tout cas, même si nous ne te répondons pas toujours aussi vite que nous le souhaiterions, tu es toujours le bienvenu par ici !

Pour tes locales, si tu veux faire un nouveau sujet pour récapituler ce qui est fait, ce qui est installé, ce qui marche, ce qui ne marche pas… :)
eggregor

Re: Paquet cassé, paquet conflit

par eggregor »

Merci Captain,
Je vais effectivement ouvrir un fil sur le problème des locales, parce que certaines applications sont ingérables en Anglais pour moi.
Je mets résolu sur ce fil et j'arrive par la fenêtre du salon.
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »