[Nouveau noyau] Erreur à l'installation ( résolu )

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

Jejewen

[Nouveau noyau] Erreur à l'installation ( résolu )

par Jejewen »

Bonjour,

alors voilà, depuis quelques jours, aptitude essaie à chaque utilisation de configurer le paquet linux-image-2.6.30-2-686, qui d'après lui est partiellement installé.

Seulement cette configuration n'a jamais réussi :

Code : Tout sélectionner

Paramétrage de linux-image-2.6.30-2-686 (2.6.30-8squeeze1) ...
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.30-2-686
Running update-grub.
User postinst hook script [update-grub] failed to execute: Aucun fichier ou dossier de ce type
dpkg : erreur de traitement de linux-image-2.6.30-2-686 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 255
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-2.6.30-2-686
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation : 
Paramétrage de linux-image-2.6.30-2-686 (2.6.30-8squeeze1) ...
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.30-2-686
Running update-grub.
User postinst hook script [update-grub] failed to execute: Aucun fichier ou dossier de ce type
dpkg : erreur de traitement de linux-image-2.6.30-2-686 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 255
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-2.6.30-2-686
Lecture des listes de paquets... Fait             
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait       
J'ai testé un aptitude reinstall, ça ne change rien non plus, j'ai les mêmes messages d'erreurs.

J'ai pas d'autres infos, j'ai jeté un oeil à la page du paquet sur packages.debian mais ça ne m'a pas aidé.

Merci d'avance à ceux qui peuvent m'aider.
Dernière modification par Jejewen le 11 déc. 2009 21:12, modifié 1 fois.
captnfab

Re: [Nouveau noyau] Erreur à l'installation ( en cours )

par captnfab »

Yop Jejewen,
Tu as sans doute hérité d'un paquet un peu foireux, ou peut-être que le problème est lié à la mise à jour de grub…

Assure toi de démarrer sur un autre noyau que linux-image-2.6.30-2-686 (vérifie avec « uname -r » pour connaître le noyau en cours).

Puis essaye de purger le paquet :

Code : Tout sélectionner

sudo aptitude purge linux-image-2.6.30-2-686
Après, il faut quand même que l'on regarde s'il n'y a pas un problème avec update-grub.

Pour me donner la liste des paquets installés :

Code : Tout sélectionner

aptitude search ~igrub
A priori, tu devrais avoir grub-common et grub-pc.
Grub-pc installe update-grub dans /usr/sbin/

Tu peux sans risque lancer la commande

Code : Tout sélectionner

sudo update-grub
Pour vérifier que tout se passe bien.

S'il y a un problème, réinstall grub-pc et grub-common et réessaye d'installer ton 2.6.30-2 :)
Jejewen

Re: [Nouveau noyau] Erreur à l'installation ( en cours )

par Jejewen »

Bon, j'ai trouvé ma connerie en suivant ta procédure : en fait, grub-pc n'était pas installé.

J'ai rectifié ça, l'installation du noyau a ensuite très bien marché :

Code : Tout sélectionner

jejewen-laptop:/home/jejewen# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.30-2-686
Found initrd image: /boot/initrd.img-2.6.30-2-686
Found linux image: /boot/vmlinuz-2.6.30-1-686
Found initrd image: /boot/initrd.img-2.6.30-1-686
Found linux image: /boot/vmlinuz-2.6.26-2-686
Found initrd image: /boot/initrd.img-2.6.26-2-686
done
jejewen-laptop:/home/jejewen# 
Par contre, impossible de booter sur le nouveau noyau ( malgré la commande précédente ), il n'apparait toujours pas dans la liste. Pourtant je pensais que cette commande mettait cette liste à jour, faut quand même pas que j'édite moi-même le menu.lst, si ?
captnfab

Re: [Nouveau noyau] Erreur à l'installation ( résolu )

par captnfab »

Le menu.lst, c'est grub 1 le grub.cfg c'est grub 2. Apparemment, tu utilises grub 2 mais c'est un vieux grub 1 qui est chargé au démarrage.

Normalement, un

Code : Tout sélectionner

sudo grub-install "(hd0)"
Devrait faire l'affaire.
Jejewen

Re: [Nouveau noyau] Erreur à l'installation ( résolu )

par Jejewen »

Capitaine Fab a écrit : Normalement, un

Code : Tout sélectionner

sudo grub-install "(hd0)"
Devrait faire l'affaire.
Niquel, c'était ça.
Merci bien.
captnfab

Re: [Nouveau noyau] Erreur à l'installation ( résolu )

par captnfab »

Youpi \o/
Jejewen

Re: [Nouveau noyau] Erreur à l'installation ( résolu )

par Jejewen »

Capitaine Fab a écrit :Youpi \o/
Youpi... ça a dégénéré cette nuit : http://forum.malekal.com/reinstallation ... 22265.html

Et je sens que ça va être rock'n'roll celui-ci...
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »