[Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

zonk

[Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par zonk »

Bonjour
D'ici quelques heures j'installerai Ubuntu Karmik Koala (9.10) et j'ai besoin de votre aide au sujet de Flash Player..
Sous Jaunty Jackalope (9.04) j'avais Swfdec comme lecteur...je l'aimait bien car il ne semblait pas créer de bugs avec Firefox mais il ne semblait pas 100% compatible avec ce que je rencontrais sur le net …

Dans le livre Simple comme Ubuntu dans la version précédente (J.Jackalope 9.04)
http://www.framabook.org/ubuntu.html
qui donne des infos sur la version 9.04 on recommande d'installer Flash Player " a la Windows" ,via une page web requérant Flash et en laissant le navigateur détecter lui-même le besoin de Flash ,ex.sur Youtube :
Question:
Est ce que ca sera le plugin "Adobe Flash Player " (propriétaire) ...(c'est ce que je crois selon mes tests)
(méthode un peu paradoxal car selon mes lectures ont recommande de passer par les "dépots" ,etc...bref...)

Selon ce que j'en ai compris...
La différence entre Adobe flash Player ,Swfdec Player for Adobe /Macromedia Flash et Gnash SWF Player est que le Adobe Flash Player est propriétaire et supporte d'avantage de sites mais contient (ou contenait ) des bugs faisant planter Firefox :
Question: tout le temps ou rarement ? qu'en est il sous 9.10 ?
Les deux autres lecteurs sont libres mais plus limités....notamment au niveau des jeux mais permettant de bloquer automatiquement les animations par défaut,bloquant ainsi des nombreuses pubs irritantes

Alors que me recommandez vous comme lecteur pour le Karmik Koala? Est ce que j'ai raison d'opter pour flashplugin-installer ??
….et autrement que via Youtube,avez vous un lien simple et clair pour le téléchargement si le besoin est ??
Question:
Est ce que ce logiciel de Adobe est supporté par la communauté coté mise a jour automatique de sécurité et bugs majeurs ?
@+ et merci beaucoup
Dernière modification par zonk le 04 déc. 2009 16:36, modifié 2 fois.
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Ubuntu 9.10] Quel lecteur pour Flash

par Lætitia »

Bonjour Zonk,
effectivement, on peut rencontrer des problèmes de compatibilités avec certaines animations si tu utilises Gnash ou swfdec. Ces 2 lecteurs d'animation flash sont libres contrairement à celui d'Adobe. Il fonctionne bien.
Tu bénéficieras des maj et la version actuelle est la 10.0.32.18.

Il vaut mieux installer tes logiciels via les dépôts pour plus de sécurité plutôt que ceux proposés sur des sites.
Tu peux installer flash via les dépôts à partir de Synaptic Système>administration>Gestionnaire de paquet Synaptic
ou en ligne de commande

Code : Tout sélectionner

sudo aptitude install flashplugin-installer
@+
zonk

Re: [Ubuntu 9.10] Quel lecteur pour Flash

par zonk »

Hi Laetitia ;)
Ces 2 lecteurs d'animation flash sont libres contrairement à celui d'Adobe. Il fonctionne bien.

Est ce que les problèmes du passé sont le fruit de mon imagination ??...maintenant tout baigne pour ce produit de Adobe??

Tu bénéficieras des maj et la version actuelle est la 10.0.32.18.

Super !
Il vaut mieux installer tes logiciels via les dépôts pour plus de sécurité plutôt que ceux proposés sur des sites.
Tu peux installer flash via les dépôts à partir de Synaptic Système>administration>Gestionnaire de paquet Synaptic
ou en ligne de commande

Code : Tout sélectionner

sudo aptitude install flashplugin-installer
C'est fait ....tout semble ok!!

Et dans le même ordre d'idée il y a Java....
j'avais pensé le prendre ici...
http://java.com/fr/
ou la :
Dans Applications -Logiteque Ubuntu je vois :
  • Environnement d'exécution Sun Java 6
    Open JDK java 6 Runtime
    OpenJDK java 6 Web Start
    Greffon java Icetea
J'irais d'avantage pour le premier de la liste :
Environnement d'exécution Sun Java 6
...mais je ne suis pas certain
que me conseilles tu s'il te plait dans la mesure que je veux le meilleur et le plus versatile des produits ?
(toujours de le contexte d'avoir un suivit coté mise a jour et cie )
@+ et merci beaucoup [/color]
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Ubuntu 9.10] Quel lecteur pour Flash

par Lætitia »

salut,
zonk a écrit : J'irais d'avantage pour le premier de la liste :
Environnement d'exécution Sun Java 6
Pareil, même si il n'est pas libre, c'est la version qui tournera le mieux avec les applets java.
Tu peux passer aussi par synaptic et installer le greffon et l'environnement selon tes besoins.
It's up to you.
zonk

Re: [Ubuntu 9.10] Quel lecteur pour Flash

par zonk »

Salut Laetitia
Parfait...j'opte pour :
Environnement d'exécution Sun Java 6
super et merci !!!
zonk

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par zonk »

Salut les amis
J'ai réinstallé Ubuntu aujourd'hui (car je fais des tests pour cibler un possible problème matériel) et
sous Lucid Lynx je suis un peu embêté pour l'installation de Java...

Je ne trouve que le greffon Java IceTea et le OpenJDK Java 6 Runtime qui semble le plus approprié pour mes besoins
J'ai installé Java IceTea dans ma première installation de Ubuntu (ca marchait bien sauf qu'il ne semblait pas être le paquet des plus versatile
..en gros je cherche a ce que tout ce qui s'appelle "Java "s'exécute automatiquement ( sans a avoir a installer 1001 paquets ).
Je cherche un ou des paquets soutenus par la communauté qui seront les plus complets et les plus versatile....
Laetitia me conseillait d'opter pour Environnement d'exécution Sun Java 6 mais je ne trouve pas cette appellation dans la Logitèque Ubuntu ni dans le Gestionnaire de paquets Synaptic
Alors que me conseillez vous ?
@+ et merci encore !!!
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par Lætitia »

salut zonk,
je te donne l'avis de notre linuxien vampirique:
Capitaine Fab a écrit :Pour les suivants, la méthode « propre » pour installer Sun Java pour Firefox / Iceweasel sous Debian / Ubuntu est la suivante :
en root :

Code : Tout sélectionner

aptitude install sun-java6-plugin
@+
zonk

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par zonk »

Merci Laetitia
Je regarde ca plus tard
....je suis retourné sous Karmik ....je cherche a cibler mon problème de "freeze" intempestif

@+ merci!!!
Wullfk

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par Wullfk »

Bonjour Laetitia, salut Zonk,

ayant la version Lucid Lynx (10.04) j'ai pas rencontrer de problème pour installer Sun Java6, bon c'est vrai j'ai suivi la procédure proposé par Capitaine Fab.
concernant ton problème de freeze intempestif, je verrais bien deux causes possibles:
la RAM ou la CG (pilote incompatible) qui sait, un pilote générique proposé par UBUNTU pourrait corriger le problème.

Salut et bon week-end
zonk

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par zonk »

Salut Wullfk
Pour la ram ,j'ai deux tests de fait avec Memtest86+4: un de ± 4 hres et un autre de 16 hres.....tout semble ok
J'ai fait trois tests de hhd avec des utilitaires différents ...tout semble ok...j'ai même changer de hhd (et fait les mêmes tests) encore la tout baigne et le "freeze" revient ,c'est intempestif et ca arrive même quand l'ordi est sous l'économiseur d'écran ...alors je dois l'arrêter par la méthode la moins recommandable et souvent ca rime que Ubuntu ne veut plus démarrer (avec des messages style "kernel Panic" etc......)
J'ai de plus ôter la carte de son ,désactiver le lecteur 3½ du bios, vérifier le câblage ,etc....et ca ne change rien

Je suis revenu a Karmik et depuis ± 60 hres pas de bugs apparent....je commence a penser que la 10.04 est comme "buggée" vs mon matériel....
Pour ce qui est de changer de pilote ,peut être mais je ne vois pas trop comment faire sous Ubuntu (le pilote en ce moment est celui qui m'a été attribué a l'install)
Pour faire un résumé je vais essayer Karmik encore quelques semaines et attendre la prochaine version pour tenter un autre test (si Karmilk ne bug pas d'ici là car par apres me restera le power supply comme cible mais auparavant je vais utiliser cet ordi via mon autre hhd qui est présentement débranché pour tester la machine et par le fait même le processeur avec un utilitaire sous Windows car c'est le seul que je connaisse et maitrise) et par la suite si ca refait le même gossage avec cette futur version je vous en glisserai un mot


Plus ca va plus j'opte pour un bug de Lucid Lynx vs mon hardware....mais je ne confirme rien
@+
Avatar de l’utilisateur
Lætitia
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par Lætitia »

bonjour zonk,
zonk a écrit :Plus ca va plus j'opte pour un bug de Lucid Lynx vs mon hardware...
Je plussoie.
Je crois bien qu'une version corrigée de 10.04 va sortir en juillet. Je n'ai pas dit qu'elle sera exempte de bug, mais peut-être que ton souci sera réglé.

Par contre, tu peux avoir des infos sur ton processeur.

Code : Tout sélectionner

cat /proc/cpuinfo
@+
zonk

Re: [Résolu][Ubuntu 9.10] Quel lecteur pour Flash et Java

par zonk »

Salut Laetitia
Je connais pas mal d'info sur mon matériel...et quand je parlais de mon processeur c'était plutôt dans le contexte de voir si il a une faille quelconque. Cet ordi est un peu âgé (c'est mon ordi cobaye ....) mais il me satisfait .

voila ce que donne le terminal:
*****@*****:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 1
cpu MHz : 2994.049
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pebs bts pni dtes64 monitor ds_cpl cid xtpr
bogomips : 5988.09
clflush size : 64
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 1
cpu MHz : 2994.049
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pebs bts pni dtes64 monitor ds_cpl cid xtpr
bogomips : 5989.24
clflush size : 64
power management:

*****@*****:~$


Je ne sais pas si tu vois quelque chose ce spécial dans ce rapport
@+ et merci
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »