[Update Squeeze] Divers problèmes "(Résolu)"

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

eggregor

[Update Squeeze] Divers problèmes "(Résolu)"

par eggregor »

Bonjour à tous,
Je suis linuxien depuis 9 mois, j'utilise Ubuntu sur 2 machines et Lenny sur mon ordinateur habituel ( amd64).
Coup de folie je passe à Squeeze : modif /sources.list et /préférences hier soir.
Ce matin avertissement du gestionnaire de mise à jour, installation de 1208 paquets, çà ne m'étonne pas plus que çà, et je lance.
Tout se passe bien, sauf que dans les derniers paquets, il m'arrive un écran de config clavier, qui ne comporte pas mon Logitech ACX100. ( Curieux qud mm que la mise à jour supprime la config matérielle et ne reconnaisse pas l'existant !)

Je fais comme je peux, et au reboot, quand arrive l'écran "login" le clavier ne répond plus, et la souris non plus.
Comme c'est du matos sans fil, je remplace par du filaire, mais même topo.

J'ai un liveCD Kaella, qui me permet d'explorer la partition racine, mais les commandes Konsole ne répondent pas, je ne suis sans doute pas assez dans le coup ?
Je tente de faire dpkg-reconfigure console-data, mais un message me dis : que /var/cache/debconf/config.dat is locked by another process.
Je suis incapable de me sortir seul de ce mauvais pas.
Pour tout arranger le forum.debian-fr.org est injoignable depuis deux jours.
Et je découvre celui-ci qui me parait bien pour parfaire mes découvertes et peut-être me sortir de cette situation.
Je crains de devoir reformater le /.
Si quelqu'un a une meilleure idée, bien entendu je prends.
Dernière modification par eggregor le 20 oct. 2009 07:17, modifié 2 fois.
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

Salut Eggregor,
Euh, je pense qu'on pourra arranger ça sans tout formater :)

Quand tu démarres avec ta Squeeze, et que tu es bloqué à ton écran de login, est-ce que le « Ctrl + Alt + F1 » marche encore ? (il devrait t'amener sur une console en mode texte où tu peux te logguer, si le clavier marche ici)

NB : comme forum d'aide pour Debian, il y a aussi http://debian-facile.org/
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

Merci de ta réponse si rapide.
Hélas non, le clavier et la souris n'existe plus en qque sorte.
Pourtant au boot, quand apparaissent les "kernel" si je fais return, le clavier est bien actif.
Mais il disparait aussitôt et si je démarre en single user mode je ne peux plus taper quoi que ce soit.
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

Ok, ça semble bien être console-setup donc.

Quand tu bootes sur ta Kaella, il te faut monter les partitions de ta deb d'origine dans /mnt, /mnt/etc, /mnt/usr etc
(je ne sais pas si tu sais faire ou non)
Une fois ceci fait, « chroot /mnt »
puis là, tu peux faire un « dpkg-reconfigure console-setup »
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

En fait, ça me semble étrange que ça ne marche pas en mode single.

C'est normal qu'il n'affiche rien puisqu'il attend un mot de passe. Tu es sûr que si tu tapes le pass puis entrée, ça ne fait rien ?
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

Pardon, je me suis mal exprimé, ce n'est pas au login que çà coince, c'est dès le nom utilisateur, et même comme je l'ai dit tt à l'h, le clavier disparait dès le boot, quand le texte "défile" sur fond noir.
Je pense pouvoir aller me loger dans /mnt/usr
Le / est sur sda5, je vais taper cd /media/sda5 et ainsi de suite.
Je vais relancer tout de suite et vois si j'obtiens qque chose.
Merci de ton aide, je reviens?
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

Quand tu démarres en sigle, il ne te demande pas de nom d'utilisateur.

Pour le chroot :
Tu montes / sur /mnt, /etc (s'il existe) sur /mnt/etc, /usr (s'il existe) sur /mnt/usr

Si tu préfères /media/bla à /mnt, c'est comme tu veux, mais il faut créer /media/bla d'abord.
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

Alors en fait en single, le démarrage se coince à un moment et attend un mot de passe pour je ne sais plus quoi que je ne peux pas renseigner sans clavier... même la touche envoi est inactive.

Je suis sur Kaella, je n'interprète pas bien " la création" du /media/bla
J'essaie.
çà marche pas, tu ferais çà comment ?

Je disais que je mets sur sda5, c'est à dire la partition où se trouvent tous les fichiersde config pourne pas aller modifier les fichiers de kaella par erreur.
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

Est-ce que tu peux me donner une vue détaillée de ton disque dur pour que je te donne les commandes et t'explique la manœuvre ?
(par vue complète j'entends : quelle partition contient quoi)
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

/dev/sda1 ntfs xp
/dev/sda2 étendue
/dev/sda5 en ext3 pour /
/dev/sda6 swap
/dev/sda7 pour /home
/dev/sda3 fat32 pour xp

En fait j'arrive à monter sda5/ mnt/ etc/ bin/ usr/ sbin
Si je fais la dpkg-reconfigure console-data j'obtiens message :
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process

et sir je fais chroot /mnt le message :
chroot: cannot run command'/bin/bash: No such file or directory

Il n'y a pas un problème de code Kde avec knoppix ?
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

C'est encore moi, je suis invité à diner chez des amis, il faut que je décroche, je repasserai demain.

Un question me taraude, le package de Squeeze de 600 Mo qui est téléchargeable sur une clé USB, est-ce qu'il fonctionnerait sur un CD ?
Pour un type comme moi, ce serait une solutions d'install parfaite.

Bonne soirée
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

Alors, à taper en root (après su ou sudo su) :

Code : Tout sélectionner

mount /dev/sda5 /mnt
cd /mnt
chroot .
dpkg-reconfigure console-setup
Si tu as un msg d'erreur, en tapant ces commandes, donne-le moi :)
Non, ça n'est pas lié à KDE.

Inutile de faire le dpkg-reconfigure si le chroot n'a pas marché.

Ok, repasse demain, pas de pb, mais je ne serai là qu'en soirée.

Pour le LiveUSB, non, il ne fonctionne pas sur CD. Je ferai peut-être un LiveCD un de ces jours...
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

Salut captain,
Voilà le résultat, je te l'envoie depuis Kaella :
[email protected]:~$ su -
[email protected]:~# mount /dev/sda5 /mnt
mount: /dev/sda5 already mounted or /mnt busy
mount: according to mtab, /dev/sda5 is mounted on /media/sda5
[email protected]:~# cd /mnt
[email protected]:/mnt# chroot .
chroot: cannot run command `/bin/bash': No such file or directory

Je suis allé jusque la, mais il est "busy" le /mnt !
Me sont venus ce matin, des souvenirs et une idée :
Les souvenirs:
Avant d'installer Lenny sur cette machine j'avais tenté l'install de Ubuntu, d'abord la 8.10 qui tournait déjà sur deux autres machines, puis la Jaunty.
Dans tous les cas il se passait des phénomènes étranges :
- L'install se bloquait, parfois très vite, parfois lorsqu'elle était engagée à 80 ou 90% et je m'apercevais que je n'avais plus de souris active pour cliquer sur les quelques boutons qui apparaissent pendant le déroulement du processus (et en réalité plus de clavier non plus).
- Et quand elle se terminait, je ne sais plus combien de tentatives j'ai pu faire, soit je n'avais pas de clavier-souris au boot, sSoit ils disparaissaient peu après la saisie de "utilisateur et login"...

Seule Lenny est parvenue à s'installer sans présenter ce problème, et j'avais complétement oublié ces expériences malheureuses qui ne sont pourtant pas si anciennes.

J'avais alors posé des questions sur le furum Ubuntu et Debian sans que quiconque semble avoir connu ces affres la.
N'y aurait-il pas un truc lié au matériel ?

L'idée, en fait génére une question :
Le boot se fait toujours sur le noyau 2.6.26 quelquechose, sur le GRUB existant /boot/grub, qui est celui de Lenny. Pendant l'install, un message est apparu, recommandant de faire un "upgrade-from-grub-legagy" après le reboot sans rien changer pendant la mise à jour.
Est-ce que celà n'est pas une cause possible de problème ?
Je dispose toujours du dvd d'install de Lenny, et j'ai téléchargé ta version "basique" de Squeeze sur le site Malekal : est-ce que je peux pas tenter quelquechose à partir du DVD ou d'un Cd de ta version que je graverais ?

J'attend impatiemment ton retour sur le forum, à ce soir.
captnfab

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par captnfab »

eggregor a écrit :Salut captain,
Voilà le résultat, je te l'envoie depuis Kaella :
[email protected]:~$ su -
[email protected]:~# mount /dev/sda5 /mnt
mount: /dev/sda5 already mounted or /mnt busy
mount: according to mtab, /dev/sda5 is mounted on /media/sda5
[email protected]:~# cd /mnt
[email protected]:/mnt# chroot .
chroot: cannot run command `/bin/bash': No such file or directory
Bon, faut juste arriver à monter /dev/sda5 qqpart.

Pour savoir quelles partitions sont montées, tape « mount ».
  • Si tu vois que /dev/sda5 est monté dans /quelque/part, essaye de faire un

    Code : Tout sélectionner

    chroot /quelque/part
  • Si tu ne vois pas de /dev/sda5, c'est que c'est sans doute la faute à /mnt
    Dans ce cas :

    Code : Tout sélectionner

    mkdir /media/poufpouf
    mount /dev/sda5 /media/poufpouf
    chroot /media/poufpouf
Normalement, une de ces deux options devrait fonctionner :)
Tu continues ensuite avec le dpkg-…
eggregor a écrit :Me sont venus ce matin, des souvenirs et une idée :
Les souvenirs:
Avant d'installer Lenny sur cette machine j'avais tenté l'install de Ubuntu, d'abord la 8.10 qui tournait déjà sur deux autres machines, puis la Jaunty.
Dans tous les cas il se passait des phénomènes étranges :
- L'install se bloquait, parfois très vite, parfois lorsqu'elle était engagée à 80 ou 90% et je m'apercevais que je n'avais plus de souris active pour cliquer sur les quelques boutons qui apparaissent pendant le déroulement du processus (et en réalité plus de clavier non plus).
- Et quand elle se terminait, je ne sais plus combien de tentatives j'ai pu faire, soit je n'avais pas de clavier-souris au boot, sSoit ils disparaissaient peu après la saisie de "utilisateur et login"...

Seule Lenny est parvenue à s'installer sans présenter ce problème, et j'avais complétement oublié ces expériences malheureuses qui ne sont pourtant pas si anciennes.
Mhh, plutôt étrange :-/
eggregor a écrit :J'avais alors posé des questions sur le furum Ubuntu et Debian sans que quiconque semble avoir connu ces affres la.
N'y aurait-il pas un truc lié au matériel ?
Plutôt à sa détection qu'au matériel lui-même. Il y a de grands changement à ce niveau là entre la lenny et la squeeze.
eggregor a écrit :L'idée, en fait génére une question :
Le boot se fait toujours sur le noyau 2.6.26 quelquechose, sur le GRUB existant /boot/grub, qui est celui de Lenny. Pendant l'install, un message est apparu, recommandant de faire un "upgrade-from-grub-legagy" après le reboot sans rien changer pendant la mise à jour.
Est-ce que celà n'est pas une cause possible de problème ?
Non.
eggregor a écrit :Je dispose toujours du dvd d'install de Lenny, et j'ai téléchargé ta version "basique" de Squeeze sur le site Malekal : est-ce que je peux pas tenter quelquechose à partir du DVD ou d'un Cd de ta version que je graverais ?
Ben, ce que tu tenterais à partir d'un de ces trucs, c'est ce que nous tentons avec la KLA, donc ça ne vaut pas le coup de changer :)

Hop...
eggregor

Re: Lenny > Squeeze: plus dereconnaissance clavier au boot

par eggregor »

Re,
Ta soirée commence de bonne heure, je ne m'y attendais pas, merci de ton passage.

[email protected]:~# mount
/dev/root on / type ext2 (rw)
/ramdisk on /ramdisk type tmpfs (rw,size=827780k,mode=755)
/UNIONFS on /UNIONFS type aufs (rw,br:/ramdisk:/KNOPPIX)
/dev/hda on /cdrom type iso9660 (ro)
/dev/cloop on /KNOPPIX type iso9660 (ro)
/proc/bus/usb on /proc/bus/usb type usbfs (rw,devmode=0666)
/dev/pts on /dev/pts type devpts (rw)
/dev/sda5 on /media/sda5 type ext3 (ro,nosuid,nodev)
[email protected]:~# chroot /media/sda5
chroot: ne peut exécuter la commande `/bin/bash': Erreur de format pour exec()
[email protected]:~# mkdir /media/sda5
mkdir: ne peut créer le répertoire `/media/sda5': Le fichier existe.
[email protected]:~#

Je suis honteux d'être aussi nul, je ne comprends pas tout :
/dev/sda5 est bien monté dans /media/sda5 ? Alors pourquoi "chroot" ne fonctionne-t-il pô !
Dur-dur d'être linuxien !
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »