[Install] Ubuntu -> Debian (résolu)

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

[email protected]

[Install] Ubuntu -> Debian (résolu)

par [email protected] »

Bonjour à tous,

Après quelques mois d'initiation à Linux sur une Ubuntu, je me sens prêt à passer à Debian, qui remplirait plus mes besoins en terme de découvertes et de personnalisation du système.

J'ai lu attentivement les réponses au sujet de Laurent_chébran : Quelle image Debian ?

Et je m'orienterais plus vers une sid (netinstall), même si je ne suis pas expert, je suis patient et plein de bonnes volontés PDT_001

Je veux donc simplement formater ma partition Ubuntu (en ext4) et la remplacer par Debian.
Mon souci, vient de grub, je suis en DualBoot avec un Windows XP (on peut pas convertir tout le monde) et j'ai peur de plus pouvoir booter sur Windows PDT_028

Le CD est gravé, j'attends le top-départ PDT_016

Merci d'avance pour votre suivi.
@+
Dernière modification par [email protected] le 21 juin 2009 15:53, modifié 1 fois.
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

Hop, je te ferais une réponse ce soir (pas le temps là). Mais bon, avant de passer en ext4, renseigne toi sur tous les bugs qu'il reste. Pour Grub, il n'y aura pas de problème, il faudra juste refaire un peu de configuration.
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Merci de ta réponse Capitaine Fab PDT_010
Pour l'installation, j'ai déjà fait le test sur une machine virtuelle, l'installation graphique est plutôt bien foutu, je devrais pas avoir trop de problème.
Pour ext4, effectivement ... Vu les nombreux sujets, je vais pas m'embarqué dedans, j'attendrais que Debian gère un autre système de fichiers plus puissant, je me tiendrais à l'ext3 pour ma 1er installation.

Mais c'est au niveau de Grub que je "m'inquiète" et au niveau bien sûr de Debian en lui même (utilisation).

@+
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

Mhh…
Le problème n'est pas qu'ext4 n'est pas assez puissant… Je l'utilise depuis quelques mois pour mon /home et je n'ai jamais eu de soucis. Seulement je sais que certains en ont eu, qu'il faut être prudent dans certains cas, etc. Donc je ne vais pas te conseiller de l'utiliser ! En plus de ça, je ne ressens pas vraiment de changement par rapport à l'ext3…

En ce qui concerne Grub…
Lorsque tu vas installer Debian, il te proposera de réinstaller Grub, ce que tu feras. Je ne sais pas s'il détectera l'ancienne installation de Windows, mais quoi qu'il en soit il sera facile de la lui faire prendre en compte.

Qu'en est-il du partitionnement actuel de ton disque dur ? Est-ce que tu as déjà une partition séparée pour /home ?

Pour ce qui est de l'utilisation de Debian, ça n'est pas si différent d'Ubuntu. Tu peux toujours utiliser des outils graphiques à-la-kon® pour configurer des trucs, installer des logiciels, mais tu peux aussi te pencher sur les outils en ligne de commande qui à l'usage se révèlent bien plus complets et maniables.
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Le problème n'est pas qu'ext4 n'est pas assez puissant… Je l'utilise depuis quelques mois pour mon /home et je n'ai jamais eu de soucis. Seulement je sais que certains en ont eu, qu'il faut être prudent dans certains cas, etc. Donc je ne vais pas te conseiller de l'utiliser ! En plus de ça, je ne ressens pas vraiment de changement par rapport à l'ext3…
Il y a peut être un mal entendu PDT_005
J'utilise déjà ext4 pour ma partition avec Ubuntu, mon /home n'est pas séparé de ma partition, j'ai sauvegardé mais documents mais je comprend l'utilité maintenant de l'avoir séparé du restes du système.
Je désire juste un système de fichiers stable, et je ne suis pas à quelques micro-secondes dans le cas d'une copie.

Un petit screen vaut mieux qu'un discourt :

Image

Pour la taille du swap, il fait 1Go mais j'ai 2Go de RAM, et je n'ai pas besoin de plus.

Je commence l'install ce soir, je te rapporterais si besoin les problèmes rencontrés
(si tu veux bien m'aider aussi PDT_016 )
Sur tes conseilles, déjà lu sur ce forum, j'utiliserais aptitude plutôt que Synaptic, je me suis déjà familiarisé avec lui sur Ubuntu.

@+

EDIT 22h:

J'ai eu quelques soucis pour l'installation PDT_001
J'ai eu ce message :

Image

J'ai monté comme je peux ma cléf et copier le fichier depuis /var/log
Ce message apparaissait juste après la sélection du swap, après tout "se bloque", impossible de revenir à l'outils de partitionnement.
Du coup, j'ai sauté l'étape du swap ...

Là, j'ai démarré Debian ... Je suis en mode texte, impossible d'installer le réseau, le cable Ethernet est connecté mais ... rien.

ifconfig :

lo link encap:Bouclelocale
inet adr:127.0.0.2 Masque: 255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1

J'ai pas d'autre interface et je me demande si c'est bien la bonne version que j'ai installé PDT_006
J'ai gravé, celle là :

debian-testing-i386-netinst.iso

C'était bien ça au moins ? PDT_004

La commande lspci n'existe pas, bref, c'est le gros bordel ! PDT_028
Avatar de l’utilisateur
mélodie
Messages : 1491
Inscription : 14 janv. 2007 00:29
Localisation : Pyrénées

Re: [Install] Ubuntu -> Debian (en cours)

par mélodie »

Salut,

netinstall est une version à finir d'installer (comme son nom l'indique, par le réseau). Si tu as rebooté, ensuite tu te connectes sur une session en mode texte en root, tu tappes quelque chose comme "dhclient" et tu attends qu'il trouve le réseau. Ensuite tu installes le reste (le serveur xorg, et un environnement de bureau)

PS: par sécurité quand j'installe, je partitionne avant, avec le live CD Gparted. (que je télécharges sur Sourceforges)
Règles à respecter sur le forum Si vous ne savez pas comment poster, cliquez ici !
(Et tout particulièrement la section «À lire avant de poster, en 5 points de Capitaine Fab»)

Texte culte
:
Comment Poser Les Questions De Manière Intelligente
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

L'installation du système de base ne s'est sans doute pas terminée, réinstalle tout en mode texte (plus stable que le mode graphique).

C'est la première fois que je vois ce problème ! :)
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Salut à tous,

J'avoue, j'ai craqué, l'installation avec le CD de la testing était carrément impossible.
J'ai du faire ça avec une stable, j'ai réussi à installer Awesome et le serveur X.

Je vous écrit du navigateur Iceweasome (le seul que j'ai trouvé en fait).
Mes problèmes actuellements :

1°/ Pas de son, alsa-mixer reconnait mon matériel
2°/ Pas de wifi, je peux utilisé ndiswrapper ? Sa marchait très bien sous Ubuntu.
3°/ Configuration de Awesome, mais c'est en cours grâce au tuto de Malekal.

@+
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

Huhu :)
Le navigateur est « Iceweasel » et non « Iceweasome », c'est en fait la version « débrandée » de Firefox. Ies fonctionnalités sont exactement les mêmes.

Pour le son, si alsamixer reconnaît ton matériel alors il devrait te suffire de tout régler comme il faut. Est-ce qu'on peut avoir une capture d'écran ?

Pour le wifi, oui, on peut utiliser ndiswrapper mais il faut l'installer.
Pour se faire, assure toi d'être connecté au net par câble ethernet et puis, en root :

Code : Tout sélectionner

aptitude update
aptitude install module-assistant
m-a update
m-a prepare
m-a a-i ndiswrapper
Puis tu installeras ensuite les pilotes de ta carte pour ndiswrapper…

Vu que tu utilises Lenny, tu peux te servir des tutos qui lui sont destinés dans la partie tuto. En particulier pour la personnalisation de bash, pour configurer sudo et pour configurer les sources.

Il n'y a pas de mal à rester sous Lenny quelque temps histoire de te faire la main. En plus, la Lenny est assez récente et exempt de tous les bugs récents de Xorg 1.6 :)
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Bonsoir !

On avance, je suis en wifi grâce à ton listing PDT_001
J'ai pratiquement tout les programmes que je veux pour le moment.

Je poste une capture pour deux problèmes :

Les caractère illisibles figurant sur firefox (je t'avoue que c'est en train de flingué mes yeux), c'est à mon avis la resolution du Windows Manager qui est en cause, mon écran est bien réglé, et ça le fais pour toute les applications.
Et pour alsa-mixer, je lance une musique avec VLC, pas un seul son sort des enceintes :

Image

Remarquer aussi, l'heure qui est déréglé ... et que je ne sais même pas changer PDT_009

EDIT 23H :
Je viens de penser que j'aurais aimé Flash player PDT_005
Pour cela, j'ai téléchargé le fichier sur le site officiel, j'ai vu sur internet que le script d'install était facultatif (t'façon, il marche pas): et qu'il fallait placé le *.so dans le répertoire plugins du navigateur ... Le problème, c'est que je sais pas ou il se trouve :p, encore faut t-il du son.

Merci de votre aide en tout cas.
@+
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

Alors déjà, pour le son, c'est simple.
Dans alsamixer, tu remarqueras que la colonne « PC Speaker » autrement dit « haut-parleurs PC » est en MUTE (M) et avec le volume à 0. Donc va sur cette colonne, tape M et monte le son :)
Je pense que c'est le seul truc qui manquait, mais tu peux toujours faire d'autres tests si ça ne marche pas. En tout cas, la carte son est bien détectée c'est juste que le volume est coupé ^^

Pour l'heure :

Code : Tout sélectionner

sudo aptitude install ntpdate
sudo dpkg-reconfigure tzdata
sudo ntpdate ntp.univ-lyon1.fr
Lors de la deuxième étape, tu dois spécifier que l'heure stockée sur l'horloge matérielle est l'heure locale et non l'heure utc, puis spécifier tes paramètres de zone.
La troisième étape synchronise l'heure avec le serveur de temps de l'université Lyon I.

Pour les histoires de petits symboles avec firefox, je ne sais plus d'où vient le problème, je vais essayer de retrouver ça :)
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

Pour flashplayer, le moyen le plus propre est :

Code : Tout sélectionner

sudo aptitude install flashplayer-nonfree
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Merci pour ton aide plus que précieuse PDT_001

J'ai du son, flash fonctionne correctement et l'heure est reglé de façon ultra-précise !

Il ne reste plus que 2 ou 3 problèmes encore présents :

1°/ La résolution des menu des applications, caractère microscopique
2°/ La configuration du réseau

Explication pour le 2°/

Actuellement pour me connecter à internet, j'utilise un script que j'ai crée pour l'occasion :

Code : Tout sélectionner

#/bin/sh
#Configuration + connexion LiveBox

iwconfig wlan0 essid "Livebox-xx" mode Auto
iwconfig wlan0 key restricted xxxxxxxxxxxx

dhclient
Livebox-xx étant mon SSID
et xxxxxxxxxxxx étant ma clé.


Tout cela ne peut-t-il pas etre executé automatique ?

De plus, n'y a t-il pas une astuce pour copier/coller dans un terminal ? Sa me faciliterais bien la vie PDT_004

@+
captnfab

Re: [Install] Ubuntu -> Debian (en cours)

par captnfab »

[email protected] a écrit :Merci pour ton aide plus que précieuse PDT_001
J'ai du son, flash fonctionne correctement et l'heure est reglé de façon ultra-précise !
Héhé, well done ;-)

[email protected] a écrit :1°/ La résolution des menu des applications, caractère microscopique
Alors, je pense que

Code : Tout sélectionner

xrandr --dpi 100
devrait rentre le truc un peu mieux. Sinon, essaye avec 120. Restera à trouver le moyen de faire ça de manière persistante (si ça règle le problème)
[email protected] a écrit :2°/ La configuration du réseau

Actuellement pour me connecter à internet, j'utilise un script que j'ai crée pour l'occasion :

Code : Tout sélectionner

#/bin/sh
#Configuration + connexion LiveBox

iwconfig wlan0 essid "Livebox-xx" mode Auto
iwconfig wlan0 key restricted xxxxxxxxxxxx

dhclient
Bien, je vois que tu maîtrises les commandes pour régler le Wifi, ça fait plaisir :)

Alors, il y a un procédé prévu pour faciliter tout ça.

Modifie ton fichier /etc/network/interfaces de la sorte

Code : Tout sélectionner

auto lo
iface lo inet loopback

auto wlan0=wifi-livebox
iface wifi-livebox inet dhcp
  wireless-mode managed
  wireless-key xxxxxxxxxxxx
  wireless-essid XXXXX
Avec ça, à chaque démarrage, il essayera de te connecter à la Livebox. Le problème étant que s'il ne la trouve pas, il perdra un temps fou au démarrage. Si ton ordinateur est un portable (et que donc ce problème sera supposé arriver) je t'expliquerai comment configurer un réseau « itinérant ».
Une autre solution simple dans ce cas est de commenter la ligne

Code : Tout sélectionner

auto wlan0=wifi-livebox
et de te connecter toi même quand tu le souhaites avec

Code : Tout sélectionner

ifup wlan0=wifi-livebox
[email protected] a écrit :De plus, n'y a t-il pas une astuce pour copier/coller dans un terminal ? Sa me faciliterais bien la vie PDT_004
Sélectionner du texte dans un terminal (ou ailleurs) le copie directement. Faire un clic avec le bouton du milieu (ou clic droit et gauche en même temps, ou Alt+Shif+Insert) colle le texte présent dans le presse-papier.
Attention tout de même au fait qu'il existe 2 presse-papiers distincts sous X (3 en fait) et qu'en copiant une vache, on peut se retrouver à coller une girafe.
[email protected]

Re: [Install] Ubuntu -> Debian (en cours)

par [email protected] »

Wifi opérationnel au démarrage PDT_028

Code : Tout sélectionner

xrandr --dpi 100
Cela ne résout hélas, pas le problème, même après redémarrage de X.
Je te renvois la sortie de la commande xrandr :

Code : Tout sélectionner

$ xrandr
Screen : minimum  320 x 200, current 1280 x 720, maximum 1440 x 1440
VGA1 disconnected
DVI0 disconnected
VGA2 disconnected 
DVI1 connected 1280x720+0+0 708mm x 398mm

1280x720              60.*+            60.0
1440x900              59.9
1152x864              75.0
1024x768              75.0              70.1              60.0
832x624                74.6
800x600                75.0              60.3
640x480                75.0              59.9
720x400                70.0
Tant que j'y suis, t'a pas une astuce pour activer VERR NUM au démarrage ? PDT_009
Dernière modification par [email protected] le 20 juin 2009 13:18, modifié 1 fois.
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »