J'ai besoin d'un avis éclairé!

Questions autour de la sécurité en général.
Pour les désinfections, merci de vous rendre dans la partie Windows --> Virus : Aide Malwares
100bugs

J'ai besoin d'un avis éclairé!

par 100bugs »

Voici la situation:

Je navigue avec IE7 et Firefox et depuis 2 jours il se passe quelque chose d'étrange avec IE7. Sur certains sites dont les 2 mentionnés ci-dessous, mon IE7 me propose d'installer un activeX de 1.7 Mo qu'il identifie comme étant: "Adobe Flash Player Installer" publié par Adobe System Inc.

* http://www.commentcamarche.net/faq/suje ... teme-ghost
* Malekal's forum (url connu)


Ce qui me chicotte c'est que sur les mêmes pages, mon Firefox ne me propose pas d'installer ce fichier et pourtant, les 2 pages (Firefox et IE7) sont identiques; toutes les images flash sont présentes.

Ce n'est donc pas mon logiciel qui est désuet mais j'ai quand-même vérifié sur le site d'adobe et ma version 10 est effectivement la plus récente.

De plus, en naviguant sur le site d'adobe (avec IE7), on ne me PROPOSE PAS d'installer ce fichier et pourtant, il est mentionné sur la page d'adobe que les images flash sont visibles avec la dernière version de flash. Le fait de les voir confirme encore que mon logiciel est à jour.

Je suis inquiet parceque cela m'a été proposé pour la première fois sur un site "à risque" où je ne faisais qu'écrire un commentaire. C'est d'ailleurs pour cette raison que j'ai refusé de l'installer car sinon j'aurais accepté.

Considérant la qualité des sites Malekal et Commentcamarche, je me dis que c'est probablement une simple coincidence et que je m'en fais pour rien mais alors:

Pourquoi me proposer ce fichier si mon logiciel est à jour?
Et pourquoi cela se produit seulement avec IE7?

Est-ce que j'aurais attrapé une "puce" au passage et que celle-ci serait en train d'essayer de faire venir la cavalerie?


Merci de m'éclairer
td947

Re: J'ai besoin d'un avis éclairé!

par td947 »

Je viens de tester ta page commentçamarche, et aucun contrôle active x à l'horizon. Bizarre ton histoire.
De plus tu demande pourquoi cela se produit avec IE7, la réponse est simple: firefox n'utilise pas et ne prend pas en compte les contrôles active x.
Quand tu y retournes, ça recommence?
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Je viens de faire un reboot pour nettoyer (au cas où) et aussitôt que je me suis branché sur Malekal (avec IE7), le fichier 1.7 Mo a recommencé à télécharger. J'ose pas accepter de l'installer tant que je ne comprends pas pourquoi on me l'offre...

Pour ma petite connexion 56K, ce 1.7 Mo est une vraie merde qui ralentie considérablement la navigation.

Pour IE7 et Firefox, je me doutais bien que le second n'acceptait pas les activeX car c'est plus sécuritaire.
td947

Re: J'ai besoin d'un avis éclairé!

par td947 »

Tu as quoi comme antivirus? Il ne dit rien lorsque l'active x essaye de se charger?
Autrement tu peut essayer de voir ce que c'est en utilisant quelque chose comme Sandboxie ou Returnil.

P.S: 56k??? PDT_030 Tu sais que l'ADSL existe depuis quelques temps? PDT_006 (joke)
Malekal_morte
Messages : 110283
Inscription : 10 sept. 2005 13:57

Re: J'ai besoin d'un avis éclairé!

par Malekal_morte »

Salut,

Regarde si tu n'as pas un ocx flash d'une ancienne version qui traine, voir : https://www.malekal.com//update_JAVA_Flash.php
Première règle élémentaire de sécurité : on réfléchit puis on clic et pas l'inverse - Les fichiers/programmes c'est comme les bonbons, quand ça vient d'un inconnu, on n'accepte pas !
Comment protéger son PC des virus
Windows 11 : Compatibilité, Configuration minimale requise, télécharger ISO et installer Windows 11

Comment demander de l'aide sur le forum
Partagez malekal.com : n'hésitez pas à partager les articles qui vous plaisent sur la page Facebook du site.
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Je viens d'aller sur http://fra.tallemu.com/comparisons.html avec IE7 et ce site est OK. Il était aussi OK avant.
Sauf erreur, je ne vois pas d'image flash sur cette page alors le fichier 1.7 Mo est peut-être légitime en fin de compte mais...

Actuellement j'ai Antivir free et G DATA (trial) comme antivirus installés.
J'aime plus ou moins G DATA car il est très lent mais par contre il détecte des choses que antivir ne voit pas...
C'est peut-être des faux positifs...
C'est G DATA qui me signale qu'il vérifie le téléchargement de 1.7 MO et quand terminé, vista me demande si je veux installer.

Pour sandboxie, je ne peux pas l'utiliser parcequ'il ne tourne pas sur vista x64. Hélas!
J'aimerais bien trouver un remplaçant. Tu en connais un?

Returnil Je ne connais pas!

Pour l'ocx flash, je vais vérifier plus tard (pas le temps maintenant) mais c'est possible car j'ai fait un update de java il y a 1 ou 2 semaines et il s'est produit une chose bizarre. Le site officiel de java m'a proposé une maj (automatique) et en l'installant mon ordi a dit que je l'avais déjà. J'ai installé quand-même.
doc pc

Re: J'ai besoin d'un avis éclairé!

par doc pc »

salut,
100bugs a écrit :Actuellement j'ai Antivir free et G DATA (trial) comme antivirus installés
oups!! un de trop!! fait ton choix!!! PDT_033
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Chez-moi, la pub à la télé dit que 1 verre de lait c'est bien mais que 2 c'est mieux...

Je plaisante!
Je vais en balancer un avant longtemps mais là je test et plus souvent qu'autrement l'un des deux est désactivé.

Je vais revenir demain après avoir lu l'info de malekal sur l'ocx. Ici il est déjà 19:10
Bon! Ma bouffe est prête et j'ai faim alors... à demain.

Merci!
doc pc

Re: J'ai besoin d'un avis éclairé!

par doc pc »

100bugs a écrit :Je vais en balancer un avant longtemps mais là je test et plus souvent qu'autrement l'un des deux est désactivé
PDT_018
100bugs a écrit :Bon! Ma bouffe est prête et j'ai faim alors... à demain
OKI bon ap!!!! PDT_003
td947

Re: J'ai besoin d'un avis éclairé!

par td947 »

Sandboxie existe en version 64 bits, regarde ici http://www.sandboxie.com/index.php?DownloadSandboxie PDT_003 Masi si je comprends bien c'est une ancienne version, donc faut voir...
Autrement en équivalent tu as VirtualBox ici: http://www.virtualbox.org/wiki/Downloads
Les tutos pour les deux sont dispos sur le site de Malekal.
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Pour td947

Je connais cette version 64 et tu as raison en disant qu'elle est vieille. En fait, son concepteur a cessé de la supporter quand microsoft a fait un changement dans une API (ou autre chose) qui était ESSENTIEL pour sandboxie et impossible à contourner. Le premier OS affecté a été vista puis, avec les maj de windows, XP (SP3 ?) a commencé à être affecté.

Donc, les seules machines 64 bits encore capables d'utiliser cette version 64 bits sont celles de XP qui n'ont pas été mis à jour. Bravo pour le progrès... et pour microsoft!

Je vais me renseigner pour virtualbox mais j'ai l'impression que c'est moins bon que sandboxie.
Peu importe! "Moins bon" est encore meilleur que rien du tout!
L'important est de connaître les limites du produit pour ne pas les excéder!


Pour MALEKAL

Il y a effectivement un problème avec mon Sun Java JRE.
Sur Secunia, on m'a détecté des versions non à jour (comme par le passé) qui ne se corrigent pas en faisant les maj. Il y a sans doute un conflit quelconque que je devrais pouvoir résoudre en lisant ta documentation. Mais je ne pense pas que c'est la cause du présent problème car ces versions java sont ainsi depuis plusieurs mois.

PAR CONTRE...

Secunia a aussi rapporté 4 Adobe Flash Player 9.0.124.0 DÉSUETS ainsi que 1 Adobe Flash Player 10.0.12.36 À JOUR.
C'est très certainement la cause du problème et la raison pourquoi il s'est présenté il y a 2 jours est parceque j'ai installé 2 logiciels Corel de traitement d'images précisément à ce moment.

C'est forcément de là que proviennent les 4 Adobe Flash Player 9.0.124.0 DÉSUETS qui n'étaient pas là avant.

J'AI MAINTENANT CE QU'IL FAUT POUR RÉGLER CES 2 PROBLÈMES!
Reste à exécuter le travail...
Je viens de l'ancer l'update du Flash player sur Secunia et... le fichier fait 1.7 Mo => Problème réglé

Merci pour votre aide et pour m'avoir orienté dans la bonne direction.
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Petit compte rendu et d'autres questions.

Pour le problème du flash player, j'ai fait la maj et le fichier ne se télécharge plus en naviguant. Cependant, Secunia pointe encore 4 fichiers désuets de version 9 et dit que pour eux la version la plus récente est 9.0.151.0.
De plus, ces 4 fichiers sont dans des locations NON par défaut.

Alors là, je ne sais plus...
Est-ce que Secunia déconne ou est-ce qu'il faut faire une installation non conventionnelle?

Est-ce que ce serait une grosse connerie si je faisais un copier-coller d'un NPSWF32.dll (up-to-date) sur les 4 NPSWF32.dll (désuets)? J'ai l'impression que oui...

====== Pour Adobe Flash Player ==========================================
Trouvé dans les locations par défaut:
----------
Adobe Flash Player 10.x 10.0.12.36 ==> up-to-date
C:\Windows\SYSTEM32\Macromed\Flash\Flash10a.ocx
----------
Adobe Flash Player 10.x 10.0.12.36 ==> up-to-date
C:\Windows\SYSTEM32\Macromed\Flash\NPSWF32.dll
----------

Trouvé dans les locations NON par défaut:
----------
Adobe Flash Player 10.x 10.0.12.36 ==> up-to-date
C:\Windows\SysWOW64\Macromed\Flash\Flash10a.ocx
----------
Adobe Flash Player 10.x 10.0.12.36 ==> up-to-date
C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll
----------
Adobe Flash Player 9.x 9.0.124.0 ==> obsolete
C:\Program Files (x86)\Adobe\Adobe Bridge CS4\browser\plugins\NPSWF32.dll

latest patched version is 9.0.151.0.
----------
Adobe Flash Player 9.x 9.0.124.0 ==> obsolete
C:\Program Files (x86)\Adobe\Adobe Extension Manager CS4\NPSWF32.dll

latest patched version is 9.0.151.0.
----------
Adobe Flash Player 9.x 9.0.115.0 ==> obsolete
C:\Program Files (x86)\Adobe\Adobe Device Central CS4\Required\Opera\program\plugins\NPSWF32.dll

latest patched version is 9.0.151.0.
----------
Adobe Flash Player 9.x 9.0.124.0 ==> obsolete
C:\Program Files (x86)\Common Files\Adobe AIR\Versions\1.0\Resources\NPSWF32.dll

latest patched version is 9.0.151.0.
----------
=========================================================================


Pour le problème du java, je dois lire la doc de malekal avant de faire quelque chose mais à première vue, çà ressemble au cas du flash player quoi qu'ici il faut considérer la possibilité de conflits.

Moi j'y connais rien mais peut-être que des connaisseurs peuvent me faire épargner du temps...

====== Pour Sun Java JRE ================================================
Trouvé dans les locations par défaut:
----------
Sun Java JRE 1.6.x / 6.x 6.0.70.6 ==> obsolete
C:\Program Files (x86)\Java\jre1.6.0_07\bin\java.exe

latest patched version is 6.0.110.0.
----------
Sun Java JRE 1.6.x / 6.x 6.0.10.7 ==> obsolete
C:\Program Files (x86)\Java\jre1.6.0_01\bin\java.exe

latest patched version is 6.0.110.0.
----------
Sun Java JRE 1.6.x / 6.x 6.0.110.3 ==> up-to-date
C:\Program Files (x86)\Java\jre6\bin\java.exe
----------

Trouvé dans les locations NON par défaut:
----------
Sun Java JRE 1.6.x / 6.x 6.0.110.3 ==> up-to-date
C:\Windows\SysWOW64\java.exe
----------
Sun Java JRE 1.6.x / 6.x 6.0.110.3 ==> up-to-date
C:\Windows\System32\java.exe
----------
=========================================================================
SkyTech

Re: J'ai besoin d'un avis éclairé!

par SkyTech »

Salut,

Supprime : (si tu n'y arrive pas fait le en mode sans échec)

C:\Program Files (x86)\Adobe\Adobe Bridge CS4\browser\plugins\NPSWF32.dll
C:\Program Files (x86)\Common Files\Adobe AIR\Versions\1.0\Resources\NPSWF32.dll
C:\Program Files (x86)\Java\jre1.6.0_07\
C:\Program Files (x86)\Java\jre1.6.0_01\

Redémarre,

Désactive les logiciels de protections (Spybot,...)

Installes ça : http://www.adobe.com/go/full_flashplayer_win_ie

Et voit si ça marche. PDT_018
Yoh

Re: J'ai besoin d'un avis éclairé!

par Yoh »

100bugs a écrit :Sur Secunia, on m'a détecté des versions non à jour (comme par le passé) qui ne se corrigent pas en faisant les maj.
Salut,
pour résoudre cela, il suffit de désinstaller les anciennes versions de Java dans "Ajout/suppression de programmes"...
PDT_019
100bugs

Re: J'ai besoin d'un avis éclairé!

par 100bugs »

Merci les gars

Bon alors si j'ai bien compris:

Pour java il suffit de désinstaller les 2 versions désuettes qui ne l'ont pas été automatiquement lors d'installation de maj. Sauf erreur, j'ai lu quelque part que les java s'installent en parallèle mais que c'est le plus récent qui est utilisé...
Alors oui, il suffit d'enlever ce qui est désuet...pour plaire à secunia. L'ordi lui s'en fiche royalement!

Pour flash, j'aimerais comprendre ce que je vais faire.
Pourquoi supprimer seulement 2 des 4 fichiers désuets?
En quoi est différent ce prog que je dois installer? Je devrais peut-être lire avant de demander...

Je vais faire cela un peu plus tard car présentement, j'ai un DL en cours et la mini tempête de neige d'hier a laissé 6 à 8 pouces (15 à 20 cm) de neige que je dois enlever.

Je vais donner des nouvelles quand ce sera fait.
Encore merci
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Securite informatique »