problemes de souris??(resolu)

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

sunday4000

problemes de souris??(resolu)

par sunday4000 »

oui bonsoir a la communauté.je suis passé linux (kubuntu) depuis quelques mois et je m en sors pas trop mal en recuperant des renseignements ca et la..mais un bug agacant m empeche de profiter pleinement de ce systeme.je joue a divers jeux (2 en fait .aux echecs sur chess 16 et dernierement dod sur steam).je rencontre un probleme tres genant sur ces deux site ou la rapidité est importante!ma souris marche tres bien mais il arrive que lorsque je veux bouger une piece...ou quand je veux tirer la souris fasse n importe quoi ce qui est tres genant quand on joue en blitz (5 mn) et qu il reste quelques secondes a jouer ainsi que quand je suis sous le feu de l ennenmi...; cest une perte de temps qui entraine la mort sur dod ou la perte de la partie aux echecs. alors j ai entendu parler de redirection dns (je suis sous alice comme fai.ma question c est comment etre sur que la souris est la cause de tout cela (mauvaise config) ou est ce alice qui fout la merde.avant de tirer des conclusions hatives, je voulais l avis des experts.a noter que ma souris marche bien la majorité du temps pour ce qui est de surfer etc...seul ces deux sites bien specifique pose probleme.je penche pour une mauvais config. je ne connais pas le type de ma souris ;c est une souris optique classique avez une molette . j ai essayé de changer de souris pour voir mais le probleme est le meme.les symptomes sont les suivants: le pointeur se met a fond a droite et ne veux plus bouger qu en horizontal.je ne reprend le controle qu au bout de quelques dizaines de seconde ce qui est la plupart du temps fatal!!alors avant de changer de fournisseur j aierais un avis eclairé!! merci et vive linux!
Dernière modification par sunday4000 le 01 août 2008 16:47, modifié 1 fois.
Engil Hramn

Re: problemes de souris??

par Engil Hramn »

Salut,
Tu parle de redirection DNS, mais cela n'as aucun rapport, rassure toi (enfin, à ce propos, assure toi de mettre ton système à jour)
Ensuite, je penche surtout sur le fait que ta souris est usée
Xorg ne provoque rien de tel (sauf un xorg.conf bien comique...et encore)
Tu met un tapis sous ta souris ?

Enlève le pour voir, car les souris optiques ne le supportent pas toujours
Les piles sont elles encore en forme ? Changes les aussi pour voir
captnfab

Re: problemes de souris??

par captnfab »

Bonsoir snday4000,
Juste pour te dire que j'aurais préféré recevoir un message comme celui-ci : PDT_002
Fais un peu attention. Nous lisons des tas de messages chaque jour, et un gros pavé sans accent sans retour à la ligne, sans majuscule avec des fautes comme celui dont tu nous as gratifié est un peu... rebutant :)
Dans un monde meilleur, sunday4000 a écrit :Oui bonsoir à la communauté.
Je suis passé linux (kubuntu) depuis quelques mois et je ne m'en sors pas trop mal en récupérant des renseignements ça et là... Mais un bug agaçant m empêche de profiter pleinement de ce système.

Je joue à divers jeux (2 en fait : aux echecs sur chess 16 et dernièrement dod sur steam). Je rencontre un problème très gênant sur ces deux sites ou la rapidité est importante : ma souris marche très bien mais il arrive que lorsque je veux bouger une pièce, ou quand je veux tirer la souris fasse n'importe quoi. Ce qui est très gênant quand on joue en blitz (5 mn) et qu'il reste quelques secondes à jouer, ainsi que quand je suis sous le feu de l'ennemi... C'est une perte de temps qui entraine la mort sur dod ou la perte de la partie aux échecs.

Alors j'ai entendu parler de redirection DNS (je suis sous Alice comme FAI). Ma question c'est comment être sûr que la souris est la cause de tout cela (mauvaise config) ou est ce Alice qui fout la merde. Avant de tirer des conclusions hâtives, je voulais l'avis des experts. À noter que ma souris marche bien la majorité du temps pour ce qui est de surfer etc... Seul ces deux sites bien spécifiques posent problème.

Je penche pour une mauvaise config. Je ne connais pas le type de ma souris : c'est une souris optique classique avec une molette. J'ai essayé de changer de souris, pour voir, mais le problème est le même.

Les symptômes sont les suivants : le pointeur se met à fond à droite et ne veux plus bouger qu'en horizontal. Je ne reprend le contrôle qu'au bout de quelques dizaines de secondes, ce qui est la plupart du temps fatal !! Alors avant de changer de fournisseur j'aimerais un avis éclairé !!

Merci et vive linux!
Engil va bientôt te répondre, si ça n'est déjà fait.
Engil Hramn

Re: problemes de souris??

par Engil Hramn »

Aussi, poste nous ton xorg.conf
Ouvre un terminal (Konsole) et tape ceci

Code : Tout sélectionner

kdesudo kate /etc/X11/xorg.conf
Tu tape ton mot de passe
Une fenêtre s'ouvre ensuite, copie/colle nous son contenu dans ta prochaine réponse
(ne modifie rien au fichier ensuite)
sunday4000

Re: problemes de souris??

par sunday4000 »

euuuuh je n ai rien ds le xorg.conf!
sunday4000

Re: problemes de souris??

par sunday4000 »

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
voila j avais fait une erreur de casse mille excuses
captnfab

Re: problemes de souris??

par captnfab »

Bon, je dois avouer que le diagnostique de ton problème est assez difficile.
Reprenons les éléments.
  • Tu as essayé avec une autre souris, le problème demeure.
  • Ta configuration est tout ce qu'il y a de plus standard
  • Le problème survient lorsque tu joues à DOD ou à Chess 16 et uniquement lorsque tu joues à un de ces jeux
  • Le problème consiste en un déplacement incessant de la souris vers la droite.
Restent encore quelques points pas clairs pour moi :
  • DOD est un jeu Steam. Comment y joues-tu ? Avec Wine ?
  • Quel type de jeu est Chess16 ? Un jeu flash sur internet ?
  • Ta souris est branchée sur le port USB ou sur un port PS/2 ?
  • As-tu d'autres périphériques USB branchés en parallèle ?
  • Est-ce que le problème survient s'ils ne sont pas branchés ?
  • Quelle est ta version d'Ubuntu ?
  • Quelle est ta version du noyau ? (tape "uname -r" dans un terminal)
  • Est-ce qu'il te semble que le problème est survenu à la suite de quelque chose en particulier ?
  • Qu'affiche "dmesg | tail" quand le problème survient.?
sunday4000

Re: problemes de souris??

par sunday4000 »

ok bonjour
j ai un probleme de souris sur toutes les pages ;meme sur ce site.
si je me met a cliquer un peu partout ici ;au bout d un moment ma souris va se bloquer a droite et j aurais un message" l url n 'est pas valide et ne peut pas etre chargee".
mais evidemment le probleme survient sur ces deux jeux car la il faut cliquer rapidemment et un peu partout sur l ecran.en temps normal donc le probleme ne se fait pas sentir.

ma version de kubuntu c est la hardy 8.04.
version noyau 2.6.24.19.generic
la souris est branchée classiquement avec la fiche standart je pense que c est ce que tu appelles ps/2.
j ai une imprimante sur un port usb .
le message dmsg | tail maintenant j ai ca .
[email protected]:~$ dmesg | tail
[ 672.281587] psmouse.c: bad data from KBC - bad parity
[ 673.535545] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 673.542967] psmouse.c: resync failed, issuing reconnect request
[ 723.115390] psmouse.c: bad data from KBC - bad parity
[ 724.024283] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 724.032087] psmouse.c: resync failed, issuing reconnect request
[ 734.646552] psmouse.c: bad data from KBC - bad parity
[ 734.841991] psmouse.c: bad data from KBC - bad parity
[ 735.926721] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 735.934008] psmouse.c: resync failed, issuing reconnect request
[email protected]:~$
j ai essayée la manoeuvre ici plusieurs et voila ce que ca donne.
en esperant t eclairer un peu plus!
captnfab

Re: problemes de souris??

par captnfab »

Bonjour,

Le problème est connu avec les souris PS/2 et certaines versions du noyau.
En attendant une correction du bug, l'utilisation d'une souris USB devrait faire l'affaire.

Désolé pour toi. Si j'ai plus d'infos je te dis, mais je ne suis pas vraiment de taille à corriger le bug moi-même.
Avatar de l’utilisateur
mélodie
Messages : 1491
Inscription : 14 janv. 2007 00:29
Localisation : Pyrénées

Re: problemes de souris??

par mélodie »

sunday4000 a écrit :# xorg.conf (X.Org X Window System server configuration file)
(...)
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection
Il manque ZAxisMapping dans cette section. Essaie de commenter cette section (mettre un #devant chaque ligne, pour rendre chaque ligne inactive), et de mettre ça à la suite pour remplacer ce bloc de texte:
Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5 6 7"
EndSection
Chez moi il y a "4 5" mais je ne joues pas. J'ai déjà eu "4 5 6 7" sur une autre config il y a un certain temps, tu peux essayer les deux façons sur quelques sessions d'utilisation.

Si tu changes les paramètres de xorg.conf au cours d'une session, il te faut de déloguer/reloguer pour recharger la configuration. (Inutile de rebooter donc).

Si tu veux passer ta souris ps2 en USB, il existe des adaptateurs qui ne coûtent pas cher pour ça. Hormis le "hotplug", et si ta souris supporte d'être connectée sur un adaptateur, je ne sais par contre pas ce que tu y gagneras.
Règles à respecter sur le forum Si vous ne savez pas comment poster, cliquez ici !
(Et tout particulièrement la section «À lire avant de poster, en 5 points de Capitaine Fab»)

Texte culte
:
Comment Poser Les Questions De Manière Intelligente
sunday4000

Re: problemes de souris??(resolu)

par sunday4000 »

bonjour tout le monde!! et bien j 'ai simplement essayé de changer ma souris pour une usb.
ca marche sans soucis donc il y a bien un bug avec les souris Ps/2.
Merci a vous deux pour votre aide.
captnfab

Re: problemes de souris??(resolu)

par captnfab »

Ok, merci pour le retour. Cela confirme nos soupçons.

J'espère pour toi que le problème sera corrigé sous peu, c'est dommage de ne pas pouvoir utiliser le PS/2
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »