Petit problème de connexion internet.....

Des questions pour configurer votre réseau, Wifi, installer un serveur, sécuriser votre machine ?

Modérateur : Mods GNU/Linux

yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Petit problème de connexion internet.....

par yuksel »

Bonjour, je viens de passer à linux (ubuntu dernière version) en dual boot avec windows
Je branche en ethernet et lance firefox : rien......
J'ai une carte wifi ralink RT 2500 sur mon packard bell W3110
L'ordi détecte mon réseau sans fil, avec la barre de sensibilité, mais lorsque je lance firefox ça ne marche pas....
J'ai comme FAI FREE, il y a 2 portables qui tourne à la maison, sur la free le mode routeur est activé, cela marche tres bien avec windows.

Je précise que j'ai attribué une adresse fixe à chaque ordi
Si quelqu'un peut m'aider
Merci par avance
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

Bonjour Yuksel,

Je n'ai pas bien compris, tu utilises un câble ou tu utilises le WiFi ?
Dans le deuxième cas, est-ce que tu as configuré Ubuntu pour se connecter à ta Freebox par le WiFi ?
Dans le premier cas, essaye peut-être en démarrant câble branché ?

Donne nous plus de détail, on pourra alors regarder le problème plus facilement :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Lorsque j'ai installé ubuntu sur mon portable, j'ai branché le cable ethernet comme précisé sur un tutorial
Une fois installé, lorsque je lance firefox il ne s'ouvre pas. mon pc étant aussi équipé du wifi avec une carte Ralink rt 2500, j'ai débranché le cable ethernet et essayé de paramétrer le wifi: je détecte mon réseau free mais firefox ne marche toujours pas !!!!

En résumé:
cable ou wifi: pas de connexion internet......

je précise que je débute.....
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

Bien, on va commencer par faire fonctionner le câble, c'est normalement plus simple. Après, si tu veux, on regardera le Wifi;

Premièrement, est-ce que tu as essayé de redémarrer Ubuntu en gardant le câble branché ?
En effet, je suppose que par défaut, Ubuntu regarde l'état du câble au démarrage seulement.

Sinon, on peut essayer la chose suivante.
D'abord, il te faut lancer un « terminal ». Pour ce faire, tu vas dans le menu, dans accessoires et tu dois trouver « terminal » ou quelque chose qui y ressemble (attention, il y a aussi terminal administrateur, ça n'est pas lui dont je parle).
Quand tu l'ouvres, une fenêtre noire apparaît, avec le nom de la machine, ton nom d'utilisateur un ~ et un $
  1. tapes :

    Code : Tout sélectionner

    sudo invoke-rc.d networking restart

    et regarde à nouveau si Firefox fonctionne
  2. sinon, tapes :

    Code : Tout sélectionner

    sudo dhclient eth0
    et regarde à nouveau si Firefox fonctionne.
  3. s'il ne fonctionne toujours pas, tapes

    Code : Tout sélectionner

    ifconfig && sudo cat /etc/network/interfaces
    et recopies le contenu dans une réponse à ce message :)
Fais-nous savoir si 1 ou 2 a fonctionné. Si tu as des problèmes pour faire tout ça, n'hésite pas à nous poser des questions.

PS: le mot de passe qui peux t'être demandé quand tu tapes une de ces commandes est ton mot de passe d'utilisateur.

Courage :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Ok, merci pour les tuyaux que j'appliquerai des jeudi soir et je te tiens au courant
Merci Capitaine Fab
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

Pas de prob, à jeudi ou à plus tard :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Voici du nouveau.....
J'ai essayé de taper les lignes dans le terminal et lorsqu'on me demande mon mot de passe: impossible de le taper !! comme si le clavier ne marchait pas....
La bonne nouvelle est que j'ai bidouillé et réussi à avoir internet mais qu'en wifi.....par ethernet ça marche pas.
J'attends vos instructions Capitaine !!!!!!
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

Hello Yuksel
yuksel a écrit :J'ai essayé de taper les lignes dans le terminal et lorsqu'on me demande mon mot de passe: impossible de le taper !! comme si le clavier ne marchait pas....
En informatique, tout n'est qu'illusion jeune padawan
Hum... oui, en fait, ton mot de passe ne s'affiche tout simplement pas quand tu tapes. Tu préférerais sans doute avoir des petites étoiles, mais non, même pas d'étoiles :) C'est la vie, il faut savoir taper des mots de passe sans étoiles. Et regarder des ciels sans mots de passe PDT_013
yuksel a écrit :La bonne nouvelle est que j'ai bidouillé et réussi à avoir internet mais qu'en wifi.....par ethernet ça marche pas.
Bien, ça prouve que tu te débrouilles pas mal :)
yuksel a écrit :J'attends vos instructions Capitaine !!!!!!
Ben, moi j'aurais tendance à dire... maintenant que tu sais que les étoiles n'existent pas, essaye de refaire les manips que je t'ai données :)
Pour ne pas interférer, coupe ta carte wifi pdt ce temps :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Re......toujours pas d'internet avec le cable......donc je poste le résultat de la commande que tu m'as donné Capitaine !!!

Ci-dessous :

eth0 Link encap:Ethernet HWaddr 00:40:d0:86:43:95
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
Interruption:21 Adresse de base:0xe000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:2562 erreurs:0 :0 overruns:0 frame:0
TX packets:2562 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:128100 (125.0 KB) Octets transmis:128100 (125.0 KB)

wlan0 Link encap:Ethernet HWaddr 00:10:60:62:c8:1a
inet adr:192.168.0.11 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: 2a01:e35:2efe:de50:210:60ff:fe62:c81a/64 Scope:Global
adr inet6: fe80::210:60ff:fe62:c81a/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:4993 erreurs:0 :0 overruns:0 frame:0
TX packets:4332 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:5765682 (5.4 MB) Octets transmis:592008 (578.1 KB)

wmaster0 Link encap:UNSPEC HWaddr 00-10-60-62-C8-1A-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

Je cherche aussi à installer l'équivalent de msn et je cherche aussi à faire fonctionner ma webcam (LOGITECH)
Merci
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

yuksel a écrit :Re......toujours pas d'internet avec le cable......donc je poste le résultat de la commande que tu m'as donné Capitaine !!!
Bien bien :)
ce que tu m'as envoyé là est la sortie de « ifconfig », mais il manque le contenu du fichier "/etc/network/interfaces", que tu peux obtenir en tappant "sudo cat /etc/network/interfaces".

yuksel a écrit :Je cherche aussi à installer l'équivalent de msn et je cherche aussi à faire fonctionner ma webcam (LOGITECH)
Crée un autre topic pour ça. Ainsi, les autres utilisateurs qui ont les mêmes questions que toi pourront s'y retrouver plus facilement.
À propos de ça, jette un œil ici : viewtopic.php?f=71&t=2 et particulièrement aux 5 points. Un joli petit nom pour ce sujet serait par exemple « [Ubuntu] Problème connexion FreeBox câble et WiFi (en cours) »
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Voila le résultat de la commande tapée capitaine

auto lo
iface lo inet loopback
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

yuksel a écrit :Voila le résultat de la commande tapée capitaine
auto lo
iface lo inet loopback
Ok, bien :)
Euh, appelle moi plutôt Fab que capitaine hein... :)

Donc, il faut rajouter quelques lignes à ce fichier.

Quelle est l'IP fixe attribuée à cet ordi ? (ip_de_lordi)
Quelle est l'IP de la freebox ? (ip_freebox)
Quels sont les serveurs DNS que tu utilises ? (ip_dns1, ip_dns2)

Commence par te connecter avec le WiFi, et tapes cette commande :

Code : Tout sélectionner

sudo aptitude install resolvconf
Ensuite, il faut modifier le fichier d'interfaces, pour ça :

Code : Tout sélectionner

sudo nano /etc/network/interfaces
Descends à la fin du fichier et ajoute les lignes suivantes :

Code : Tout sélectionner

iface ether-freebox inet static
  address ip_de_lordi
  netmask 255.255.255
  gateway ip_freebox
  dns-nameservers ip_dns1 ip_dns2

auto eth0=ether-freebox
(En remplaçant bien entendu les ip par leur valeurs)
Sauvegarde : Ctrl + O et Entrée

Vérifie que le WiFi est bien désactivé.
Redémarre le réseau :

Code : Tout sélectionner

sudo invoke-rc.d networking restart
Donne des nouvelles :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

Re.....lorsque je tape la commande: sudo invoke-rc.d networking restart , j'ai cela :

* Reconfiguring network interfaces...
/etc/network/interfaces:15: option with empty value
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:15: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"
[fail]

Help !!!!!!
Avatar de l’utilisateur
captnfab
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)

Re: Petit problème de connexion internet.....

par captnfab »

yuksel a écrit :/etc/network/interfaces:15: option with empty value
ifdown: couldn't read interfaces file "/etc/network/interfaces"
Re
Qu'y a-t-il à la ligne 15 de ton fichier "/etc/network/interfaces" ?
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]
yuksel
Messages : 39
Inscription : 24 oct. 2007 14:15

Re: Petit problème de connexion internet.....

par yuksel »

J'y vois rien moi à la ligne 15......
Voila le contenu du fichier "/etc/network/interfaces"

auto lo
iface lo inet loopback






iface ether-freebox inet static
192.168.0.11
netmask 255.255.255
gateway 192.168.0.254
dns-nameservers 212.27.54.252 212.27.53.252

auto eth0=ether-freebox



iface eth0 inet dhcp
address 192.168.0.254
netmask 255.255.255.0

auto eth0
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Réseau sous GNU/Linux »