Problème d'ipv4 / ipv6

Ici on parle de réseau, configurations, problèmes etc..

Modérateur : Mods Windows

powo

Problème d'ipv4 / ipv6

par powo »

Hello ! Je viens vers vous, car je galère depuis quelques temps, voir quelques mois avec une adresse ipv6 qui viens ce mettre sur mon serveur, alors qu'il est incompatible avec l'ipv6. Je l'ai désactivé dans ma box, puis sous Windows.

Il faut quand même que je vous dise, qu'avec un autre ordinateur travaillant sous XPpro, il n'y a aucun problème, j'ai automatiquement une adresse ipv4. Mais lorsque je travail sous Windows 7 ou Vista, je n'ai que l'adresse ipv6.

Je suis abonné chez SFR (neufBox NB4-FXC-r2)

Pour désactivé l'ipv6 de la configuration de la neufbox, ce n'ai pas sorcier, il suffit de décoché 2 cases.
Dans Windows 7, soit on passe par le site de Microsoft, puis on suit les indications, soit :
On va dans : (Panneau de configuration -> Réseau et Internet -> Connexion réseau) désactivé l'ipv6....

Puis : également ajouter une clé dans la base base de registre, dans l'arborescence suivante:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\

DWORD (32-bit) > DisabledComponents en créant une clé "0xffffffff" pour désactiver tous les composants de IPv6, sauf l’interface de bouclage IPv6. Cette valeur configure également Windows Vista pour utiliser Internet Protocol version 4 (IPv4) au lieu du protocole IPv6 dans stratégies de préfixe.

Et j'ai bien redémarré ma machine pour une bonne prise en compte des changements....

Mais rien n'y fait....

Mais si je fais ça, je ne vois même plus mon serveur...... PDT_013

J'ai comparé les registres de XP et Windows7 ; sous XP, les clés HKLM\system\CurrentControlSet\Services\TCPIP6 et TCPIP6TUNNEL sont absentes ; il suffirait peut-être de les supprimer sous Windows 7 ?
Mais il y a peut être un risque d'instabilité du système.

J'ai donc pris mon portable "Windows7", puis je suis allé chez mes parents pour essayer avec "orange" et là ça fonctionne, sans faire aucune modification....Il me donne bien une adresse ipv4.
Dés que je suis rentré chez moi, retour à la case départ.... Il me donne une adresse ipv6.... PDT_009

Ce que je ne comprend pas c'est que j'ai bien une adresse ipv4 lorsque je lance le jeu, donc tout fonctionne parfaitement....
Mais il me donne une adresse ipv6 lorsque je lance le jeu avec mon serveur perso... PDT_013

Donc quelqu'un a déjà rencontré ce problème ou à une idée, elle sera la bienvenue.... PDT_001

Merci
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

Trop confus, ça bloque dès la première phrase.

"une adresse ipv6 qui viens ce mettre sur mon serveur"

De quel serveur parlez-vous ?
Comment obtenez-vous cette information ?
powo

Re: Problème d'ipv4 / ipv6

par powo »

Ok ! PDT_011 Je suis sur freelancer, un mod basé sur un jeu en réseau.... http://www.stargate-infini.com

Je fais du moding sur ce mode pour apporter des modifications et des améliorations... Enfin bref! j'ai un serveur perso comme tout les modeurs de notre communauté pour effectuer ces changements et surtout pour effectuer des tests après modifications, voir si bug ou pas .... Il existe donc un serveur en commun pour tout les joueurs du monde (ou là ! je n'ai pas de souci), et ce même serveur fonctionne avec un "FLserver" donc (mon serveur perso) sous "Flhook" (Je ne sais pas pas si tout cela vous sera utile, ou vous sera compréhensible, mais qui demande question, obtient des réponses)....
Cela ne vous avancera pas plus, car ce n'est pas le souci.... C'est juste que depuis que je suis passé sous Windows 7 j'ai ce souci, alors que je ne l'avais pas sous Windows XP.
Mais ne vous bloquez pas sur la première phrase, car le reste explique le pourquoi de ma demande... PDT_019
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

Via la neufbox, vous avez de l'IPv4 sur XP Pro alors qu'avec Vista & 7 c'est de l'IPv6 ; malgré paramétrages / postes + box. Vous testez depuis une LiveBox avec Windows 7 et à votre surprise le DHCP attribue de l'IPv4.

C'est ça ?
powo

Re: Problème d'ipv4 / ipv6

par powo »

Tout à fait...
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

La désactivation IPv6 de la neufbox est-elle bien effective ?
Avez-vous redémarré la box ? Qu'indique le statut de l'IPv6 ?

Depuis le portable "Windows7", Menu "Démarrer" → Exécuter : cmd.exe
Saisir ipconfig /all > "%tmp%\ipcfg.log" & notepad "%tmp%\ipcfg.log"
Relire la syntaxe plusieurs fois avant de valider avec la touche "Entrée".
Le bloc-notes va s'ouvrir, copier le contenu dans votre prochaine réponse.

Avez-vous testé de forcer l'IPv4 en paramétrant l'interface sur IP fixe ?
powo

Re: Problème d'ipv4 / ipv6

par powo »

Dans la config de ma box, il est bien marqué que internet ipv6 est bien désactivé. et j'ai bien rebouté ma box par la suite...

Le portable :
Configuration IP de Windows

Nom de l'h“te . . . . . . . . . . : Schwarzi-PC
Suffixe DNS principal . . . . . . :
Type de noeud. . . . . . . . . . : Hybride
Routage IP activ‚ . . . . . . . . : Non
Proxy WINS activ‚ . . . . . . . . : Non

Carte r‚seau sans fil Connexion r‚seau sans filÿ:

Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Qualcomm Atheros AR5B95 Wireless Network Adapter
Adresse physique . . . . . . . . . . . : 88-9F-FA-42-98-77
DHCP activ‚. . . . . . . . . . . . . . : Oui
Configuration automatique activ‚e. . . : Oui
Adresse IPv4. . . . . . . . . . . . . .: 192.168.1.49(pr‚f‚r‚)
Masque de sous-r‚seau. . . .ÿ. . . . . : 255.255.255.0
Bail obtenu. . . . . . . . .ÿ. . . . . : lundi 8 d‚cembre 2014 18:52:52
Bail expirant. . . . . . . . .ÿ. . . . : mardi 9 d‚cembre 2014 18:53:31
Passerelle par d‚faut. . . .ÿ. . . . . : 192.168.1.1
Serveur DHCP . . . . . . . . . . . . . : 192.168.1.1
Serveurs DNS. . . . . . . . . . . . . : 192.168.1.1
NetBIOS sur Tcpip. . . . . . . . . . . : Activ‚

Carte Ethernet Connexion au r‚seau local :

Statut du m‚dia. . . . . . . . . . . . : M‚dia d‚connect‚
Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Atheros AR8132 PCI-E Fast Ethernet Controller (NDIS 6.20)
Adresse physique . . . . . . . . . . . : 70-5A-B6-D8-20-D4
DHCP activ‚. . . . . . . . . . . . . . : Oui
Configuration automatique activ‚e. . . : Oui

Carte Tunnel isatap.{4CD46305-C3DF-4533-8248-241BBDC64D45} :

Statut du m‚dia. . . . . . . . . . . . : M‚dia d‚connect‚
Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Carte Microsoft ISATAP
Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP activ‚. . . . . . . . . . . . . . : Non
Configuration automatique activ‚e. . . : Oui

Mon PC principal :

Configuration IP de Windows

Nom de l'h“te . . . . . . . . . . : Stephane-PC
Suffixe DNS principal . . . . . . :
Type de noeud. . . . . . . . . . : Hybride
Routage IP activ‚ . . . . . . . . : Non
Proxy WINS activ‚ . . . . . . . . : Non

Carte Ethernet Connexion r‚seau Bluetooth :

Statut du m‚dia. . . . . . . . . . . . : M‚dia d‚connect‚
Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : P‚riph‚rique Bluetooth (r‚seau personnel)
Adresse physique . . . . . . . . . . . : 00-26-83-14-AF-BE
DHCP activ‚. . . . . . . . . . . . . . : Oui
Configuration automatique activ‚e. . . : Oui

Carte Ethernet Connexion au r‚seau local :

Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
Adresse physique . . . . . . . . . . . : F4-6D-04-19-35-6E
DHCP activ‚. . . . . . . . . . . . . . : Oui
Configuration automatique activ‚e. . . : Oui
Adresse IPv4. . . . . . . . . . . . . .: 192.168.1.60(pr‚f‚r‚)
Masque de sous-r‚seau. . . .ÿ. . . . . : 255.255.255.0
Bail obtenu. . . . . . . . .ÿ. . . . . : lundi 8 d‚cembre 2014 06:09:17
Bail expirant. . . . . . . . .ÿ. . . . : mardi 9 d‚cembre 2014 18:09:16
Passerelle par d‚faut. . . .ÿ. . . . . : 192.168.1.1
Serveur DHCP . . . . . . . . . . . . . : 192.168.1.1
Serveurs DNS. . . . . . . . . . . . . : 192.168.1.1
NetBIOS sur Tcpip. . . . . . . . . . . : Activ‚

Carte Tunnel isatap.{0BB690EA-22F0-4111-85D4-ED4D782CA58B} :

Statut du m‚dia. . . . . . . . . . . . : M‚dia d‚connect‚
Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Carte Microsoft ISATAP
Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP activ‚. . . . . . . . . . . . . . : Non
Configuration automatique activ‚e. . . : Oui

Carte Tunnel Teredo Tunneling Pseudo-Interface :

Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP activ‚. . . . . . . . . . . . . . : Non
Configuration automatique activ‚e. . . : Oui
Adresse IPv6. . . . . . . . . . .ÿ. . .: 2001:0:5ef5:79fd:24a7:2562:aef1:eaf6(pr‚f‚r‚)
Adresse IPv6 de liaison locale. . . . .: fe80::24a7:2562:aef1:eaf6%12(pr‚f‚r‚)
Passerelle par d‚faut. . . .ÿ. . . . . : ::
NetBIOS sur TCPIP. . . . . . . . . . . : D‚sactiv‚

Carte Tunnel isatap.{9B688719-85BF-4E0F-9CB5-91046D6798B7} :

Statut du m‚dia. . . . . . . . . . . . : M‚dia d‚connect‚
Suffixe DNS propre … la connexion. . . :
Description. . . . . . . . . . . . . . : Carte Microsoft ISATAP #2
Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP activ‚. . . . . . . . . . . . . . : Non
Configuration automatique activ‚e. . . : Oui


Avez-vous testé de forcer l'IPv4 en paramétrant l'interface sur IP fixe ? Non, je ne pense pas, cela consiste à quoi ?
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

Les adresses assignées par votre DHCP semblent en IPv4.
Schwarzi-PC (192.168.1.49) & Stephane-PC (192.168.1.60)
Et la plage d’adresses n'est pas farfelue, tout semble OK.

Vous utilisez correctement les DNS de votre FAI.
Et votre IP ( internet) xxx.xxx.xxx.77.rev.sfr.net est en IPv4.

Il est où le problème d'adressage ?

La seule mention d'IPv6 vient de l'interface Teredo ( activée par défaut )
A la limite si vous ne l'utilisez pas sur Stephane-PC, désactivez la.

Démarrer → Exécuter saisir cmd.exe,
Clique-droit "Exécuter en tant qu'Administrateur"
Saisir netsh interface teredo set state disable
Puis redémarrer le PC.
powo

Re: Problème d'ipv4 / ipv6

par powo »

ѠOOT a écrit :Il est où le problème d'adressage ?
Ben là ! Est mon problème, et même beaucoup de mes collègues bosses dessus sans résultat, alors qu'ils travailles eux même sous Windows 7..... PDT_009
ѠOOT a écrit :La seule mention d'IPv6 vient de l'interface Teredo ( activée par défaut )
A la limite si vous ne l'utilisez pas sur Stephane-PC, désactivez la.
Mais même si je la désactive, ceci ne réglera pas le problème, vue que mes autres ordinateurs on le même souci... PDT_013

Heureusement que je m'en suis refais un autre avec XP, mais c'est la galère pour travailler efficacement.... :grrr:
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

Problème ? A mon avis derrière tout ça il y a surtout un problème de compréhension.
Vous êtes en IPv4. La configuration est correcte, aussi bien vos postes que votre box.

Je reviens sur les faits constatés, vous avez écrit: Ce que je ne comprend pas c'est que j'ai bien une adresse ipv4 lorsque je lance le jeu, donc tout fonctionne parfaitement.... Mais il me donne une adresse ipv6 lorsque je lance le jeu avec mon serveur perso...

Si j'interprète, mot pour mot, les symptômes ( message d'erreur ou je ne sais quoi d'ailleurs ) se manifestent lorsque vous tentez d'établir une connexion à votre propre serveur Stargate-Infini car... toujours d'après le serveur, vous seriez connecté depuis une IPv6, laquelle n'est pas supportée par le jeu.

Est-ce la nature exacte du "problème" ?
powo

Re: Problème d'ipv4 / ipv6

par powo »

Bon ! Je n'ai pas de réponse à votre question, d’ailleurs SFR et personne n'y arrive... PDT_009
Je pense que je vais passer par un autre opérateur qui à comme support orange, comme ça je n'aurai plus de problèmes.... PDT_001
De toutes manières, je suis sûr que le problème vient de SFR ... PDT_019
chef

Re: Problème d'ipv4 / ipv6

par chef »

Mais même si je la désactive, ceci ne réglera pas le problème, vue que mes autres ordinateurs on le même souci... PDT_013
bonsoir,
je suis pas sur de comprendre , as tu regardé avec la commande de ѠOOT sur les autre pc .
Teredo est installé par défaut sous Windows Vista, Windows 7 et Windows 8 , (et donc pas sous xp) !!!
ѠOOT

Re: Problème d'ipv4 / ipv6

par ѠOOT »

Bonjour,

Si c'était SFR, d'autres joueurs auraient les mêmes problèmes.
Personne n'y arrive car ce n'est peut être pas reproductible.
C'est déjà assez compliqué de comprendre le "problème".

Peut-être n'est-ce qu'un bogue sur Stargate-Infini.

Bon courage pour la suite.
powo

Re: Problème d'ipv4 / ipv6

par powo »

Oui ! merci pour vos réponses, et pour l'aide que vous m'avez apporté, car je vois que c'est un problème important, que certains pourraient rencontrer, vue l'avancement de l'ipv6.... PDT_010
Donc voici mon point de vue :
Certains fournisseurs, (comme S.R, pour ne pas le citer).... Devance cette technologie sans ce soucier de l'actuel...
Ensuite certains fournisseurs de "serveur" doivent aujourd'hui ce mettre à jour pour cette nouvelle technologie, mais trop faible devant la rémunération à donner...
Le choix et fait......
Enfin! si aujourd'hui on n'y connaît rien en informatique, on n'a plus qu'a payer...............
Je connaît le site de malekal depuis quelques années maintenant, et merci à vous tous de le faire vivre et de le faire durer, car il rend service à beaucoup... Surtout que des "pro" sont là ! pour nous répondrent.... PDT_003
Merci

Revenir à « Réseau »