Pour demander de l'aide, vous devez vous créer un compte et vous connecter. Utilisez les boutons sociaux ci-dessous depuis ce lien : S'inscrire sur le forum
Plus d'informations : Comment demander de l’aide sur le forum

(RESOLU) Iceweasel ne se lance plus

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

(RESOLU) Iceweasel ne se lance plus

Message par eggregor »

Amis du jour, bonjour,
Et bonne année en cette veille d'épiphanie !

Après un arrêt machine normal tout bête, au redémarrage quelques heures plus tard : plus moyen de lancer iceweasel, ni depuis X, ni depuis la console. Sous X, il y a le "chrono" qui tournicote 30 secondes, et plus rien.

En console j'ai un retour exec : 193 : ./firefox-bin: not found -Ne vous marrez pas, je suis incapable de me rappelerla commande qui permet d'aller voir à quoi çà correspond.
(Pour mémoire bécane amd64 avec XP + Mint + Sid installée avec l'aide du capitaine )

J'ai comparé ceci entre Sid64 qui coince, et Sid32 et Ubuntu qui roulent :
Sur la machine qui coince
[email protected]: ls /home/eggregor/.mozilla
drwx------ 3 1000 1000 4096 firefox
drwxr-xr-x 99 1000 1000 20480 ..
drwx------ 4 1000 1000 4096 .
-rw-r--r-- 1 1000 1000 335 appreg
drwx------ 4 1000 1000 4096 extensions

Sur les autres machines
/.mozilla
extensions firefox
(ce contenu semble être celui qu'on trouve généralement)

En déplaçant/renommant /.mozilla je ne trouve aucun changement, sauf évidemment, que si je lance firefox sous MINT je perds tout marque-pages et synchro par Xmarks.
J'ai donc remis le dossier à sa place, pour redonner à Mint sa splendeur, en continuant de chercher, mais l'affaire dure depuis l'année dernière (!) et ..... ma bouée se dégonfle.

Le contenu de ce fichier peut-il être le problème.
Est-il venu par SID ou par MINT (le /home étant commun)? et pourquoi ce souci sans aucun changement de ma part, hormis les upgrades depuis les dépôts ?

Une fois de plus je m'en remets à vos connaissances, et je vous en remercie d'avance. PDT_014
Pièces jointes
local_bin.tar.gz
J'espère que çà colle, salut Captain !
(76.27 Kio) Téléchargé 57 fois
Dernière modification par eggregor le 08 janv. 2011 15:49, modifié 2 fois.

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Plop Eggregor :)
Bonne année 2011 et bonne santé !

Mhh… « exec : 193 : ./firefox-bin: not found  »
Je vois deux explications à ce message :
1) le fichier firefox-bin (normalement présent dans le paquet "iceweasel") n'est pas présent
2) ce fichier est "cassé", le packager ayant du faire une bêtise.

Je te conseille de faire un "aptitude update" puis un "aptitude reinstall iceweasel". Ça devrait résoudre le problème. Sinon, reviens nous le dire :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

Replop captain,
Tu es un ami précieux.
A vrai dire j'avais tenté sans le dire ici un "aptitude reinstall" avant hier, sans résultat.

La situation ce soir est celle-ci :
En console utilisateur, quelle que soit la commande essayée, toujours la réponse exec : 193...
Je viens de faire une seconde réinstall à tt hasard, çà mange pas de pain, et il y a un changement :

Dans mes recherches, plusieurs avis déterminent la cause de non-démarrage dans le "profile".

Dans mes essais aujourd'hui, j'ai constaté que je peux lancer iceweasel depuis root, qui n'a pas je suppose de profil dans firefox, ce qui isolerait ainsi la cause au profil. Supposition de "moi-même personnellement".

J'ai donc lancé la commande:

"$ firefox -P" qui renvoie toujours la même erreur exec : 193... de me firefox -safe-mode et d'autres.
et "# firefox -P" qui ouvrait avant la 2ème réinstall une fenêtre "choose user profile" qui avait l'inconvénient de ne lister aucun profil.

Et qui maintenant en root, affiche la fenêtre avec un profil "default" que je peux modifier ou supprimer, il y a donc un progrès, que je testerai dès l'aube. ( pour autant le démarrage ne se fait tjrs pas)

Je fais peut-être fausse route, ton point de vue prévaudra.
Merci captain à d'main.

PS du d'main: suite à une coupure de courant j'ai eu bien du mal à démarrer cette fois ma seconde machine où "nous" avions installé grub sur une partition, celle de squeeze, avec un script que tu m'avais concocté pour parvenir à lancer sid.
Plus moyen de marcher. Heureusement j'ai gravé cet été un super_grub_disk_hybrid qui m'a permis de relancer, mais je suis sous squeeze ! enfin çà marche.
Je suis allé voir les bugs d'iceweasel, il y a un "iceweasel : fail to start with no errror if ~/.mozilla has wrong permissions"

Avec ma connaissance de l'anglais je doute, mais n'y aurait-il point correspondance avec mon affaire.
@plus

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

Re,
Juste une info complémentaire, voilà ce qui me semble être le firefox-bin, un lien symbolique ?
Non, juste un lien, pas symbolique, il n'a pas de @ final.
Qui est identique sur les deux machines. Blue_PDT_01_14

[email protected]:~$ ls -la /usr/lib/iceweasel/firefox-bin
lrwxrwxrwx 1 root root 33 15 août 17:34 /usr/lib/iceweasel/firefox-bin -> ../xulrunner-1.9.1/xulrunner-stub

Je complète : Après bien des recherches je soupçonne "la cible" ce xulrunner, d'être la cause de mes désagréments.

J'ai viré complétement iceweasel 3.5.16.3 qui doit être la dernière version parvenue dans ma machine pendant l'upgrade précédent l'arrêt.
Je me suis lancé dans l'install de iceweasel 4 beta qui demande xulrunner-2.0.
Tout s'est bien passé, ajout dépôt, import-export de la clé, et finalement patatra avec des dépendances non satisfaites, notamment un conflit depuis libcairo2, bibliothèque graphique vectorielle impliquée semble-t-il avec Gnome.

( serait-ce aussi la cause de l'autre histoire de points de coordonnées avec f-spot? )

Je fais une pose.
Si tu as une idée ?

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Hop. Donc, un peu de théorie.

firefox-bin est bien un lien *symbolique* vers xulrunner, c'est à dire que c'est un « pointeur » vers xulrunner. Le lien symbolique s'oppose au lien physique, qui consiste lui en deux fichiers partageant le même contenu.

Donc, pour éviter les conflits, revenons à la version 3.6 de firefox.
Tu purges la version beta 4 et les trucs qui se sont installés avec.

Concernant firefox, tu réinstalles iceweasel (la version que tu as dans les dépots), puis tu fais un

Code : Tout sélectionner

aptitude update
aptitude reinstall ~i~Riceweasel
Cela devrait réinstaller iceweasel et toutes ses dépendances (dont xulrunner).

Fais-moi signe si ça ne marche tjrs pas :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

Pataglop Captain,
Merci de ton aide, mais çà ne s'ouvre toujours pas.
Néanmoins il y a une piste, tu interpréteras mieux que moi.
Je pars pour la journée.

debian:/home/eggregor# aptitude reinstall ~i~Riceweasel
Les paquets suivants seront RÉINSTALLÉS :
debianutils fontconfig iceweasel libc6 libgcc1 libglib2.0-0 libgtk2.0-0
libnspr4-0d libstdc++6 procps xulrunner-1.9.1
0 paquets mis à jour, 0 nouvellement installés, 11 réinstallés, 0 à
enlever et 0 non mis à jour.
Il est nécessaire de télécharger 16,9 Mo d'archives. Après dépaquetage,
0 o seront utilisés.
16,9 Mo téléchargés en 1min 17s (218 ko/s)
E: Impossible d'effectuer la configuration immédiate de « libgcc1 ».
Veuillez consulter la page de manuel apt.conf(5) et notamment la section
à propos de APT::Immediate-Configure, pour plus d'informations. (2)

debian:/home/eggregor# apt-cache policy xulrunner
xulrunner:
Installé : (aucun)
Candidat : 1.8.1.14-3.1

Table de version :
1.8.1.14-3.1 0
500 http://mirror.home-dn.net/debian-multimedia/ squeeze/main
i386 Packages

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Bon, on rentre un peu dans les méandres du fonctionnement du système de dépendances là.

Alors, si tu fais « man 5 apt.conf », comme indiqué, tu apprends que :
man 5 apt.conf a écrit : Immediate-Configure
La valeur par défaut de ce réglage est « on » ce qui conduira APT à installer les paquets essentiels et importants dès que
possible pendant les opérations d'installation ou de mise à jour. Cela permet de limiter les conséquences de l'échec d'un appel
à dpkg(1) : si cette option est désactivée, APT gérera un paquet important de la même manière qu'un paquet « extra » ; entre le
dépaquetage du paquet important A et sa configuration pourront prendre place de nombreux autres opérations de dépaquetage ou de
configuration. Ainsi, si le paquet B, qui n'a pas de rapport avec A, provoque une erreur de dpkg(1) (p. ex. en cas d'erreur dans
les scripts du responsable), le paquet A sera alors dans l'état installé mais non configuré et chaque paquet qui en dépend ne
fonctionnera plus nécessairement puisque sa dépendance n'est pas satisfaite. Le marqueur de configuration immédiate sera aussi
utilisé pour toute dépendance qui peut créer un problème, par exemple les dépendances circulaires. En effet, utiliser le
marqueur de configuration immédiate revient à gérer une pré-dépendance. Il est donc possible, en théorie, qu'APT rencontre une
situation où il lui est impossible d'effectuer la configuration immédiate, qu'il se termine alors avec une erreur en faisant
référence à cette option afin que l'utilisateur puisse la désactiver temporairement pour retenter l'opération d'installation ou
de mise à jour. Il est à noter que « en théorie » indique ici que cette situation n'a été rencontrée que dans de rares cas, sur
des versions instables de distributions, la cause étant des dépendances incorrectes ou un système déjà dans un état instable. Il
est donc déconseillé de désactiver cette option sans réfléchir car la situation décrite précédemment n'est qu'un des cas où la
configuration immédiate permet de résoudre des situations complexes. Avant de tenter une opération telle que dist-upgrade avec
cette option désactivée, il est largement préférable d'essayer une opération install sur le paquet qu'APT ne peut configurer
immédiatement. Il est également conseillé de signaler ce type de problème dans le système de suivi de bogues de la distribution
utilisée afin qu'il soit étudié et corrigé.
Autrement dit, on va essayer de régler le problème en installant libgcc1 à part comme suit :

Code : Tout sélectionner

aptitude install libgcc1
Puis vérifier que le gestionnaire de paquets est dans un état sain avec

Code : Tout sélectionner

aptitude install -f
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

C'est fait captain, merci du tuyau.
Je n'avais pas eu le temps de regarder le man qui pour une fois est en français mais je je serais pas de toute façon parvenu à ta conclusion pour les commandes.
Je te refile la sauce édulcorée pour pas faire trop long :

aptitude install libgcc1
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

aptitude install -f
Les NOUVEAUX paquets suivants vont être installés :
bitpim bitpim-lib gnome-office{b}
0 paquets mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 4 976 ko d'archives. Après dépaquetage, 18,8 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
gnome-office: Dépend: inkscape (>= 0.47) mais il ne sera pas installé.
Dépend: simple-scan mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :
Conserver les paquets suivants dans leur version actuelle :
1) gnome-office [Non installé]

Accepter cette solution ? [Y/n/q/?] y
Les NOUVEAUX paquets suivants vont être installés :
bitpim bitpim-lib
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 4 958 ko d'archives. Après dépaquetage, 18,7 Mo seront utilisés.

Sélection du paquet bitpim-lib précédemment désélectionné.
Dépaquetage de bitpim-lib (à partir de .../bitpim-lib_1.0.7+dfsg1-2_i386.deb) ...

Pour moi, installer libgcc1 et trouver bitpim-1.0.7 à l'arrivée, tu comprends: çà me laisse pensif, pour pas dire pantois !
Mais la vérif finalement !!
$ apt-cache policy libgcc1
libgcc1: Installé : 1:4.4.5-10 Candidat : 1:4.4.5-10

Pour autant point de démarrage d'iceweasel.

Il y a une autre question qui me turlupine, pourquoi :
apt-cache policy xulrunner
xulrunner: Installé : (aucun) Candidat : 1.8.1.14-3.1

Et pourquoi :
locate xulrunner
/etc/alternatives/xulrunner-stub
/etc/alternatives/xulrunner-stub.1.gz
/usr/bin/xulrunner-1.9.1

Et si je refais :
~$ ls /usr/lib/iceweasel/firefox-bin
lrwxrwxrwx 1 0 0 33 /usr/lib/iceweasel/firefox-bin -> ../xulrunner-1.9.1/xulrunner-stub

Ce soir je me demande si "intellectuellement" j'avance ou je recule.
Honnêtement ?

Nos héros sortiront-ils vainqueurs ? :zen:

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Haha, sacré Eggregor :)

Bon, en fait, on avance. Je suis soulagé de voir que le problème avec libgcc1 n'était rien. Par contre, il a rendu ma commande inopérante, donc, pour palier à ça, et au passage résoudre une de tes interrogations, voici le feuilleton du soir:

D'abord, lecture :

Code : Tout sélectionner

aptitude show iceweasel/sid
Paquet : iceweasel
Nouveau : oui
État : non installé
Automatiquement installé : non
Version : 3.5.16-3
Priorité : optionnel
Section : web
Responsable : Maintainers of Mozilla-related packages <[email protected]>
Taille décompressée : 3 858 k
Dépend : libc6 (>= 2.2.5), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.10), libnspr4-0d (>= 1.8.0.10), libstdc++6 (>= 4.1.1), fontconfig, procps, debianutils (>= 1.16), xulrunner-1.9.1 (>= 1.9.1.16)
Suggère : ttf-lyx | latex-xft-fonts, xfonts-mathml, ttf-mathematica4.1, xprint, mozplugger, libgssapi-krb5-2 | libkrb53
Fournit : gnome-www-browser, www-browser
Description : Navigateur web basé sur Firefox
Firefox est une refonte du navigateur de Mozilla. Il est similaire à Galeon, K-Meleon et Camino, mais est écrit en utilisant le langage d'interface utilisateur XUL, et pensé pour être léger et multi-plates-formes.

Ce navigateur est basé sur le code source de Firefox avec des modifications mineures. Historiquement, il était précédemment connu sous les noms de Firebird et Phoenix.
Qu'apprend-t-on ici ? Que le paquet se nomme xulrunner-1.9.1 et non xulrunner. Donc, on va faire ce que j'espérais, à tort, que ma commande précédente fasse, c'est à dire réinstaller xulrunner:

Code : Tout sélectionner

aptitude reinstal xulrunner-1.9.1
Pouf.
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

Patapouf donc,
Feuilleton du matin, chagrin...

# aptitude reinstall xulrunner-1.9.1
Les paquets suivants seront RÉINSTALLÉS :
xulrunner-1.9.1
0 paquets mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 0 o/7 256 ko d'archives. Après dépaquetage, 0 o seront utilisés.
(Lecture de la base de données... 181725 fichiers et répertoires déjà installés.)
Préparation du remplacement de xulrunner-1.9.1 1.9.1.16-3 (en utilisant .../xulrunner-1.9.1_1.9.1.16-3_i386.deb) ...
OK
[email protected]:~$ iceweasel
exec: 193: ./firefox-bin: not found

Pour ne pas finir définitivement idiot : pour quoi apt-cache policy xulrunner me donne toujours la réponse "installé aucun"?

Et si finalement le gravier était ailleurs ? A plus captain.

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

eggregor a écrit :Pour ne pas finir définitivement idiot : pour quoi apt-cache policy xulrunner me donne toujours la réponse "installé aucun"?
Parce que c'est vrai.
C'est "xulrunner-1.9.1" qui est installé, et non pas "xulrunner". Regarde en détail le message d'erreur où j'ai graissé du texte.
eggregor a écrit :Et si finalement le gravier était ailleurs ?
Mhh…
Que donne

Code : Tout sélectionner

ls ls /usr/lib/xulrunner*/
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

C'est bien çà que tu demandes ? Parce que ls ls je ne l'ai pas !

ls /usr/lib/xulrunner*/
drwxr-xr-x 4 0 0 4096 .
lrwxrwxrwx 1 0 0 17 libmozjs.so -> ../libmozjs.so.0d
-rw-r--r-- 1 0 0 5784 javaxpcom.jar
lrwxrwxrwx 1 0 0 30 defaults -> ../../share/xulrunner/defaults
lrwxrwxrwx 1 0 0 16 libplc4.so -> ../libplc4.so.0d
lrwxrwxrwx 1 0 0 30 greprefs -> ../../share/xulrunner/greprefs
lrwxrwxrwx 1 0 0 25 res -> ../../share/xulrunner/res
drwxr-xr-x 2 0 0 4096 extensions
lrwxrwxrwx 1 0 0 28 chrome -> ../../share/xulrunner/chrome
lrwxrwxrwx 1 0 0 25 dictionaries -> ../../share/myspell/dicts
lrwxrwxrwx 1 0 0 17 libnspr4.so -> ../libnspr4.so.0d
-rw-r--r-- 1 0 0 107 dependentlibs.list
lrwxrwxrwx 1 0 0 17 libxpcom.so -> ../libxpcom.so.0d
lrwxrwxrwx 1 0 0 23 libgtkembedmoz.so -> ../libgtkembedmoz.so.0d
-rw-r--r-- 1 0 0 0 .autoreg
-rw-r--r-- 1 0 0 8284 libjavaxpcomglue.so
lrwxrwxrwx 1 0 0 15 libxul.so -> ../libxul.so.0d
lrwxrwxrwx 1 0 0 17 libplds4.so -> ../libplds4.so.0d
drwxr-xr-x 241 0 0 77824 ..
drwxr-xr-x 2 0 0 12288 components
drwxr-xr-x 3 0 0 4096 .
lrwxrwxrwx 1 0 0 17 libmozjs.so -> ../libmozjs.so.2d
lrwxrwxrwx 1 0 0 33 icons -> ../../share/xulrunner-1.9.1/icons
lrwxrwxrwx 1 0 0 36 defaults -> ../../share/xulrunner-1.9.1/defaults
-rwxr-xr-x 1 0 0 583 reportbug-helper-script
-rwxr-xr-x 1 0 0 19548 updater
-rwxr-xr-x 1 0 0 69456 xulrunner-stub
lrwxrwxrwx 1 0 0 36 greprefs -> ../../share/xulrunner-1.9.1/greprefs
-rwxr-xr-x 1 0 0 76656 xulrunner-bin
lrwxrwxrwx 1 0 0 31 res -> ../../share/xulrunner-1.9.1/res
lrwxrwxrwx 1 0 0 34 chrome -> ../../share/xulrunner-1.9.1/chrome
-rwxr-xr-x 1 0 0 37872 xpcshell
-rwxr-xr-x 1 0 0 10936 mozilla-xremote-client
lrwxrwxrwx 1 0 0 20 dictionaries -> ../../share/hunspell
-rwxr-xr-x 1 0 0 3858 xulrunner
-rw-r--r-- 1 0 0 12284 libxpcom.so
-rw-r--r-- 1 0 0 6 update.locale
-rwxr-xr-x 1 0 0 10459 run-mozilla.sh
lrwxrwxrwx 1 0 0 35 modules -> ../../share/xulrunner-1.9.1/modules
-rw-r--r-- 1 0 0 50 platform.ini
-rw-r--r-- 1 0 0 0 .autoreg
-rw-r--r-- 1 0 0 12994756 libxul.so
drwxr-xr-x 241 0 0 77824 ..
drwxr-xr-x 2 0 0 20480 components

Regret, j'essaie en root :
debian:/home/eggregor# ls ls /usr/lib/xulrunner*/
ls: impossible d'accéder à ls: Aucun fichier ou dossier de ce type
/usr/lib/xulrunner/:
chrome dictionaries libgtkembedmoz.so libplc4.so res
components extensions libjavaxpcomglue.so libplds4.so
defaults greprefs libmozjs.so libxpcom.so
dependentlibs.list javaxpcom.jar libnspr4.so libxul.so

/usr/lib/xulrunner-1.9.1/:
chrome libmozjs.so reportbug-helper-script xulrunner
components libxpcom.so res xulrunner-bin
defaults libxul.so run-mozilla.sh xulrunner-stub
dictionaries modules update.locale
greprefs mozilla-xremote-client updater
icons platform.ini xpcshell

Je vais encore manger mon chapeau !
C'est la même chose ? avec plus ou moins de détails ? il me faudrait deux paires de lunettes.

Je m'épuise captain, je te suis dans le brouillard. àd'tal.

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Bah, il y est pourtant ce fichier…

Que se passe-t-il si tu essayes de lancer directement

Code : Tout sélectionner

/usr/lib/xulrunner-1.9.1/xulrunner-stub
dans ton terminal ?

(Tu devrais avoir le message « Could not read application.ini »)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

eggregor
Intermédiaire
Intermédiaire
Messages : 228
Inscription : 23 sept. 2009 18:20

Re: Iceweasel ne se lance plus

Message par eggregor »

Comme tu dis :

[email protected]:~$ /usr/lib/xulrunner-1.9.1/xulrunner-stub
Could not read application.ini

Question subsidiaire captain cab, comme disent les chenilles zélées... eheheh :cartonnes: Pardon,

Si je t'envoie un scan de ma main, tu peux me lire l'avenir ?

Serait-on près du but ? Je sens çà comme çà.

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Iceweasel ne se lance plus

Message par captnfab »

Euh, on l'a dépassé le but là. ^^' Reste à revenir en arrière pour bien comprendre ce qu'il se passe.

Je reprends les étapes une par une :

1) Quand tu tapes « iceweasel » dans ton terminal. Ça devrait te lancer « /usr/bin/iceweasel ».
Vérifie ça en tapant « which iceweasel » dans un terminal.

2) « /usr/bin/iceweasel » est un lien vers « ../lib/iceweasel/iceweasel » donc « /usr/lib/iceweasel/iceweasel »

3) « /usr/lib/iceweasel/iceweasel » est un fichier bash qui va lancer « /usr/lib/iceweasel/firefox-bin »

4) Ce dernier étant un lien symbolique vers « ../xulrunner-1.9.1/xulrunner-stub », donc « /usr/lib/xulrunner-1.9.1/xulrunner-stub ».

« /usr/lib/xulrunner-1.9.1/xulrunner-stub » existe et est exécutable.

On dirait donc que
a) soit tu ne tapes pas « iceweasel » pour lancer firefox
b) soit tu as un autre iceweasel dans ton PATH.
c) soit je rate encore qqch :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

Répondre

Revenir à « Utilisation de GNU/Linux »