mount ne "mount" plus (Résolu)

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

eggregor

mount ne "mount" plus (Résolu)

par eggregor »

Bonjour à tous,
J'ai pas mal pédalé dans la sciure hier pour mettre les menus de Sid en français.
J'avais fait la moitié du chemin et je me suis dit qu'il fallait en finir.
(dpkg-reconfigure ne s'exécutait pas complètement)
Voilà pour info n°1 :
La question étant "[email protected] ne devrait-elle pas être LANG=POSIX" ?
# locale
[email protected]
LC_CTYPE="[email protected]"
LC_NUMERIC="[email protected]"
LC_TIME="[email protected]"
LC_COLLATE="[email protected]"
LC_MONETARY="[email protected]"
LC_MESSAGES="[email protected]"
LC_PAPER="[email protected]"
LC_NAME="[email protected]"
LC_ADDRESS="[email protected]"
LC_TELEPHONE="[email protected]"
LC_MEASUREMENT="[email protected]"
LC_IDENTIFICATION="[email protected]"
LC_ALL=

Je vous montre çà, parce que comme c'est la seule modif que j'ai apportée, je la soupçonne d'être pour quelquechose dans le problème "mount".
Donc info n°2:
# mount
/dev/sda8 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/sda6 on /home type ext3 (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sdf1 on /media/disk type fuseblk (rw,allow_other,blksize=4096)
/dev/sdf2 on /media/backup type fuseblk (rw,allow_other,blksize=4096)

D'où il ressort que les deux partitions de mon disque dur externe sdf1 et sdf2 sont apparemment "montées" sur /media/disk et /backup.

Mais pour autant, je ne peux plus ni les lire, ni ajouter quoique ce soit dessus.
Il y a bien sur le bureau les icônes des partitions existantes, mais plus d'icônes des partitions montées.

J'ai fait umount et (re)mount et çà ne change rien.
Info n°3 :
# cd /media/disk
debian:/media/disk# ls -l
total 54577
-rwxrwxrwx 2 root root 651276 janv. 9 2008 13404 formulaire déclarations travaux.pdf
-rwxrwxrwx 2 root root 826845 nov. 7 2007 13406 demande PC.pdf
-rwxrwxrwx 1 root root 707574 nov. 5 2008 13409PC.pdf
-rwxrwxrwx 2 root root 1268617 nov. 7 2007 51190 notice PC.pdf
drwxrwxrwx 1 root root 4096 mars 12 2009 Aix les bains
-rwxrwxrwx 2 root root 392 mai 4 2005 Anciens documents Excel.lnk
drwxrwxrwx 1 root root 36864 oct. 9 16:02 été 2009

Je ne rapporte pas tous les fichiers, mais ce qui apparait qui n'apparaissait pas avant, c'est l'interprétation du (é) de "déclaration" et "été 2009".
Je sais que j'ai le défaut de mettre des accents dans les noms de fichiers ( jamais dans un terminal), mais jusqu'ici çà n'empêchait pas de monter une partition, puisque ces noms de fichier existent depuis deux ans pour certains.

Par contre, celà voudrait-il dire qu'en modifiant les "locales", j'ai modifié involontairement le "language system" et que çà interprète mal les commandes ?

Je pense que çà doit se règler en deux coups de cuiller en bois, mais j'ose pas me lancer, si vous avez un conseil ?

En attendant je vais faire un bonhomme de neige. PDT_040
Dernière modification par eggregor le 17 déc. 2009 14:44, modifié 1 fois.
captnfab

Re: mount ne "mount" plus

par captnfab »

Plop Eggregor,

Euh, je ne sais pas si ça va tout régler, mais déjà, change les locales en fr_FR.UTF-8 avec un "sudo dpkg-reconfigure locales".

Si le dpkg-reconfigure ne fonctionne pas, donne nous le message d'erreur. :)
eggregor

Re: mount ne "mount" plus

par eggregor »

replop captain,

# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "[email protected]"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
Generation complete.

# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
[email protected]
LC_CTYPE="[email protected]"
LC_NUMERIC="[email protected]"
LC_TIME="[email protected]"
LC_COLLATE="[email protected]"
LC_MONETARY="[email protected]"
LC_MESSAGES="[email protected]o"
LC_PAPER="[email protected]"
LC_NAME="[email protected]"
LC_ADDRESS="[email protected]"
LC_TELEPHONE="[email protected]"
LC_MEASUREMENT="[email protected]"
LC_IDENTIFICATION="[email protected]"
LC_ALL=

En fait il doit y avoir un truc que je ne sais pas faire :
dpkg-reconfigure locales ouvre comme tu le sais une petite fenêtre avec une liste "en bleu".
Je descends jusqu'aux "fr"
Là je trouve
[ ] fr_FR.UTF-8 UTF-8
[*] [email protected] ISO-8859-15
Et pas moyen de décocher la 2ème ligne, c'est idiot mais je ne trouve pas comment faire.
Pour y parvenir, je suis obligé d'éditer le fichier /etc/locale.gen et d'ajouter # à[email protected] en le retirant à UTF8.

Toutefois çà ne change pas la réponse à la commande "locale" comme tu peux le voir, et le dpkg-reconfigure ramène immédiatement le message bourré d'erreur, qui était devenu mon problème, quand hier j'ai pris le taureau par les cornes, wharf !

Ce "setting locale failed" allant jusqu'à bloquer les upgrades avec constamment une message "perl: warning:.... etc"

Pour mémoire, si je coche/décoche en éditant /etc/locale.gen voilà le résultat de dpkg-reconfigure :

debian:/home/eggregor# dpkg-reconfigure locales
Generating locales (this might take a while)...
fr_FR.UTF-8... done
Generation complete.

Il y a bien "génération de quelquechose"
Ensuite, le résultat de locale reste identique, gardant les trois premières lignes(*) que je n'avais plus hier.
et "[email protected] euro" reste toujours au pouvoir.

# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
[email protected]
LC_CTYPE="[email protected]"
LC_NUMERIC="[email protected]"
LC_TIME="[email protected]"
LC_COLLATE="[email protected]"
LC_MONETARY="[email protected]"
LC_MESSAGES="[email protected]"
LC_PAPER="[email protected]"
LC_NAME="[email protected]"
LC_ADDRESS="[email protected]"
LC_TELEPHONE="[email protected]"
LC_MEASUREMENT="[email protected]"
LC_IDENTIFICATION="[email protected]"
LC_ALL=

(*) pour preuve le "locale" de mon premier message qui donnait un résultat sans les 3 lignes d'alerte !

D'ailleurs je me demande comment j'en étais arrivé à çà !!!
eggregor

Re: mount ne "mount" plus

par eggregor »

rereplop,

J'ai pris le temps de déjeuner et en refaisant tout de suite :

debian:/home/eggregor# locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

La machine travaille toute seule dans mon dos, je vais voir si çà change le mount : NON

Ce n'est peut-être pas un pb de locale finalement ?

J'observe que sur la Sid 32 bits, le résultat de loacle est strictement le même.

J'oubliais :

# cd /media/disk
debian:/media/disk# ls -l
total 54577
-rwxrwxrwx 2 root root 651276 janv. 9 2008 13404 formulaire déclarations travaux.pdf
-rwxrwxrwx 2 root root 826845 nov. 7 2007 13406 demande PC.pdf
-rwxrwxrwx 1 root root 707574 nov. 5 2008 13409PC.pdf
-rwxrwxrwx 2 root root 1268617 nov. 7 2007 51190 notice PC.pdf
drwxrwxrwx 1 root root 4096 mars 12 2009 Aix les bains

Au moins les noms de fichiers ont repris la bonne couleur.
eggregor

Re: mount ne "mount" plus (Résolu)

par eggregor »

Pataglop captain,

Je mets résolu.
En fait l'idée m'est venue de faire un reboot et mes partitions sont revenues à de meilleurs sentiments.

C'est bien le choix [email protected] qui a créé ce cirque du montage.

Et je m'y attendais d'autant moins que j'ai lu un tuto de la documentation Debian ( configurer les applications pour le français) qui ne mettait aucune alerte sur cette norme.

Contentt en tout cas de t'avoir retrouvé à la barre, et donc à plus si une nouvelle aventure me guette.
captnfab

Re: mount ne "mount" plus (Résolu)

par captnfab »

Hop, bien :)

Le [email protected] ne doit plus être utilisé. C'est une ancienne norme datant d'avant l'UTF-8 compatible uniquement avec les pays de l'occident. fr_FR.UTF-8 est compatible avec bien plus de monde et est aujourd'hui l'encodage recommandé pour les systèmes français. De plus, l'utf-8 reconnaît l'ancien iso-8859-11 (utilisé par [email protected]) alors que le contraire n'est pas vrai.

Bref, passe en fr_FR.UTF-8.

:)
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Revenir à « Utilisation de GNU/Linux »