[Résolu]Installation Impossible VM Win8.1 avec VirtualBox

Vous n'arrivez pas à faire ce que vous voulez ? Vous avez un problème avec un logiciel ou son installation ?

Modérateur : Mods GNU/Linux

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

[Résolu]Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 13 août 2014 09:02

Bonjour,

Précédemment dans une autre message, j'avais eux un problème pour créer une VM, que j'ai réussi à résoudre.

Maintenant que le HDD virtuel est bien crée, je n'arrive pas à installer Windows 8.1Pro via un fichier ISO, j'obtiens systématiquement un message d'erreur :

Image

en plus de cela, après plusieurs essaies d'installation, je finis par avoir un crash de VirtualBox:

le rapport étant beaucoup trop long, je met un lien externe : http://cjoint.com/?DHniSqf0agv

J'ai aussi ce message :
La virtualisation matérielle VT-x/AMD-V n'est pas disponible sur votre système. Certains invités (comme OS/2 ou QNX) nécessitent cette fonctionnalité pour pouvoir démarrer.
hors dans les paramètres de la VM, onglet Accélération, j'ai pas accès à ce réglage, l'onglet est grisé, d'autre part j'ai vérifié dans le BIOS si ce paramètre était activé, ce qui est le cas (je croyais que cela correspondait à Vanderpool Technologie). Donc retour case départ.

La seule façon d'installer la VM Windows 8.1Pro, c'est d'utiliser VMware-Player
La pas de problème d'installation, mais des difficultés dans l'utilisation (ralentissements, lags, blocages), j'ai pourtant mis 1024Mo de mémoire, mais par exemple le lancement de Firefox, plante (il n'y a que 4 extensions, Adblock Plus, NoScript, All in one Sidebar, The Addon Bar (Restorer)), si je jette un œil dans le Gestionnaire des Taches, je peux constater, que le processeur tourne à 100% , alors qu'il n'y a aucun soucis pour la mémoire utilisée (très bas)
La VM installé, aux vues des problèmes qu'il y a, est quasiment inutilisable.

Le processeur du PC hôte est un Intel E6600, j'ai 2,5Go de RAM.

Merci d'avance à ceux qui prendront le temps de me lire, et qui pourront m'aider et/ou me conseiller pour résoudre si possible mon problème.

@+
Dernière édition par Wullfk le 14 août 2014 10:58, édité 3 fois.


"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com


Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 13 août 2014 10:40

Pour vérifier que mon PC supporte bien la virtualisation, j'ai lancé via un terminal la commande suivante (pour proc Intel):

Code : Tout sélectionner

grep --color vmx /proc/cpuinfo
résultat:

Code : Tout sélectionner

wullfk@UbuntuLTS:~$ grep --color vmx /proc/cpuinfo
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow
manip effectuée, d'après les infos recueilli sur le site de Korben : http://korben.info/installer-windows-8- ... e-pas.html

d'après ce qui est dit:
Vous devrez voir alors vmx ou svm s'afficher en couleur. Si c'est le cas, c'est bon, votre processeur supporte la virtualisation. Sinon, c'est mort, vous n'avez plus qu'à changer de machine.
chez moi vmx est affiché en rouge, donc c'est censé être OK, mais cela ne fonctionne pas pour autant.

++
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 13 août 2014 12:04

Toujours concernant l'erreur:

Code : Tout sélectionner

Your PC needs to restart.
Please hold down the power button.
Error code: 0x000000C4
Parameters:
0×0000000000000091
0x000000000000000F
0xFFFFF801E5962A80
0×0000000000000000
J'ai tenté cette manip trouvé sur le forum Ubuntu : http://forum.ubuntu-fr.org/viewtopic.php?id=1314441

Qui consiste via un terminal, de saisir cette commande:

Code : Tout sélectionner

VBoxManage setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1
en remplaçant vmname par le nom de ma VM
ne sachant pas de quel nom il s'agissait exactement, celui du répertoire de la VM qui se nome chez moi : VM Windows 8.1Pro, ou celui du HDD virtuel (format VMDK=VMware) = Windows 8.1PRO

voila le résultat retourné avec le nom du répertoire de la VM ou le fichier .vbox du même nom::

Code : Tout sélectionner

wullfk@UbuntuLTS:~$ VBoxManage setextradata [VM Windows 8.1Pro] VBoxInternal/CPUM/CMPXCHG16B 1
VBoxManage: error: Could not find a registered machine named '[VM'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 804 of file VBoxManageMisc.cpp
et avec le nom du disque dur virtuel .VMDK:

Code : Tout sélectionner

wullfk@UbuntuLTS:~$ VBoxManage setextradata [Windows 8.1PRO] VBoxInternal/CPUM/CMPXCHG16B 1
VBoxManage: error: Could not find a registered machine named '[Windows'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 804 of file VBoxManageMisc.cpp
J'ai pas mis l'extension .VMDK , de toute façon c'est le même résultat

il doit certainement y avoir une erreur dans la commande, mais je sais pas laquelle. ou peut être faut-il se mettre dans le répertoire de VirtualBox pour quelle soit prise en compte, mais je ne sais pas comment faire.

qu'est ce que cela veut dire "faire un man VBoxManage" ? dixit ce qu'il y a d'indiqué dans le topic du forum Ubuntu.
Du coup j'en ai profité pour ré-ouvrir la discussion, en exposant mon cas identique.

cette commande fait suite à celle qui existe déjà pour Windows :

Code : Tout sélectionner

"c:\Program Files\Oracle\VirtualBox\VBoxManage.exe" setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1
++
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 13 août 2014 19:33

Ne sachant quoi faire d'autre, j'ai posté un message sur le forum Virtualbox.org : https://forums.virtualbox.org/viewtopic ... 40#p296240

Ce qui ma été proposé, je l'ai déjà vérifié 3 fois; vérification de l'activation VT-x dans le BIOS

On verra bien la suite....
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 13 août 2014 23:14

Bon d'après mes recherches, et la conversation sur le forum VirtualBox.org, Je pense que c'est rappé pour l'installation d'une VM Windows 8.1Pro sur ma config ou j'ai Ubuntu, car dans le BIOS je ne trouve plus/pas l'option VT-x qui doit être activée pour Windows 8 et 8.1 j'en déduit donc que c'est pas compatible et que je ne peux pas l'installer.
La référence de ma carte mère : ASUS P5B DELUXE Rev.1.03G (BIOS 1226) Chipset P965

Pour ce qui est de la config Windows 7Pro 64bits, la référence de la CM : ASUS MAXIMUS EXTREME (BIOS 1302) Chipset X38 j'ose plus me prononcé sur l'éventualité de la présence ou pas de l'option VT-x
Si ça se trouve elle aussi n'est pas compatible pour une virtualisation Windows 8 ou 8.1

Tous ceci me donne envie de me refaire une nouvelle config à base d'I7 (mais pas les moyens financiers pour le moment)

++
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com


Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: Installation Impossible VM Win8.1 avec VirtualBox

Message par Wullfk » 14 août 2014 10:53

J'ai parcouru, toute la documentation des deux cartes mère, et nul part il est fait mention de VT-x

Donc, je confirme que mes deux configs ne sont pas compatible pour une virtualisation de Windows 8 ou 8.1

Je considère le sujet comme résolu, bien que le résultat final ne joue pas en ma faveur.

Salut
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: [Résolu]Installation Impossible VM Win8.1 avec VirtualBo

Message par Wullfk » 14 août 2014 15:28

Rectification, la virtualisation est possible sur mes deux configs.

Tout ce passe dans mes deux BIOS (sur chaque PC)
Il suffisait d'activer Vanderpool Technology qui correspond à VT-x

J'ai pas encore effectué la manip sur ma config Ubuntu, mais je sais que l'option est présente.
Pour l'instant j'ai installer la VM Windows 8.1Pro sur ma config Windows 7 car j'ai plus de marge au niveau processeur (Quad Core Q9550)
sur Ubuntu je ferais l'installation une autre fois.

bien content d'avoir résolu positivement le problème.

Salut
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Avatar de l’utilisateur
Wullfk
Geek à longue barbe
Geek à longue barbe
Messages : 685
Inscription : 28 avr. 2010 20:16
Localisation : en sortant première à gauche
Contact :

Re: [Résolu]Installation Impossible VM Win8.1 avec VirtualBo

Message par Wullfk » 15 août 2014 12:41

Pour ce qui est de ma config Ubuntu, je me suis réjouis un peu trop vite.
l'option Vanderpool Technology existe bien dans le BIOS, mais j'en n'ai pas l'accès, la zone est grisé, et de plus elle est bien désactivée.

c'est pas de bol.
"L'expérience est le nom que l'on donne à ses erreurs" ~ Oscar Wilde ~
Blogs: http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com


Répondre

Revenir vers « Utilisation de GNU/Linux »