Page 1 sur 2

flash player sous debian (resolu retour sous ubuntu)

Publié : 07 avr. 2014 11:47
par chef
bonjour,
je n'arrive pas a mettre a jour flash player sous chromium avec debian , j'ai bien essayer ceci mais rien a faire , il veut pas .
http://www.commentcamarche.net/faq/1419 ... ous-debian

voici l'erreur
root@jeje-EasyNote-TV44HC:/home/jeremy# gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C
gpg: demande de la clef 16BA136C sur le serveur hkp subkeys.pgp.net
gpg: /root/.gnupg/trustdb.gpg : base de confiance créée
gpg: clef 16BA136C : clef publique « Backports.org Archive Key <ftp-master@backports.org> » importée
gpg: aucune clef de confiance ultime n'a été trouvée
gpg: Quantité totale traitée : 1
gpg: importées : 1
root@jeje-EasyNote-TV44HC:/home/jeremy# gpg --export | apt-key add -
OK
root@jeje-EasyNote-TV44HC:/home/jeremy# aptitude update
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Prendre : 1 http://ftp.fr.debian.org wheezy-updates Release.gpg [836 B]
Atteint http://ftp.fr.debian.org wheezy Release
Atteint http://security.debian.org wheezy/updates Release.gpg
Prendre : 2 http://ftp.fr.debian.org wheezy-updates Release [124 kB]
Atteint http://security.debian.org wheezy/updates Release
Atteint http://security.debian.org wheezy/updates/main Sources
Atteint http://security.debian.org wheezy/updates/contrib Sources
Atteint http://security.debian.org wheezy/updates/non-free Sources
Atteint http://ftp.fr.debian.org wheezy/main Sources
Atteint http://security.debian.org wheezy/updates/main amd64 Packages
Atteint http://ftp.fr.debian.org wheezy/main amd64 Packages
Atteint http://security.debian.org wheezy/updates/contrib amd64 Packages
Atteint http://security.debian.org wheezy/updates/non-free amd64 Packages
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr
Atteint http://security.debian.org wheezy/updates/contrib Translation-en
Atteint http://ftp.fr.debian.org wheezy/main Translation-en
Atteint http://security.debian.org wheezy/updates/main Translation-en
Prendre : 3 http://ftp.fr.debian.org wheezy-updates/main Sources [4 057 B]
Atteint http://security.debian.org wheezy/updates/non-free Translation-en
Ignoré http://www.backports.org etch-backports Release.gpg
Prendre : 4 http://ftp.fr.debian.org wheezy-updates/contrib Sources [14 B]
Prendre : 5 http://ftp.fr.debian.org wheezy-updates/non-free Sources [14 B]
Ignoré http://www.backports.org lenny-backports Release.gpg
Atteint http://ftp.fr.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Prendre : 6 http://ftp.fr.debian.org wheezy-updates/contrib amd64 Packages [14 B]
Prendre : 7 http://ftp.fr.debian.org wheezy-updates/non-free amd64 Packages [14 B]
Ignoré http://www.backports.org etch-backports Release
Prendre : 8 http://ftp.fr.debian.org wheezy-updates/contrib Translation-en [14 B]
Atteint http://ftp.fr.debian.org wheezy-updates/main Translation-en/DiffIndex
Prendre : 9 http://ftp.fr.debian.org wheezy-updates/non-free Translation-en [14 B]
Ignoré http://www.backports.org lenny-backports Release
Erreur http://www.backports.org etch-backports/main amd64 Packages
404 Not Found [IP : 5.153.231.4 80]
Erreur http://www.backports.org etch-backports/contrib amd64 Packages
404 Not Found [IP : 5.153.231.4 80]
Ignoré http://www.backports.org etch-backports/contrib Translation-fr_FR
Ignoré http://www.backports.org etch-backports/contrib Translation-fr
Ignoré http://www.backports.org etch-backports/contrib Translation-en
Ignoré http://www.backports.org etch-backports/main Translation-fr_FR
Ignoré http://www.backports.org etch-backports/main Translation-fr
Ignoré http://www.backports.org etch-backports/main Translation-en
Erreur http://www.backports.org lenny-backports/main amd64 Packages
404 Not Found [IP : 5.153.231.4 80]
Erreur http://www.backports.org lenny-backports/contrib amd64 Packages
404 Not Found [IP : 5.153.231.4 80]
Ignoré http://www.backports.org lenny-backports/contrib Translation-fr_FR
Ignoré http://www.backports.org lenny-backports/contrib Translation-fr
Ignoré http://www.backports.org lenny-backports/contrib Translation-en
Ignoré http://www.backports.org lenny-backports/main Translation-fr_FR
Ignoré http://www.backports.org lenny-backports/main Translation-fr
Ignoré http://www.backports.org lenny-backports/main Translation-en
129 ko téléchargés en 18s (6 989 o/s)
W: impossible de récupérer http://www.backports.org/debian/dists/e ... 4/Packages : 404 Not Found [IP : 5.153.231.4 80]
W: impossible de récupérer http://www.backports.org/debian/dists/e ... 4/Packages : 404 Not Found [IP : 5.153.231.4 80]
W: impossible de récupérer http://www.backports.org/debian/dists/l ... 4/Packages : 404 Not Found [IP : 5.153.231.4 80]
W: impossible de récupérer http://www.backports.org/debian/dists/l ... 4/Packages : 404 Not Found [IP : 5.153.231.4 80]
E: Échec du téléchargement pour certains fichiers d'index. Soit ils ont été ignorés, soit les anciens fichiers ont été utilisés à la place.
E: Impossible de reconstruire le cache des paquets

root@jeje-EasyNote-TV44HC:/home/jeremy# aptitude install flashplugin-nonfree
Pas de version candidate trouvée pour flashplugin-nonfree
Pas de version candidate trouvée pour flashplugin-nonfree
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

Re: flash player sous debian

Publié : 07 avr. 2014 11:56
par captnfab
Salut Chef,

Comme tu sais peut-être, Adobe ne mets plus à jour flash pour Linux. Le seul moyen d'avoir une version à jour de Flash est donc d'utiliser chrome ou chromium, avec le plugin flash pour chrome.

Pour ce faire, il te faut installer chromium et le paquet pepperflashplugin-nonfree depuis les backports.

Je t'invite à consulter cette page pour comprendre un peut mieux comment ajouter les backports et de manière générale, comprendre ce que tu dois trouver dans ton sources.list : https://wiki.debian-facile.org/doc:syst ... ts-mozilla

De plus, pour les infos Debian, je te conseille de te référer au site officiel http://wiki.debian.org/ ou au wiki et au forum Debian-Facile http://debian-facile.org http://wiki.debian-facile.org/

Re: flash player sous debian

Publié : 07 avr. 2014 12:22
par angelique
captnfab est spécialiste , je rajoute une question lol

il est dans des dépots (pas officiel ! ) http://www.deb-multimedia.org/pool/non- ... sh-player/

Image


Moi je met pas flash !! mais ça marche pas comme ça captnfab ????


---------------------


angel@debian:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 NETINST Binary-1 20131215-03:38]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 NETINST Binary-1 20131215-03:38]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main


# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main

## DEBIAN MULTIMEDIA
deb http://www.deb-multimedia.org stable main non-free
deb-src http://www.deb-multimedia.org stable main non-free

Re: flash player sous debian

Publié : 07 avr. 2014 12:38
par chef
re,
du coup il faut que j'installe celui la pour chromium ?

Re: flash player sous debian

Publié : 07 avr. 2014 12:47
par chef
c'est bon je sais pas comment j'ai fais pour installer flash player PDT_009 , mais sa marche même pour chromium PDT_006

Re: flash player sous debian

Publié : 07 avr. 2014 14:37
par captnfab
@angelique: c'est la version 11 de Flash ça. Qui ne sera pas mise à jour. Et de plus, nul besoin d'aller chez deb-multimedia puisque tout est dans debian section non-free (flashplugin-nonfree).

@chef: je te conseille tout de même de nettoyer ton fichier sources.list en regardant le lien que je t'ai donné. Parce qu'au vu des messages d'erreur, y'a du nettoyage à faire :)

Re: flash player sous debian

Publié : 07 avr. 2014 14:49
par angelique
@angelique: c'est la version 11 de Flash ça. Qui ne sera pas mise à jour. Et de plus, nul besoin d'aller chez deb-multimedia puisque tout est dans debian section non-free (flashplugin-nonfree).
bah je l'ai pas dans mon gestionnaire de paquet Synaptic lol

Re: flash player sous debian

Publié : 07 avr. 2014 15:00
par captnfab
c'est parce que tu ne dois pas avoir activé les dépôts contrib, voir le lien vers le sources.list donné plus haut :)

Re: flash player sous debian

Publié : 07 avr. 2014 17:14
par chef
captnfab a écrit :
@chef: je te conseille tout de même de nettoyer ton fichier sources.list en regardant le lien que je t'ai donné. Parce qu'au vu des messages d'erreur, y'a du nettoyage à faire :)
bon ben je voudrais bien , mais je n'y arrive pas , et même pour modifier mon fichier sources.list il veut pas il me dit que j'ai pas les droits !!!!
je voulais le modifier en mettant que ceci :

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian stable main contrib non-free

deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free
mais pas moyen

car moi j'ai ça

Code : Tout sélectionner

deb http://ftp.fr.debian.org/debian/ wheezy contrib non-free main
deb-src http://ftp.fr.debian.org/debian/ wheezy contrib non-free main

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates contrib non-free main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates contrib non-free main
deb http://www.backports.org/debian etch-backports main contrib
deb http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main contrib non-free
deb http://www.deb-multimedia.org stable main non-free
deb-src http://www.deb-multimedia.org stable main non-free
deb http://www.backports.org/debian lenny-backports main contrib

Re: flash player sous debian

Publié : 07 avr. 2014 17:32
par angelique
il faut lancer ton editeur texte en tant que root , exemple

Image

Re: flash player sous debian

Publié : 07 avr. 2014 17:52
par chef
je voudrais bien mais il me dit :
bash: /etc/apt/sources.list.save: Permission non accordée

Re: flash player sous debian

Publié : 07 avr. 2014 17:54
par angelique
c'est pas sources.list.save mais sources.list

attention dangeureux , avec prudence Alt+F2 et tape gksu thunar

tu seras root sur tout le systeme de fichier, casse pas tout lol

Re: flash player sous debian

Publié : 07 avr. 2014 17:56
par chef
bash: /etc/apt/sources.list: Aucun fichier ou dossier de ce type
cela dit quand je suis le chemin mon fichier et bien nommé sources.list.save
edit ok vu

Re: flash player sous debian

Publié : 07 avr. 2014 18:01
par angelique
angel@debian:~$ su
Mot de passe :
root@debian:/home/angel# cd /etc/apt
root@debian:/etc/apt# ls -a
. apt.conf.d preferences.d sources.list~ sources.list.save trusted.gpg trusted.gpg.d
.. listchanges.conf sources.list sources.list.d trustdb.gpg trusted.gpg~
root@debian:/etc/apt# cat sources.list
#

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 NETINST Binary-1 20131215-03:38]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 NETINST Binary-1 20131215-03:38]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main


# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main



bah je l'ai bien , passe par gksu thunar

Re: flash player sous debian

Publié : 07 avr. 2014 18:07
par chef
il me dit :
gksu thunar

(gksu:17318): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Erreur GConf : Aucun service D-BUS en cours d'exécution


(gksu:17318): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Erreur GConf : Aucun service D-BUS en cours d'exécution


(gksu:17318): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Erreur GConf : Aucun service D-BUS en cours d'exécution

je pense que je vais réinstallé plus simple lol