Pas de son dans les écouteurs

Votre carte vidéo, carte son, imprimante n'est pas reconnue ?

Modérateur : Mods GNU/Linux

Avatar de l’utilisateur
Lætitia
Geek à longue barbe
Geek à longue barbe
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen
Contact :

Re: Pas de son dans les écouteurs

Message par Lætitia » 27 déc. 2012 15:31

salut,
pour alsamixer, tu as encore des entrées sur la droite. Tu devrais agrandir la fenêtre du terminal. Tant que tu as des > sur le bord, tu as encore des infos masquées.
Mais bon, ça ne fera pas avancer ton souci. Ce qui me gêne, c'est que tu as déjà réussi une fois à avoir le son. Ce qui veut dire qu'il suffit de trouver le bon réglage dans "son" et "alsamixer" voire "pulseaudio"

Tu ouvres le son et dans les réglages, tu as un truc du genre?
Image
Quand tu branches les écouteurs, ça devient comme ça :
Image

Autre question, as-tu installé pavucontrol. Il sert à configurer pulseaudio-usine_a_gaz.

@+

Avatar de l’utilisateur
dds69
Intermédiaire Expert
Intermédiaire Expert
Messages : 256
Inscription : 22 janv. 2008 22:20

Re: Pas de son dans les écouteurs

Message par dds69 » 27 déc. 2012 18:52

Bonjour,

Quand je branche mes écouteurs j'ai les mêmes options que toi sauf que le problème il ne passe pas d'une sortie à l'autre.

je vais tester pavucontrol

edit : cela ne change pas grand chose :(

Avatar de l’utilisateur
Lætitia
Geek à longue barbe
Geek à longue barbe
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen
Contact :

Re: Pas de son dans les écouteurs

Message par Lætitia » 27 déc. 2012 22:30

salut,
dans pavucontrol, tu as bien headphone dans les périph de sortie? Le son n'est pas en muet dans la fenêtre Son>Sortie>casque analogique.

C'est quoi ton modèle de PC, marque, référence…? On peut essayer de bricoler alsa-base.conf. Mais, il doit y avoir quelque chose que tu as fait une fois pour avoir le son. Je sais bien que la sorcellerie d'angel est super puissante, mais quand même. :D

@+

EDIT
dis voir, sur la capture alsamixer, c'est la carte HDMI. Va voir en changeant de carte en appuyant sur F6. Et agrandis ton terminal pour voir les entrées qui sont à droite.
Et aussi

Code : Tout sélectionner

lspci|grep -i audio

Avatar de l’utilisateur
dds69
Intermédiaire Expert
Intermédiaire Expert
Messages : 256
Inscription : 22 janv. 2008 22:20

Re: Pas de son dans les écouteurs

Message par dds69 » 30 déc. 2012 20:00

j'ai même plus de son quand je branche les écouteurs et que je change pour me mettre sur la sortie des écouteurs -_-

Avatar de l’utilisateur
Lætitia
Geek à longue barbe
Geek à longue barbe
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen
Contact :

Re: Pas de son dans les écouteurs

Message par Lætitia » 02 janv. 2013 00:37

salut et bonne année,
alors tu vas brancher tes écouteurs et tu vas aller dans alsa. Tu vas sur headphone et tu mets en mute en appuyant sur le "m", tu vas voir un MM. Tu vérifies si tu as du son.
Si tu n'en as pas, à la fin du fichier "/etc/modprobe.d/alsa-base.conf" tu vas ajouter :

Code : Tout sélectionner

option snd-intel-hda model=generic
et tu restart alsa

Code : Tout sélectionner

sudo /sbin/alsa-utils reset & sudo /sbin/alsa-utils restart
tu me dis quoi, @+

Avatar de l’utilisateur
dds69
Intermédiaire Expert
Intermédiaire Expert
Messages : 256
Inscription : 22 janv. 2008 22:20

Re: Pas de son dans les écouteurs

Message par dds69 » 03 janv. 2013 21:45

Bonsoir et bonne année :D

Après avoir fait les manipulations, toujours rien :(

cordialement

dds69

Avatar de l’utilisateur
Lætitia
Geek à longue barbe
Geek à longue barbe
Messages : 2068
Inscription : 28 août 2008 15:53
Localisation : près Rouen
Contact :

Re: Pas de son dans les écouteurs

Message par Lætitia » 06 janv. 2013 22:19

salut,
bonne année à toi aussi :)

Question con : tes écouteurs fonctionnent bien?
dds69 a écrit : ce matin en rallumant mon ordinateur le son fonctionner dans les écouteurs -_- donc je ne sais pas si c'est suite aux modifs demandées par angélique ou trouvé sur le forum ubuntu mais en tout cas ça marche.
Te souviens-tu de la manip que tu avais faite? C'est sûrement un réglage tout bête. Enfin bon…

Avatar de l’utilisateur
dds69
Intermédiaire Expert
Intermédiaire Expert
Messages : 256
Inscription : 22 janv. 2008 22:20

Re: Pas de son dans les écouteurs

Message par dds69 » 07 janv. 2013 22:16

Bonsoir,

je me rappelle avoir mis des ppa mais par la suite je les ai enlever car ils posaient soucis pour faire les mis à jours

Avatar de l’utilisateur
captnfab
Geek à longue barbe
Geek à longue barbe
Messages : 2292
Inscription : 31 mai 2008 22:03
Localisation : Aubenas (07), Montpellier (34)
Contact :

Re: Pas de son dans les écouteurs

Message par captnfab » 11 janv. 2013 10:05

Yo,

Plusieurs pistes :
- Les pilotes récents ajoutent l'option « Auto-mute » dans alsamixer. Je vois que c'est le cas chez toi.
L'idée derrière « auto-mute », quand ça marche bien, c'est de couper le son des haut-parleurs lorsque l'on branche le casque.
On peut naviguer entre les diverses valeurs d'auto-mute avec flèche du haut et flèche du bas.
À ta place, je désactiverais l'auto-mute sur la sortie hdmi et je l'activerais sur la carte son.

- Changer de version du noyau / des modules son.
Il est possible que ta carte son soit récente, et que le module contenant le pilote de ta carte son ne soit pas à jour dans la version de ton noyau installée. Tu peux soit essayer d'installer une version plus récente du noyau, soit essayer de recompiler une version plus récente des modules alsa.

Je n'aurai pas le temps de te guider le long de ces pistes, mais j'espère que ça t'aidera à avancer :)
Capitaine Fab (captnfab), Girafe à longues dents.
Liens utiles et nécessaires : Avant de poster, consultez les règles du forum || Débutants : la FAQ Linux
Entraide Debian : Documentation Debian-Facile || Forum DF || [url=irc://irc.freenode.net/debian-facile]Salon IRC : #debian-facile @ irc.freenode.net[/url]

Avatar de l’utilisateur
dds69
Intermédiaire Expert
Intermédiaire Expert
Messages : 256
Inscription : 22 janv. 2008 22:20

Re: Pas de son dans les écouteurs

Message par dds69 » 11 janv. 2013 15:22

Bonjour à tous,

Suite aux manipulations que j'ai effectué hier soir (voir ce lien) le son est revenue dans mes écouteurs et quand je branche mes écouteurs il fait la transaction.

Cependant tout n'est pas parfait (utopie quand tu nous tiens) au niveau graphique la transaction ne se fait pas.
1356614944.png
Le changement ne se fait pas à ce niveau. Mais bon si ce n'est que ça :D

a+

Répondre

Revenir vers « Configuration du matériel sous GNU/Linux »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité