Page 1 sur 1

Problèmes pour boot sur linux mint (mode efi)

Publié : 22 févr. 2017 20:42
par artaga
Bonsoir,
Je découvre linux et je souhaite l'installer en parallèle de windows 8 sur un toshiba (avec mode uefi).
J'ai installé linux Mint mais je n'arrive pas à boot dessus windows se lance directement.
Je me suis un peu renseigné sur internet et entre autres :
https://www.lifewire.com/fix-uefi-bootl ... ng-2200655

J'ai alors démarré Mint en live USB pour exécuter :
sudo apt-get install efiboot mgr
sudo efitbootmgr

Ce qui me renvoie :
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.

Je suis bloqué à ce stade. J'ai cru comprendre que le mode EFI posait un peu problème y-a-t-il un moyen de résoudre cela ?

Re: Problèmes pour boot sur linux mint (mode efi)

Publié : 23 févr. 2017 16:06
par nam1962
Essaye de désactiver le secure-boot dans le bios !

Re: Problèmes pour boot sur linux mint (mode efi)

Publié : 23 févr. 2017 16:09
par artaga
Bon, j'ai trouvé ce qui ne fonctionnait pas : le boot ne se faisait pas en mode uefi dès le démarrage.
Pour une raison que j'ignore le live USB que j'avais créé avec LinuxLive USB Creator ne se lançait pas lorsque le pc était en mode UEFI.

J'ai donc repris l'installation de Mint à l'aide des tutoriels suivants :
https://forums.linuxmint.com/viewtopic.php?t=201455
et de sa version mise à jour en anglais.
Puis j'ai monté l'image ISO avec unetbootin sur une clé usb et j'ai refait l'installation sans encombre.

Mon PC est bien en dual-boot windows 8.1 / Linux Mints désormais ! En espérant que ce fail puisse en aider d'autres.

Re: Problèmes pour boot sur linux mint (mode efi)

Publié : 23 févr. 2017 16:11
par artaga
Je viens de mettre à jour le post ^^
Le secure-boot était bien une condition nécessaire !